Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Kubuntu 12.04 - installed updates and Grub4Dos boot menu no longer appears


  • Please log in to reply
13 replies to this topic

#1 Al1000

Al1000

  • Global Moderator
  • 7,405 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:39 AM

Posted 03 July 2014 - 12:05 PM

Hi,

The computer notified me that updates were available, and said that at least some of them were ''important security updates,'' and I just installed the lot. But now when I start up or reboot the computer, it boots straight into Kubuntu and the Grub4Dos menu does not appear.

I have a separate boot partition on sda1, and Kubuntu is installed on sda7. I had thought that the BIOS should automatically boot from sda1, and nothing seems to have changed there:

snapshotKubuntu2_zps81e85051.jpeg

I guess one option that would probably work would be to delete the existing Grub4Dos boot files and run the program again, so that it would automatically overwrite whatever boot files the computer is now using. But it would be nice to know what exactly happened when I updated it, where whatever boot files its now using are located and if I can edit them manually, and why it doesn't seem to be booting from sda1.

Any advice much appreciated.

Edited by Al1000, 03 July 2014 - 12:05 PM.


BC AdBot (Login to Remove)

 


#2 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,736 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:03:39 PM

Posted 05 July 2014 - 04:23 AM

Try this.

 

grub2 - Restoring Grub after Kubuntu installation - Ask Ubuntu

Edited by NickAu1, 05 July 2014 - 04:47 AM.


#3 Al1000

Al1000
  • Topic Starter

  • Global Moderator
  • 7,405 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:39 AM

Posted 05 July 2014 - 05:01 AM

Thanks for the link. I am just after running Grub4Dos again. I backed up the menu.lst file first of all, then deleted the new one that was created when I ran Grub4Dos and replaced it with the back up, and I now have the menu back just as it was before. :) I briefly looked into using Grub and Grub Legacy 2013 as they are also both on Puppy, found that they have been superseded by Grub2, and wasn't sure if the ''standard version'' of Grub2 would detect frugal installations of Puppy as the bootloaders that come with Puppy do, so decided just to stick with Grub4Dos in the meantime since I know how to use it and it does the job.

#4 Kaosu

Kaosu

  • Members
  • 173 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:39 AM

Posted 08 July 2014 - 09:39 PM

Thanks for the link. I am just after running Grub4Dos again. I backed up the menu.lst file first of all, then deleted the new one that was created when I ran Grub4Dos and replaced it with the back up, and I now have the menu back just as it was before. :) I briefly looked into using Grub and Grub Legacy 2013 as they are also both on Puppy, found that they have been superseded by Grub2, and wasn't sure if the ''standard version'' of Grub2 would detect frugal installations of Puppy as the bootloaders that come with Puppy do, so decided just to stick with Grub4Dos in the meantime since I know how to use it and it does the job.

 

Sorry, I never noticed this thread until now. Your solution of backing up your menu.lst and reinstalling the bootloader is exactly what I would have recommended. Also, if you ever do want to use Grub2 with frugal installations of Puppy, it is pretty easy to configure.

 

I recommend just sticking to Grub4Dos since that is what works well for you. This is just additional information in case you ever needed to use Grub2.

 

1) open /etc/grub.d/40_custom

sudo nano /etc/grub.d/40_custom

2) Create a new menu entry

menuentry "Puppy Linux 5.3.3 (frugal on sda5)" {
set root='(hd0,4)'
search --no-floppy --fs-uuid --set 2C20-6100
linux /slacko5.3.3frugal/vmlinuz pmedia=atahd psubdir=slacko5.3.3frugal
initrd /slacko5.3.3frugal/initrd.gz
}

[+] Replace menuentry Puppy Linux 5.3.3 (frugal on sda5) with whatever text you want to show up at the selection screen

[+] Replace set root='(hd0,4)' with the correct partition information

[+] Replace search --no-floppy --fs-uuid --set 2C20-6100  with the UUID of the correct disk

[+] Replace linux /slacko5.3.3frugal/vmlinuz pmedia=atahd psubdir=slacko5.3.3frugal with the correct directory information

[+] Replace initrd /slacko5.3.3frugal/initrd.gz with the correct directory information

 

Tip: Only modify what is highlighted in red.

 

 

For more information about Grub2:

 

http://puppylinux.org/wikka/Grub2

https://help.ubuntu.com/community/Grub2

http://www.gnu.org/software/grub/manual/grub.html


Edited by Kaosu, 09 July 2014 - 03:10 AM.


#5 Al1000

Al1000
  • Topic Starter

  • Global Moderator
  • 7,405 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:39 AM

Posted 09 July 2014 - 10:13 AM

Many thanks for all that info. I'm still trying to get my head around Grub4Dos and will stick with it for the meantime, but that will all come in handy when I try Grub2.

 

I'm having a minor issue booting into Kubuntu 14.04 using Grub4Dos on my desktop pc, and wonder if it has something to do with menu.lst. Kubuntu works fine, but instead of displaying the usual icons while booting up before the log-in screen appears, a bunch of text scrolls down the screen. That in itself I don't mind, but I found the following error:

al@al-System-Product-Name:~$ grep error /var/log/dmesg
[   16.022639] EXT4-fs (sda7): re-mounted. Opts: errors=remount-ro

... and this is what I have in menu.lst:

title Kubuntu 14.04 LTS (sda7)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /vmlinuz root=/dev/sda7 ro
initrd /initrd.img

I tried deleting ''ro'' from menu.lst because the error message mentions it, but that didn't make any difference, so I assume it's superfluous.

 

When I previously had Ubuntu 12.04 installed, the text that Grub4Dos wrote wouldn't boot into it at all; so I asked on the Ubuntu forum and someone posted this:

title Ubuntu-12.04-sda7
root (hd0,6)
kernel /boot/grub/core.img
#savedefault
####boot

After pasting that into menu.lst, when I selected Ubuntu from the Grub4Dos boot menu, it took me to the original (Grub2?) boot menu that Ubuntu had installed. I liked that configuration since although it took slightly longer to boot up, as I had two menus to deal with instead of just one, it gave me access to the other options on the menu.

Also, before pasting that text into menu.lst, I was able to boot into Ubuntu by selecting ''find Grub2'' from the Grub4Dos Advanced Options menu, where it similarly took me to the original boot menu. But selecting that option now that I have Kubuntu 14.04, it doesn't find the original boot menu, and I'm not sure why.

What (I think) I would ideally like to have is the same configuration as I had with Ubuntu, where selecting Kubuntu from the Grub4Dos menu would take me to the boot menu that Kubuntu installed. Failing that, I am wondering if I should try to get rid of this error message.


Edited by Al1000, 10 July 2014 - 07:16 AM.


#6 Kaosu

Kaosu

  • Members
  • 173 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:39 AM

Posted 09 July 2014 - 08:39 PM

Many thanks for all that info. I'm still trying to get my head around Grub4Dos and will stick with it for the meantime, but that will all come in handy when I try Grub2.

 

I'm having a minor issue booting into Kubuntu 14.04 using Grub4Dos, and wonder if it has something to do with menu.lst. Kubuntu works fine, but instead of displaying the usual icons while booting up before the log-in screen appears, a bunch of text scrolls down the screen. That in itself I don't mind, but I found the following error:

al@al-System-Product-Name:~$ grep error /var/log/dmesg
[   16.022639] EXT4-fs (sda7): re-mounted. Opts: errors=remount-ro

 

This is normal activity and not really an error.

 

During the normal boot process your root partition will be mounted as read-only to protect the filesystem. Once the boot process has finished, it will re-mount the partition so it can be used by the running installation. The message you're seeing is just part of the normal boot process and is basically saying: "sda7 was remounted after boot. Sda7 will remount as read-only if any filesystem errors are detected", which also allows you to still have access to the partition if a filesystem error does occur, since it will be mounted as read-only.

 

 

... and this is what I have in menu.lst:

title Kubuntu 14.04 LTS (sda7)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /vmlinuz root=/dev/sda7 ro
initrd /initrd.img

I tried deleting ''ro'' from menu.lst because the error message mentions it, but that didn't make any difference, so I assume it's superfluous.

 

The "ro" kernel paramater will just mount root as read-only during the boot process. Removing it wouldn't have suppressed the "error" message, because it isn't an error to begin with, and most distributions will remount the partition anyway. I would add this paramater back to ensure my filesystem was being protected during the boot process.

 

You should try this entry and see if your loading icons come back:

title Kubuntu 14.04 LTS (sda7)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /vmlinuz root=/dev/sda7 ro quiet splash
initrd /initrd.img

This will hopefully bring back your pretty splash screen.

 

 

When I previously had Ubuntu 12.04 installed, the text that Grub4Dos wrote wouldn't boot into it at all; so I asked on the Ubuntu forum and someone posted this:
title Ubuntu-12.04-sda7
root (hd0,6)
kernel /boot/grub/core.img
#savedefault
####boot

After pasting that into menu.lst, when I selected Ubuntu from the Grub4Dos boot menu, it took me to the original (Grub2?) boot menu that Ubuntu had installed. I liked that configuration since although it took slightly longer to boot up, as I had two menus to deal with instead of just one, it gave me access to the other options on the menu.

Also, before pasting that text into menu.lst, I was able to boot into Ubuntu by selecting ''find Grub2'' from the Grub4Dos Advanced Options menu, where it similarly took me to the original boot menu. But selecting that option now that I have Kubuntu 14.04, it doesn't find the original boot menu, and I'm not sure why.

What (I think) I would ideally like to have is the same configuration as I had with Ubuntu, where selecting Kubuntu from the Grub4Dos menu would take me to the boot menu that Kubuntu installed. Failing that, I am wondering if I should try to get rid of this error message.

 

Yes, that menu entry is just booting Grub2 instead of the Linux kernel. This is why you go straight to the boot menu that is configured by Kubuntu.

 

Try the following entry and see if you have better luck:

title Kubuntu 14.04 (Grub2)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /boot/grub/core.img

If you're still unable to boot into Grub2 with this entry, verify that you're pointing the entry to the correct partition.


Edited by Kaosu, 09 July 2014 - 09:23 PM.


#7 Al1000

Al1000
  • Topic Starter

  • Global Moderator
  • 7,405 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:39 AM

Posted 10 July 2014 - 06:54 AM

Many thanks again. I had only just discovered the ''grep error'' command; have now also run it on my laptop and sure enough it reports the same ''error.''

 

I hadn't even previously reailsed what ''ro'' means. I typed it back in, and adding ''quiet splash'' did the trick as the icons now display as expected. :)

 

I tried:

title Kubuntu 14.04 (Grub2)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /boot/grub/core.img

... but it results in the following error:

 

Booting into Kubuntu 14.04 (Grub2)

setting root to (hd0,6)

Filesystem is ext 2fs, partition type 0x83

kernel /boot/grub/core.img

Error 15: File not found

 

 

(I copied that using pen and paper, so can't guarantee the accuracy of the spacings)

 

I'm not sure why it says filesystem is ext 2fs, as the partition is ext4, but I've noticed it says the same when booting into Puppy which is on an ext3 partition.

 

Here are the entire contents of menu.lst, with the script that didn't work commented out:

 

# menu.lst produced by grub4dosconfig-v1.9.1
color white/blue black/cyan white/black cyan/black
#splashimage=/splash.xpm
timeout 10
default 0

# Frugal installed Puppy

title Lucid Puppy 5.2.8.6 (sda5)
  uuid 82bc42e3-0685-436d-849b-7f59dcd7c617
  kernel /Lucid/vmlinuz   psubdir=Lucid pmedia=atahd pfix=fsck
  initrd /Lucid/initrd.gz

title Arcade Puppy 11 (sda5)
  uuid 82bc42e3-0685-436d-849b-7f59dcd7c617
  kernel /arcadepuppy/vmlinuz   psubdir=arcadepuppy pmedia=atahd pfix=fsck
  initrd /arcadepuppy/initrd.gz

# Full installed Linux

# title Kubuntu 14.04 (Grub2)
# uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
# kernel /boot/grub/core.img

title Kubuntu 14.04 LTS (sda7)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /vmlinuz root=/dev/sda7 ro quiet splash
initrd /initrd.img

# Windows
# this entry searches Windows on the HDD and boot it up
title Windows\nBoot up Windows if installed
  errorcheck off
  find --set-root --ignore-floppies --ignore-cd  /bootmgr
  chainloader /bootmgr
  find --set-root --ignore-floppies --ignore-cd  /ntldr
  chainloader /ntldr
  find --set-root --ignore-floppies --ignore-cd   /io.sys
  chainloader /io.sys
  errorcheck on

# Advanced Menu
title Advanced menu
  configfile /menu-advanced.lst
  commandline

 

 

I take it that ''uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6'' would be the correct partition, since it's the same in the script that does work as in the script that doesn't.

 

This is how I have the HDD partitioned:

 

drives1_zps6b134a22.jpg



#8 Al1000

Al1000
  • Topic Starter

  • Global Moderator
  • 7,405 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:39 AM

Posted 10 July 2014 - 07:08 AM

I am now wondering if perhaps I selected a different option when I ran Grub4Dos after installing Ubuntu12.04, than I did when I ran it after installing Kubuntu 14.04, possibly concerning overwriting the Grub2 files?



#9 Kaosu

Kaosu

  • Members
  • 173 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:39 AM

Posted 10 July 2014 - 06:44 PM

Many thanks again. I had only just discovered the ''grep error'' command; have now also run it on my laptop and sure enough it reports the same ''error.''

 

I hadn't even previously reailsed what ''ro'' means. I typed it back in, and adding ''quiet splash'' did the trick as the icons now display as expected. :)

 

I tried:

title Kubuntu 14.04 (Grub2)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /boot/grub/core.img

... but it results in the following error:

 

Booting into Kubuntu 14.04 (Grub2)

setting root to (hd0,6)

Filesystem is ext 2fs, partition type 0x83

kernel /boot/grub/core.img

Error 15: File not found

 

 

(I copied that using pen and paper, so can't guarantee the accuracy of the spacings)

 

I'm not sure why it says filesystem is ext 2fs, as the partition is ext4, but I've noticed it says the same when booting into Puppy which is on an ext3 partition.

 


 

 

The kernel seems to use the same type code of 0x83 for most supported filesystems. I don't know enough about Grub4Dos to give any hard answers, but I believe it is just scanning type codes and then returning the first result, which happens to be ext2. You have nothing to worry about.

 

The partition to point to depends on how you installed Kubuntu. By default, it should create everything but swap on one single partition. If that is the case, you should be pointing it to the correct partition and it just isn't finding your grub files. However, if it installed to a new or existing boot partition, then that is the partition you will want to point the menu entry to. You should boot up into Kubuntu and locate the grub files. Once you have manually located the grub files, you will at least know what partition they are located on and the correct directory structure. For example, if they are located in /boot/grub/x64/ instead of /boot/grub then that would cause it to fail.

 

If the grub files happen to be damaged or deleted, make a backup of your Grub4Dos files then reinstall Grub2 and make a backup of the /boot/grub directory. Once completed, you can just reinstall Grub4Dos and put all of the required files back in the correct locations.

 

We won't really know more until you do a little manual exploring and verify that /boot/grub/ is the correct directory, core.img is the correct filename, and they are located on the correct partition.


Edited by Kaosu, 10 July 2014 - 06:45 PM.


#10 Al1000

Al1000
  • Topic Starter

  • Global Moderator
  • 7,405 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:39 AM

Posted 11 July 2014 - 06:30 PM

Thanks for the info re ext2.

 

/boot/grub is on the same partition as Kubuntu.

al@al-System-Product-Name:/boot/grub$ ls
fonts  gfxblacklist.txt  grub.cfg  grubenv  i386-pc  locale

There is a file called core.img in /boot/grub/i386-pc

 

So I guess I should try changing ''kernel /boot/grub/core.img'' to ''kernel /boot/grub/i386-pc/core.img'' in menu.lst



#11 Kaosu

Kaosu

  • Members
  • 173 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:39 AM

Posted 11 July 2014 - 06:58 PM

Thanks for the info re ext2.

 

/boot/grub is on the same partition as Kubuntu.

al@al-System-Product-Name:/boot/grub$ ls
fonts  gfxblacklist.txt  grub.cfg  grubenv  i386-pc  locale

There is a file called core.img in /boot/grub/i386-pc

 

So I guess I should try changing ''kernel /boot/grub/core.img'' to ''kernel /boot/grub/i386-pc/core.img'' in menu.lst

 

Yes, that should fix the issue.

title Kubuntu 14.04 (Grub2)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /boot/grub/i386-pc/core.img

Come back and let me know if we have solved all of your bootloader issues.



#12 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 12,736 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:03:39 PM

Posted 11 July 2014 - 06:59 PM

Off Topic a bit.

 

Al you are really picking this stuff up fast, Wasn't it you who bet me 1 that Linux  wouldn't   boot on his pc,,, 2  That puppy linux retro wouldn't work with your wifi only a few short months ago?

 

Good on you, You are a great  example of what somebody can do and that its not that hard to learn Linux.



#13 Al1000

Al1000
  • Topic Starter

  • Global Moderator
  • 7,405 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:39 AM

Posted 12 July 2014 - 07:59 AM

 

Thanks for the info re ext2.

 

/boot/grub is on the same partition as Kubuntu.

al@al-System-Product-Name:/boot/grub$ ls
fonts  gfxblacklist.txt  grub.cfg  grubenv  i386-pc  locale

There is a file called core.img in /boot/grub/i386-pc

 

So I guess I should try changing ''kernel /boot/grub/core.img'' to ''kernel /boot/grub/i386-pc/core.img'' in menu.lst

 

Yes, that should fix the issue.

title Kubuntu 14.04 (Grub2)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /boot/grub/i386-pc/core.img

Come back and let me know if we have solved all of your bootloader issues.

 

 

That solved the problem! Thanks again for all your help.

 

I couldn't decide which I wanted to use, so kept:

title Kubuntu 14.04 LTS (sda7)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /vmlinuz root=/dev/sda7 ro quiet splash
initrd /initrd.img

..in menu.lst to boot straight into Kubuntu from there, and put:

title Kubuntu 14.04 LTS (Grub2)
uuid 4c93117c-8286-4e4a-916e-02ccecb01bc6
kernel /boot/grub/i386-pc/core.img

..into advanced-menu.lst, which finds the Grub2 boot menu from there.

 

Your explanations are invaluable. While any help is helpful, taking the time to explain what causes things to happen enables me to be able to fix them myself. I suppose it's a bit like the difference between giving someone a fish, and teaching them to fish.

 

So now I'll go and do the same with Kubuntu 12.04 on my laptop. :)



#14 Al1000

Al1000
  • Topic Starter

  • Global Moderator
  • 7,405 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:06:39 AM

Posted 12 July 2014 - 08:17 AM

Off Topic a bit.

 

Al you are really picking this stuff up fast, Wasn't it you who bet me 1 that Linux  wouldn't   boot on his pc,,, 2  That puppy linux retro wouldn't work with your wifi only a few short months ago?

 

Good on you, You are a great  example of what somebody can do and that its not that hard to learn Linux.

 

Thanks Nick. I'm not sure who that was but it wasn't me. I initially joined this forum, which was the first computer forum I had ever joined (although I have since joined a few others), to find a live OS that would boot my old laptop. All I wanted to do was manually remove a folder containing some malware I had inadvertantly downloaded (but fortunately hadn't installed) while downloading an old and now freeware version of Command & Conquer. The folder containing the malware wouldn't let me access it, and neither the anti-virus software nor MoveOnBoot would shift it either. Knoppix was the only live OS I had heard of at that point in time, and I assumed the reason it wouldn't boot my laptop was because its 768MB of RAM wasn't enough. and that I needed a smaller live OS. That was when I discovered Puppy, which unlike Knoppix which is slow and clunky because it has to keep loading files from the CD, ran the laptop better than XP! So there was no going back from there.

 

I had been considering moving to Linux with the end of support for XP approaching anyway, and had had Ubuntu 12.04 installed as a dual-boot with XP for a couple of months by then on my desktop pc. But I didn't use it much as I found it hard to navigate and didn't like the desktop, and it had other issues which I now reailse were due to the HDD beginning to fail although I didn't know that at the time.

 

I have also always been keen on keeping software to a minimum which is one reason I like Puppy, as it does so much with so little. Now I find the same is true with the Linux Terminal. For instance I was initially surprised that Kubuntu didn't appear to include a file search application, and had planned on installing one, until I discovered ''find'' in the terminal. That is exactly the sort of thing I like; a way to do more, with less software. :)


Edited by Al1000, 12 July 2014 - 08:20 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users