Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Skyrim: Visual C++ crashing for no reason (some Spoilers)


  • Please log in to reply
No replies to this topic

#1 Benie

Benie

  • Members
  • 29 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:18 AM

Posted 02 July 2014 - 11:23 PM

So, hi there. I used to be in the PC Tech Support area trying to fix a serious BSOD. Finally got that out. Now, we talk about a specific game called Skyrim.
I got this game through Steam, a few years ago for the full asking price(because dragons). Anyway, for over a month, I have been plaqued by a pesky, random, rage and depression-inducing error, called a Visual C++ error. Namely this annoying thing.
 
This is what I know about the error, from the past to now (warning, spoilers);
-Can happen at anytime, any place, making it impossible to track down.
-Doesn't matter what mods I have.
-Doesn't matter on the load order, if I use LOOT or not.
-Doesn't matter if Visual C++ is installed on my computer or not.
-Doesn't matter if the master files are cleaned or not.
-Doesn't matter if I do the bugged Soul Carin quest or not.
-Has nothing to do with my PC Specs, or what I do for Skyrim's video settings.
-No Memory patches, mods, and tweaks I've installed, worked to fix it and the CTDs.
-The crashes don't affect my saves, allowing me to bypass where it crashed... only to crash later on.
-It only happens in this game (haven't tested other games that use Visual C++).
-Crashes in areas it never crashed before(now it's crashing in the Dragonborn questline...).
-Doesn't seem to matter if I use a Bashed Patch or not.
 
Here's what I've done in my failed quest to find and kill the source of the crash;
-Reinstalled Skyrim clean(three times), wiped out all mods and saves. Even used an uninstaller called Revo Uninstaller Pro.
-Have verified the integrity(multiple times), yet I keep getting "1 file failed to validate" everytime I try.
-Have tried to install mods one by one, but due to the unpredictable nature of the crashes, it's hard to tell which (if any) mods are causing it.
-Uninstalled and reinstalled Visual C++ 2010, both the x86 and x64 versions.
-Uninstalled all Visual C++ versions from 2005 to 2013 from my computer in a desperate move to fix.
-Scanned for viruses with Spybot - Search and Destroy and Windows Security Essentials(set to do a full scan every Monday Evening).
-Cleaned my computer/registry with CCleaner(what was assumed to be the culprit).
-Defragged my hard drives.
-Have cleaned the master files and any mods in need of dirty edit cleaning with TES5EDIT.
-Have ran the Skyrim Save Script Cleaner on my latest saves.
-Using the Unofficial Patches (these are confirmed not the source).
-I'm caught up with all important/recommended Windows Updates.
-Tried the patch in SKSE(latest version) in the ini by adding those three lines.
 
Recently, I did these;
-Ran System File Checker to see if the registry was corrupted. Did 5 scans with Windows booted and 5 scans before Windows booted. All were clean.
-Did a Check Disk on all drives. No help.
-Did a completely clean mod-free playthrough. Still happened.
-Did a clean reinstall of Windows.
 
Now, I had thought the Windows reinstall got it. I played through all three questlines, no CTD, no Visual C++ crash. The people over on the Steam forums were pretty sure it was registry corruption.

 

Then I tried to install mods again using Mod Organizer (used to use NMM). In the Skyrim playthrough, I got 4 random CTDs, but nothing all that severe. I thought "they're just mod-related. Expect it!" No Visual C++ crashes.
Did the Dawnguard questline. No CTDs. No Visual C++ crashes. At this point, I was pretty convinced I got it.
Did the Dragonborn questline... BAM. Visual C++ crash in the Temple of Mirrak.
 
Due to my " :ranting: " ranting, I haven't tried to check if it would happen again. If it would just be a one-time crash. Or just require another freakin' playthough of all questlines with no mods (again).

But I have done 10+ playthroughs already, to the point I remember exactly where to go, and how to react to each situation..., and I'm sick of playing the questlines!

I was hoping to do the entire playthough... one. more. time(with the mods I currently have), then feel like I can finally "retire" in Lakeview Manor with my wife and two adopted human kids for the rest of my Skyrim life. I would be happy.

But noooo. :nono:  The Visual C++ crash cares less for my happiness. It doesn't care how much money I handed over to Steam for the DLCs. It serves to annoy me for the rest of my life, laughing and saying " :hysterical:! You still didn't fix me yet! :devil: " . It continues to defy all logical reasons to the cause of the error. And defies all attempts to fix it! <_<
 
At this point, I need a miracle. Which is why I come here, praying you guys will tell me something simple like flicking a switch that I didn't do to stop this madness. Or at least, recommend me to a forum that would help me (and not the Steam Forums or the Steam Community. I came from there, and the Skyrim Nexus forum).

 

I'd paste my Load Order and DxDiag, but I don't see a way to add attachments. There is no attachments window. I can at least give my specs;

 

OS: Windows 7 x64 SP 1 (latest Windows updates)

CPU: AMD Phenom FX 4350

GPU: EVGA GeForce GTX 750 Ti (latest drivers)

Sound: Intergrated

RAM: 8GB DDR-3


Edited by Benie, 03 July 2014 - 12:11 AM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users