Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 7 Drops Internet when it sleeps


  • Please log in to reply
10 replies to this topic

#1 Hal06

Hal06

  • Members
  • 880 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York, New York, USA
  • Local time:07:35 AM

Posted 29 June 2014 - 07:40 AM

Hello. New computer running Windows 7. When I step away from the computer for too long it goes into sleep mode. I have to reenter the password and reconnect to my home wifi. Is there any way to prevent it from disconnecting to the internet when it goes into sleep mode?

 

Thanks.



BC AdBot (Login to Remove)

 


m

#2 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:35 AM

Posted 29 June 2014 - 10:46 AM

That's probably a power-saving option that's been enabled. Try disabling it:

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/wireless-devise-disconnects-every-time-computer/2d4bd3af-ef13-4d2c-97e8-7e80080d8816



#3 Hal06

Hal06
  • Topic Starter

  • Members
  • 880 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York, New York, USA
  • Local time:07:35 AM

Posted 29 June 2014 - 01:36 PM

Thanks.



#4 Hal06

Hal06
  • Topic Starter

  • Members
  • 880 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York, New York, USA
  • Local time:07:35 AM

Posted 06 July 2014 - 07:42 AM

So I disabled the power saving module a few days ago. Now it's disconecting again. Very annoying!



#5 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:35 PM

Posted 06 July 2014 - 08:02 AM

Can you check if your laptop has Advanced Power Settings - Wireless Adapter? Do you use the recommended power settings? Post also the computer model next time please. See also your network adapter properties by device manager and Power Management tab and toggle checking/uncheck the  Allow computer... box.

djlZ60N.jpg

This is from an HP Power Plan Advanced settings.


Tekken
 


#6 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:35 AM

Posted 06 July 2014 - 10:33 AM

If jhayz's suggestion still doesn't fix it, go back to each (Network Connections and Device Manager) and make sure the computer isn't reverting those back to the old settings. It may be a case where the driver needs to be updated. You'll then have to go the wireless device maker's website and install the latest drivers.



#7 Hal06

Hal06
  • Topic Starter

  • Members
  • 880 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York, New York, USA
  • Local time:07:35 AM

Posted 28 July 2014 - 02:35 PM

Could it be a problem with the router? It's rather old.



#8 sflatechguy

sflatechguy

  • BC Advisor
  • 2,164 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:35 AM

Posted 28 July 2014 - 02:44 PM

Do you ever get disconnected from the WiFi while the computer is running and not in sleep mode? If not, it's definitely a problem on the computer.

 

When a computer goes to sleep, it basically shuts down everything except the keyboard and the mouse. This would include shutting down the WiFi adapter. Are you using a built-in WiFi adapter, or a USB WiFi connector? If you are using a USB connector, go into Control Panel>Power Options>Edit Plan settings, and disable the USB suspend setting.

 

You might also want to just disable sleep mode.



#9 Datcoolguy

Datcoolguy

  • Members
  • 303 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:35 AM

Posted 28 July 2014 - 05:29 PM

As noted above when a computer goes to sleep it shuts down all non essencial hardware, such as Wi Fi adapters, wich means that when it comes back from sleep and turns the adapter back on it'll have to reconnect to the Wi Fi network again, you can disable sleep entirelly if it's just annoying you, but either way you can also set up your computer to connect back to the wifi automatically without you having to enter the password every time.


"If you don't understand how your computer works, you shouldn't be messing with it!"


#10 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:35 PM

Posted 29 July 2014 - 07:27 PM

Please post the router and computer model if the problem is not yet resolved after following the suggestions from sflatechguy and Datcoolguy. :thumbup2:


Tekken
 


#11 Hal06

Hal06
  • Topic Starter

  • Members
  • 880 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York, New York, USA
  • Local time:07:35 AM

Posted 06 August 2014 - 04:08 PM

So the computer has not slept in days, nor been powered down. I'm installing an online backup system and it seems to take A VERY long time to perform the first backup. I suppose I'll see if the wifi problem is still present once the backup is complete and the computer starts sleeping again.

 

Thanks for the help.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users