Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

It's Programs Files (x86) all the way down...


  • Please log in to reply
5 replies to this topic

#1 ishist

ishist

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:11:16 AM

Posted 28 June 2014 - 03:08 AM

I've had this issue for over a year and I can't seem to nail down the cause. Now it's interfering with program installations due to long files names.

 

With some programs, during installation, regardless of the default or custom install location chosen, the program tries to install to a Program Files (x86) folder with in a Program Files (x86) folder within...etc.

 

I have an SSD for my OS and a large HDD for everything else. A few years ago I attempted to change the default install location in the registry using some online tutorial. Shortly afterwords I found out that Windows doesn't like that at all, so I changed it back. I'm not certain if this is the cause of the problem I'm having but it seems relevant.

 

I'm using Windows 7 Pro 64.

 

I'm attaching a picture of the address bar showing the problem as I've had other attempts of receiving assistance met with overwhelming confusion.

 

Thank you for any help.

 

Attached File  Programfilesissue.jpeg   20.3KB   0 downloads  

 

edit just in case: Some of the affected installations are Adobe Reader and Razer Synapse 2.0


Edited by ishist, 28 June 2014 - 03:10 AM.


BC AdBot (Login to Remove)

 


m

#2 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,230 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:02:16 AM

Posted 28 June 2014 - 03:20 AM

It certainly appears you have broken it... You are a great example of why one should not mess with the registry when they don't understand it.

 

Not that I don't feel sorry for you.

 

TsVk!

 

(edit: not that it is not fixable either, if you can direct us directly to your modifications)


Edited by TsVk!, 28 June 2014 - 03:52 AM.


#3 ishist

ishist
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:11:16 AM

Posted 28 June 2014 - 04:17 AM

In writing out my problem and reading your response I may have stumbled on the solution. I went back and triple checked the values for ProgramFilesDir and ProgramFilesDir (x86) and found that when I changed them back I'd put C:\ instead of C:\Program Files. I tested by installing Adobe Reader and it installed to the correct location. That isn't definitive obviously, but I'll spend a few days installing and reinstalling some programs to see if I can reproduce the problem.

 

Thank you for your assistance and reminder of the perils of tinkering in your registry. I'll reply if the problem reappears.



#4 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,230 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:02:16 AM

Posted 28 June 2014 - 04:20 AM

It's all in the details with registry editing. :thumbsup2:



#5 scotty_ncc1701

scotty_ncc1701

  • Members
  • 520 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:16 PM

Posted 28 June 2014 - 11:35 AM

I had the same issue in Windows 7, but not as bad as you screen cap shows.

See if this helps.

http://stackoverflow.com/questions/6913784/multiple-layers-of-application-data-folders-windows7

http://answers.microsoft.com/en-us/windows/forum/windows_7-files/multiple-occurances-of-same-file/ac11fe50-e945-e011-9577-d485645a8348

Best of luck.



#6 ishist

ishist
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Local time:11:16 AM

Posted 29 June 2014 - 01:32 PM

Looks like my self-congratulations was a bit premature. Could someone specify exactly what information you would need to determine the problem?

 

Thanks! 

 

edit: added some obvious examples

 

Attached File  All The Way Down.jpg   39.26KB   0 downloads

 

Attached File  HKEY_LOCAL_MACHINE - SOFTWARE - Microsoft - Windows - CurrentVersion.jpg   65.51KB   0 downloads

 

Edit Again: just noticed the value for ProgramFilesDir is C:\Programs files. Sure hope I didn't do that.


Edited by ishist, 29 June 2014 - 01:49 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users