Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Unable to boot from "UEFI" stick


  • Please log in to reply
7 replies to this topic

#1 OS51

OS51

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:05:07 AM

Posted 27 June 2014 - 11:33 AM

Hello all.  So I have Tails Linux installed on a USB flashdrive.  I followed an online instruction about using Rufus and setting it for GPT UEFI filesystem but that did not work.  Here is my problem;

I use an Asus motherboard.  When I load the BIOS, it shows the Sandisk with "UEFI" noted next to it.  Like:  "UEFI:  Sandisk."  However, under the hard drive priorities, you can pick a device just called "Sandisk" and put it ahead of the real HDD in boot priority.

 

If the system tries to boot from this "UEFI" thing, it just skips it and goes to Windows.  If you hit the UEFI drive in the BIOS boot override menu, the screen goes black for a second, then the BIOS screen you were just on simply reappears.

 

Obviously I can dig into the BIOS and override to the Sandisk every time I want to boot this - but I was hoping for a way to be able to just plug the drive into the computer, restart, and find myself looking at Linux.  Is there a way I can make this happen?

 

Thanks,

-OS51



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,966 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:07 AM

Posted 27 June 2014 - 11:36 AM

If there is a Fastboot option in BIOS, disable that. You may have to disable Secure Boot also.



#3 OS51

OS51
  • Topic Starter

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:05:07 AM

Posted 27 June 2014 - 12:23 PM

If there is a Fastboot option in BIOS, disable that. You may have to disable Secure Boot also.

 

Just tried it; didn't work.  Thanks for the suggestion, though.

 

-OS51



#4 JohnC_21

JohnC_21

  • Members
  • 22,966 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:07 AM

Posted 27 June 2014 - 12:41 PM

I don't know what you are looking for with Tails but FatDog64 boots UEFI with SecureBoot enabled.

 

http://distro.ibiblio.org/fatdog/web/faqs/secure-boot.html

 

Edit: See if Tails can boot with Fastboot and SecureBoot disabled using Unetbootin.

 

Edit Edit: I would still have Secure Boot Disabled as I am not sure about removing the FatDog64 key once it is in place.


Edited by JohnC_21, 27 June 2014 - 12:50 PM.


#5 OS51

OS51
  • Topic Starter

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:05:07 AM

Posted 27 June 2014 - 01:33 PM

I don't know what you are looking for with Tails but FatDog64 boots UEFI with SecureBoot enabled.

 

http://distro.ibiblio.org/fatdog/web/faqs/secure-boot.html

 

Edit: See if Tails can boot with Fastboot and SecureBoot disabled using Unetbootin.

 

Edit Edit: I would still have Secure Boot Disabled as I am not sure about removing the FatDog64 key once it is in place.

 

Just tried Tails with UNetbootin with fastboot and secure boot disabled - no luck.  And yeah I need Tails and Tails specifically.

 

I don't understand why the device shows me this "UEFI: Sandisk" and then an additional "Sandisk" (without the UEFI tag) which it understands as a hard drive.  Much less do I understand why it finds it an impossible to task to boot from the flash drive.

 

-OS51



#6 JohnC_21

JohnC_21

  • Members
  • 22,966 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:07 AM

Posted 27 June 2014 - 01:42 PM

The only thing I can think of is to enable Legacy mode in BIOS if you have that option and then create a bootable USB flash drive using the MBR partition scheme in Rufus. If you do not have a Legacy mode then use Sandisk without the UEFI but use the MBR partition scheme in Rufus.

 

Since you already have Tails using Unetbootin, have you tried using Sandisk without the UEFI tag in BIOS?



#7 OS51

OS51
  • Topic Starter

  • Members
  • 96 posts
  • OFFLINE
  •  
  • Local time:05:07 AM

Posted 27 June 2014 - 08:31 PM

The only thing I can think of is to enable Legacy mode in BIOS if you have that option and then create a bootable USB flash drive using the MBR partition scheme in Rufus. If you do not have a Legacy mode then use Sandisk without the UEFI but use the MBR partition scheme in Rufus.

 

Since you already have Tails using Unetbootin, have you tried using Sandisk without the UEFI tag in BIOS?

 

I can use it without UEFI but then I have to enter BIOS and override to it anytime I want to use it - it's doable, all I'm asking about here is convenience.  It'd be nice to be able to just "plug and play" if you will.

 

-OS51



#8 JohnC_21

JohnC_21

  • Members
  • 22,966 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:07 AM

Posted 27 June 2014 - 09:18 PM

I found this. Seems Tails is still working on booting UEFI.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users