Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Remote Desktop help


  • Please log in to reply
10 replies to this topic

#1 brett222

brett222

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:09:49 PM

Posted 24 June 2014 - 04:40 PM

Hi!

I need some help setting up a remote desktop connection from within my lan. Here is my current setup.

 

I have enabled remote desktop connection under remote settings for any connection type.

I have disabled the firewall on both computers.

I have disabled avast on both computers, dont think it matters since I do not pay for the firewall feature.

I use at&t U verse router and I see no where in the settings to turn on or off remote desktop. I think that from within the lan all ports are open and functional.

 

Im really confused why this doesn't work.

 

Brett



BC AdBot (Login to Remove)

 


#2 scotty_ncc1701

scotty_ncc1701

  • Members
  • 520 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:49 AM

Posted 24 June 2014 - 04:53 PM

It's easier to use VNC, they have a free version for home use:  http://www.realvnc.com/download/

 

Basically, you install it on both machines, bring it up on computer 1, enter the other computer's name (e.g. computer2), and click connect.  The first time your firewall my ask if it is OK, allow it permanently, and you're in business.  You don't need to disable anything.  I use REALVNC all the time!

 

Best of luck.



#3 brett222

brett222
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:09:49 PM

Posted 24 June 2014 - 04:55 PM

I would like to currently stick with the Rdp since it is natively installed. I have used and do love vnc, but currently would like to stay with rdp.



#4 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,049 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:05:49 AM

Posted 24 June 2014 - 05:27 PM

Hi,

 

If you want to connect from the outside to one of your machines you need to port forward TCP port 3389 on the router.

 

For security reasons I recommend you change the default port to something else and make sure you setup strong passwords on the user accounts you will use for RDP, accounts with empty passwords will not connect.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#5 brett222

brett222
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:09:49 PM

Posted 24 June 2014 - 05:32 PM

Im currently just trying to get this to work from within the network. I eventually would like to do this from the outside, but I dont think that the Uverse router supports that.



#6 scotty_ncc1701

scotty_ncc1701

  • Members
  • 520 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:49 AM

Posted 24 June 2014 - 05:58 PM

I know you said you wanted to stick with RDP, but another alternative from the outside in would be Teamviewer.  You set up TV to accept unattended connections (my friend did this when he was in Europe).  Then login to the TV site, and you're in business.

 

Setting up teamviewer, as well as VNC is a breeze.

 

Best of luck.



#7 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,049 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:05:49 AM

Posted 25 June 2014 - 03:29 AM

Im currently just trying to get this to work from within the network. I eventually would like to do this from the outside, but I dont think that the Uverse router supports that.

 

On the internal network the U verse router doesn't affect anything.

- What exactly happens when you try to connect?

- Did you try to connect using the name and the IP of the other machine?


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#8 brett222

brett222
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:09:49 PM

Posted 30 June 2014 - 04:02 AM

Sorry for the slow reply... I didn't know that anyone posted...

When I try and connect the connection just times out asthough the computer was not found.

I have tried using the computer name and the ip address.

Even under the network display, It displays the computer and I can right click it and press connect remotely, but nothing works.



#9 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,049 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:05:49 AM

Posted 30 June 2014 - 04:11 AM

Sorry for the slow reply... I didn't know that anyone posted...

When I try and connect the connection just times out asthough the computer was not found.

I have tried using the computer name and the ip address.

Even under the network display, It displays the computer and I can right click it and press connect remotely, but nothing works.

 

If you open the Command Prompt and try the command ping followed_by_the_ip_address and ping followed_by_the_computer_name do you get a reply?


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 


#10 brett222

brett222
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:09:49 PM

Posted 30 June 2014 - 07:52 PM

they both ping each other ok.



#11 SleepyDude

SleepyDude

  • Malware Response Team
  • 3,049 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portugal
  • Local time:05:49 AM

Posted 01 July 2014 - 03:54 AM

Hi,

 

On the computer with the Remote Desktop enabled open the Command Prompt and type the following:

netstat  -an | findstr  3389

Tell me the result.


• Please do not PM me asking for support. Post on the forums instead it will increases the chances of getting help for your problem by one of us.
• Posts in the Malware section that are not replied to within 4 days will be closed. PM me or a moderator to reactivate.
• Please post your final results, good or bad. We like to know! Thank you!

 
Proud graduate of GeekU and member of UNITE
___
Rui

 
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users