Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

PC doesn't like static ip.


  • Please log in to reply
18 replies to this topic

#1 flickdog93

flickdog93

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Local time:08:00 AM

Posted 23 June 2014 - 01:50 PM

Every time I use a static IP for my desktop and it restarts it can't connect back to the internet. It gives me the error message that DHCP is disabled. That is the point of a static IP right?

 

My router automatically assigns IP addresses, but my desktop is set for a specific one so that I can run a Minecraft server and use the same IP. Every time I turn my computer off then back on. like if I shut it off one night then turn it back on later the next day, it'll give the caution symbol on the wifi indicator, I'll run the troubleshooter, it'll give me that DHCP error, then switch it back to applying IPs automatically.

 

It's a real pain having to setup the static IP every time my desktop restarts so is there any solution that I haven't tried already?


Edited by hamluis, 29 June 2014 - 08:02 AM.
Moved from Win 7 to Networking - Hamluis.


BC AdBot (Login to Remove)

 


m

#2 Kilroy

Kilroy

  • BC Advisor
  • 3,279 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:08:00 AM

Posted 23 June 2014 - 01:57 PM

Set up a DHCP reservation on the router for this machine.  When you are setting a static IP address it is recommended that it be outside of your DHCP assigned IP addresses.



#3 zingo156

zingo156

  • BC Advisor
  • 3,333 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:00 AM

Posted 23 June 2014 - 02:09 PM

As Kilroy mentioned, setup the static ip either outside of the DHCP range or reserve the ip. What is likely happening is when your machine is off, another computer or phone connects using that ip you manually set for your minecraft server. Then when your computer tries to connect with that static ip, it is denied since another computer/device holds the lease.

 

Don't forget to forward your ports for the new ip if you change it...


Edited by zingo156, 23 June 2014 - 02:09 PM.

If I am helping you with a problem and I have not responded within 48 hours please send me a PM.

#4 scotty_ncc1701

scotty_ncc1701

  • Members
  • 520 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:00 AM

Posted 23 June 2014 - 02:33 PM

It sounds like you haven't put in the DNS servers and/or the default gateway (router/modem IP) when you sat up your static IP.

Although there are different ways to get the info, just call your ISP, and ask for:

1.  Primary DNS Server address.
2.  Secondary DNS Server address.
3.  The default Gateway address for the router/modem.

Then when sitting up the static IP, use the above information.  That should in theory get you to work just fine.

Also, remember that if you have a Wi-Fi connection on the PC, and also a cable connection, you must individually set each up with an IP address.  Each adapter must have a unique IP address.  In windows 7 and 8, by default, if there is a wi-fi connection available and a cable connection available, the wi-fi takes precedence.  For online gaming, I don't recommend wi-fi.

 

I set up my wife's PC to have a static IP, using the information above, with no changes to the DHCP in the router/modem.  Finally, make sure that no other PC on your home network has the same IP address.  For static IP addresses, recommend that the last octet is > 100, just to insure no possibility of collision.  If your home network has more than 100 devices, I bow down to you! :bowdown:

 

I have a 34 port, CNet power switch I got from one of my jobs.  The network folks were just going to throw it out, and management gave me permission to take it home.  It's setting on the closet shelf now.  My home network has 3 devices (computers).

Best of luck!
========
Windows 7 and 8 by default uses a wireless connection if available.

There are three ways to force Windows 7 or 8 to use the a cable (Ethernet) connection.

1.  Method 1 - Disable the wireless, temporarily.
1.1.  In the case of my computer, I use the Fn+F12 key (it has an antenna on the key).
1.2.  Pressing this combo (or whatever your computer manufacturer uses), will disable the wireless for this session.  Once you reboot your computer, the wireless goes active again, and you have to repeat 1.1.

2. Method 2 - Change the priority.
2.1.  This method will make the cable (Ethernet) the priority.  As long as there's a cable attached, it will be the first one it will attempt to use.
2.2.  Procedure:
2.2.1.  Open the Control Panel.
2.2.2.  Go to Network and Sharing Center.
2.2.3.  Click on "Change Adapter settings".
2.2.4.  Press Alt Key - it will show the menubar.
2.2.5.  Click Menu - Advanced.
2.2.6.  Click Sub Menu - Advanced Settings.
2.2.7.  Most people will see this in the order listed here, in the top box:
2.2.7.1.  Wi-Fi.
2.2.7.2.  Ethernet.
2.2.8.  Click on Ethernet.
2.2.9.  Then click on the up arrow to the right of the box.  This makes the cable (Ethernet) the priority.
2.2.10.  Click OK.
2.2.11.  Reboot.

Now, your cable (Ethernet) will always be used if it's plugged in.  If you unplug it, then the Wireless will be used.

Method 3A - Disable the wireless all together.

3A.1.  This method will disable the wireless connection all together.
3A.2.  Procedure:
3A.2.1.  Open the Control Panel.
3A.2.2.  Go to Network and Sharing Center.
3A.2.3.  Click on "Change Adapter settings".
3A.2.4.  Right Click on the Wireless connection.
3A.2.5.  Click "Disable"
3A.2.6.  Reboot.

Method 3B - Enable the wireless all together.

3B.1.  This method will enable the wireless connection, after using method 3A.
3B.2.  Procedure:
3B.2.1.  Open the Control Panel.
3B.2.2.  Go to Network and Sharing Center.
3B.2.3.  Click on "Change Adapter settings".
3B.2.4.  Right Click on the Wireless connection.
3B.2.5.  Click "Enable"
3B.2.6.  Reboot.
========

 


Edited by scotty_ncc1701, 23 June 2014 - 02:40 PM.


#5 flickdog93

flickdog93
  • Topic Starter

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Local time:08:00 AM

Posted 23 June 2014 - 02:40 PM

OK, most of what y'all said is what I did, although I didn't setup the IP up to that range. I'm using 10.0.0.50 ATM. I have that IP reserved for my desktop's MAC address. I also have ethernet disabled so that only the wifi connects. (I'm on wifi bcause 1. the router is 20-30 feet down the hall 2. other people don't appreciate really long ethernet cables like I do 3. It's just me and my girlfriend on the server so I'm not exactly doing intense gaming that requires anything above wifi) I'll look into changing the IP to something above 50. It's just weird that it is reserved for this MAC address and it still has that problem.



#6 zingo156

zingo156

  • BC Advisor
  • 3,333 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:00 AM

Posted 23 June 2014 - 02:45 PM

I would try setting the ip outside of your dhcp range. If the router has a DHCP range of 10.0.0.1 to 10.0.0.50, try 10.0.0.51


If I am helping you with a problem and I have not responded within 48 hours please send me a PM.

#7 scotty_ncc1701

scotty_ncc1701

  • Members
  • 520 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:00 AM

Posted 23 June 2014 - 02:49 PM

"...other people don't appreciate really long ethernet cables like I do..."  My wife doesn't like the cables either.  Until I got my new PC, and she started to use my old laptop, the cable was necessary, because the desktop is cable only.  Now the cable is behind the couch, until we get her new PC, because if the laptop she's using goes out, I'll just take the desktop to her craft room, and  she'll be on line in a matter of minutes.



#8 Agouti

Agouti

  • Members
  • 1,548 posts
  • OFFLINE
  •  
  • Local time:10:00 AM

Posted 23 June 2014 - 03:21 PM

flickdog93, you have to limit the range of IP addresses that the router's DHCP is using then set your static IP outside of that range.  When you log on to your router's administrative panel, say the DHCP range is currently 10.0.0.1 to 10.0.0.255, then set it to, say, 10.0.0.1 to 10.0.0.100.  After that you can set your computer's static IP to any one in the range 10.0.0.101 to 10.0.0.254.



#9 flickdog93

flickdog93
  • Topic Starter

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Local time:08:00 AM

Posted 26 June 2014 - 11:31 AM

OK, so I've limited the range to 10.0.0.45 and have 10.0.0.50 reserved, and it still gives me the same error. I'm not sure what else to try.



#10 zingo156

zingo156

  • BC Advisor
  • 3,333 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:00 AM

Posted 26 June 2014 - 11:47 AM

Try without reserving the ip in the router, you don't need to reserver it as the DHCP server will not be assigning that least to anyone else... If that doesn't work, let us know how you are setting static ip in the desktop and what router you have. You should manually set the dns server to the same address as the default gateway. You could also use open dns if you wanted.

 

Here is where you should be changing the ip address (yours will say wireless not wired). Double check that after you click ok it saves the settings by opening ipv4 settings again.

http://windows.microsoft.com/en-us/windows/change-tcp-ip-settings#1TC=windows-7


Edited by zingo156, 26 June 2014 - 11:49 AM.

If I am helping you with a problem and I have not responded within 48 hours please send me a PM.

#11 flickdog93

flickdog93
  • Topic Starter

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Local time:08:00 AM

Posted 28 June 2014 - 03:33 PM

10.0.0.50 isn't reserved anymore, but I still get the same problem. I change it the way you show in the link. I've used google's open dns servers (8.8.8.8 Primary, 8.8.4.4. Secondary), and had just Primary as my default gateway. The only other information that seems relevant is I have my Netgear (The router I'm connecting to wirelessly) get it's connection from the Arris cable modem which also has wifi. (That's a whole other story with the Arris. Most of the settings for WAN and LAN are grayed out and are only able to be messed with if I did a full reset.)



#12 flickdog93

flickdog93
  • Topic Starter

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Local time:08:00 AM

Posted 07 July 2014 - 02:36 PM

OK. I had it working well for a while. This problem was resolved, but I brought my rig to my buddy's place and when I set it back up afterwards the same problem came back up.

I haven't changed any settings so anyone got any ideas?



#13 zingo156

zingo156

  • BC Advisor
  • 3,333 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:00 AM

Posted 07 July 2014 - 02:38 PM

How did you connect the computer at your friends house? Did you have to switch the computer's ipv4 settings back to obtain automatically? Unless both your router and your friends run the same gateway, you must have had to change settings to connect to the internet unless you used a different wireless/wired connection.


If I am helping you with a problem and I have not responded within 48 hours please send me a PM.

#14 flickdog93

flickdog93
  • Topic Starter

  • Members
  • 73 posts
  • OFFLINE
  •  
  • Local time:08:00 AM

Posted 07 July 2014 - 04:51 PM

I had to switch it to automatic, but I set it back to static when I set my pc back up at my house.



#15 zingo156

zingo156

  • BC Advisor
  • 3,333 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:08:00 AM

Posted 07 July 2014 - 04:58 PM

If it were me, I would try to uninstall and then install the most up to date driver. Also do not instal the 3rd party software that may be included, only the driver. Let windows manage the connection.

 

Download the newest driver before uninstalling...


Edited by zingo156, 07 July 2014 - 04:59 PM.

If I am helping you with a problem and I have not responded within 48 hours please send me a PM.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users