Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Headphones appear as 'Speakers'


  • Please log in to reply
21 replies to this topic

#1 JoeVehicle

JoeVehicle

  • Members
  • 104 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:32 PM

Posted 20 June 2014 - 05:37 PM

In 'Sound' my USB Headphones are appearing as speakers. 

 

 

RwvwjgS.png

 

 

I've tried a lot of threads on the internet, however I can't seem to find one that fixes it for me.

 

So far I've tried everything from rebooting to countless variations of properties and settings.

 

I installed Realtek's drivers, that didn't help either.

 

 

 

Last time I had a major issue with my PC I came here and you guys helped a ton.  Hope this one is an easy fix.

 

I don't recall ever having issues with USB ports/sound devices before, I have a set of headphones (jack plugged into the speakers) that is working fine.

 

 

 

Thanks a head of time!  :wink:



BC AdBot (Login to Remove)

 


m

#2 wpgwpg

wpgwpg

  • Members
  • 1,149 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:US of A
  • Local time:04:32 PM

Posted 20 June 2014 - 06:19 PM

 Don't feel bad, I have a stereo speaker that Windows thinks is a headphone.   :clapping: In my case though it doesn't prevent things from working like I want them to.  I didn't see where it was causing you a problem either.  Is it?  If so, what?


Everyone with a computer should back his system up to an external hard drive regularly.  :thumbsup:

#3 JohnC_21

JohnC_21

  • Members
  • 21,705 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:32 PM

Posted 20 June 2014 - 06:20 PM

Hello,

I am not sure you have it but under Control Panel select large Icons instead of Category. You should see Realtek Audio Manager. Open that. There may be a setting that marks the fromt audio jack for headphone use. Make a note of the current settings so you can lrevert back to them if the new settings do not work.



#4 JoeVehicle

JoeVehicle
  • Topic Starter

  • Members
  • 104 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:32 PM

Posted 20 June 2014 - 06:28 PM

It does effect my headphones greatly, my sound acts like the headphones are speakers, so they are as loud as speakers.

I have to put the volume setting down to like 2 before I can even handle putting them up to my ears.

 

 

 

It has a mic, and it works fine.  I'm pretty sure the headset has nothing to do with the problem.

 

 

 

Hello,

I am not sure you have it but under Control Panel select large Icons instead of Category. You should see Realtek Audio Manager. Open that. There may be a setting that marks the fromt audio jack for headphone use. Make a note of the current settings so you can lrevert back to them if the new settings do not work.

 

I'm not sure what you mean by this.  First off, if I untick the 'Disable front panel jack detection' (the only front jack setting I can find) it turns off sound for my speakers or headphones.  I kept it ticked because of it.

 

Also, I'm plugging them into the computer.  My old set of headphones go into the front jack on my speakers, but these are USB since it has a mic.



#5 JohnC_21

JohnC_21

  • Members
  • 21,705 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:32 PM

Posted 20 June 2014 - 06:33 PM

Sorry about that. Yea, had a brain fart there. Saw the USB headphones in the title and realized what I posted is not valid for USB.

 

Edit: Hopefully this link will help some.


Edited by JohnC_21, 20 June 2014 - 06:36 PM.


#6 JoeVehicle

JoeVehicle
  • Topic Starter

  • Members
  • 104 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:32 PM

Posted 20 June 2014 - 07:17 PM

Funny, I already saw that in my trouble shooting efforts.

 

Didn't work, unfortunately.



#7 JohnC_21

JohnC_21

  • Members
  • 21,705 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:32 PM

Posted 20 June 2014 - 07:27 PM

Do you have a make and model of the headset?

#8 JoeVehicle

JoeVehicle
  • Topic Starter

  • Members
  • 104 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:32 PM

Posted 20 June 2014 - 07:43 PM

Yes, it's the Koss SB-45.



#9 JohnC_21

JohnC_21

  • Members
  • 21,705 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:32 PM

Posted 20 June 2014 - 08:06 PM

I didn't find very much support for these. Have you see this link when your were troubleshooting. It's for logitech but it's a generic guide for USB headsets. In device manager are there any yellow exclamation marks? I am kind of surprised playback device does not mention Koss headset,only USB plug and play device. Is the headset still within the warranty period. You may want to contact Koss support.



#10 JoeVehicle

JoeVehicle
  • Topic Starter

  • Members
  • 104 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:32 PM

Posted 20 June 2014 - 09:21 PM

None of those instructions work since it's not even recognizing it as a headset, but as speakers.

 

No, there are no yellow exclamation marks, though I practically uninstalled and reinstalled all the drivers.

 

 

It is quite annoying that they're not working, all of the reviews on Amazon seemed very good, and no one said anything about a related problem.



#11 JohnC_21

JohnC_21

  • Members
  • 21,705 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:32 PM

Posted 20 June 2014 - 09:23 PM

Sorry I couldn't be of further help. Hopefully somebody else on the forum can give some ideas on the problem.

 

Edit: When you right click on the playback device window check show disabled devices and disconnected devices. Does anything show up?


Edited by JohnC_21, 20 June 2014 - 09:28 PM.


#12 JoeVehicle

JoeVehicle
  • Topic Starter

  • Members
  • 104 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:32 PM

Posted 20 June 2014 - 09:54 PM

Nope, nothing shows up.

 

Thanks for the effort!  :wink:

 

 

Hopefully I'll get more people tomorrow.



#13 JohnC_21

JohnC_21

  • Members
  • 21,705 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:32 PM

Posted 21 June 2014 - 07:59 AM

I wanted to clarify something. Your headphones are detected as speakers. Is there sound through them but it is too loud? Or, is there no sound through them? I noticed in your image no checkmark is next to your Speakers detected as headphones which indicates it's not set as default. Right click the Speaker icon notes as USB PnP generic and set it as default. Does this solve the problem? I am pretty sure you have already tried this but just wanted to confirm it.

#14 JoeVehicle

JoeVehicle
  • Topic Starter

  • Members
  • 104 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:32 PM

Posted 21 June 2014 - 10:24 AM

It's just way too loud.  I can only stand the volume set on 1-4 which doesn't give me enough options.

 

It's also kind of glitchy, like I can't change volume anywhere else, it just stays loud.

 

 

Also, I had the headphones not set as default because I didn't want to use them, but it does play through them when it's set as default.

 

 

 

To clear up confusion, the reason the bottom one (speakers) says 'speakers/headphones' is because of RealTek's drivers.



#15 JohnC_21

JohnC_21

  • Members
  • 21,705 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:32 PM

Posted 21 June 2014 - 10:31 AM

When you reinstalled your audio drivers did you download the HD audio drivers from Realtek's website?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users