Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

WIndows 7 Doesnt Specifie USB Headset


  • Please log in to reply
1 reply to this topic

#1 SevenNightSN

SevenNightSN

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:59 AM

Posted 01 June 2014 - 03:53 PM

Hi there!

So today i bought a new Headset, its the Creative Sound Blaster Tactic3d Rage USB version. Its awesome but I've got a problem with windows 7 and the driver.

I got Windows 7 Ultimate and when i plug in the headset, i can hear the sound from my PC just fine, the mic works too. the only problem is that when i try to open up the Sound Blaster Control Panel, there comes an error message which says: The Audio device supported by this application cannot be detected. This application will not close.

That is strange, since the device is already plugged in and working. when i open up the sound mixer, i can see a pic of the headset, so the pc knows its plugged in, its just not specified. I've tried numerous things like:
Plugging in the USB in another socket, front and backside. I've uninstalled and reinstalled the drivers and restarted my pc like 4 times.
I have gone to the control panel, In to the device manager, and deleted the Host controller so everything that is plugged in by USB had to reinstall. and i tried the headset on my laptop, which has windows 8 on it, and it just worked fine. the driver panel opened up with no problem whatsoever.

something else to notice, is that when i go to devices and printers, i can see that the headset is listed under ''Unspecified''. so my PC doesn't recognize is at all. I know that the problem is 100% my pc.

If you know a solution, i would very much appreciate it!

Thnx!


Edited by hamluis, 01 June 2014 - 07:00 PM.
Moved from Win 7 to External Hardware - Hamluis.


BC AdBot (Login to Remove)

 


#2 wpgwpg

wpgwpg

  • Members
  • 1,149 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:US of A
  • Local time:08:59 PM

Posted 01 June 2014 - 04:06 PM

 In my limited experience Creative Labs has very good tech support.  I'd go to their web site, put in the details including serial no., and ask them.  When I bought a bluetooth speaker from them, I got good answers for all my questions I asked them.


Everyone with a computer should back his system up to an external hard drive regularly.  :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users