Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

My Laptop Won't recognize TV as an Audio Source (Hdmi)


  • Please log in to reply
18 replies to this topic

#1 Miroku16

Miroku16

  • Members
  • 307 posts
  • OFFLINE
  •  
  • Local time:01:26 PM

Posted 28 May 2014 - 02:22 PM

Okay, so this has happened about a few days ago.  I used to be able to connect my laptop to my tv through hdmi and watch and listen to content through the tv.  But for some reason, the sound only chooses to play through my computer, even though it is connected to the television.  I can get my tv to display everything that my computer does; it just does not play any of the sounds from it.  I tried going into control panel and sounds to try to enable sound for devices outside of my computer, but it does not recognize my tv as a connected device.  What is wrong?  Is it the drivers for Windows 7 or something else.  It worked just fine last week, but it stopped feeding sound to my computer a few days ago.  Please let me know how I can resolve this issue.  Thank you.

 

Miroku16

 

 

Operating system: Windows Home premium

 

Laptop: HP Pavilion dv7-4087cl


Edited by Chris Cosgrove, 28 May 2014 - 05:58 PM.
Moved to Audio section


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,950 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:01:26 PM

Posted 28 May 2014 - 07:08 PM

Hello,

My first suggestion would be to try a new HDMI cable. If you cannot do that, try detaching and attaching the HDMI cable at the computer and TV.

 

Finally, Right click the speaker in the system tray, select Playback devices and disable your computer speakers.



#3 Miroku16

Miroku16
  • Topic Starter

  • Members
  • 307 posts
  • OFFLINE
  •  
  • Local time:01:26 PM

Posted 30 May 2014 - 08:04 PM

My hdmi cable works.  My computer sends the right video system to my computer.  The problem lies with the computer not relaying any sound to my tv.  It doesn't recognize it as an audio playback device. Only Peakers and Headphones and Independent headphones are the only options available.  I tried a different hdmi cord from a gaming console, and it still didn't recognize my tv as an audio device.  Is it my drivers or some update that knocked it out, because it was working last week.  I get picture, but no audio.



#4 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:26 AM

Posted 31 May 2014 - 08:36 PM

Only Peakers and Headphones and Independent headphones are the only options available

 

Can you right-click within playback devices and see if disabled devices (for HDMI) is unticked? Reinstalling the correct driver from the support site is also another option just in case.


Tekken
 


#5 Miroku16

Miroku16
  • Topic Starter

  • Members
  • 307 posts
  • OFFLINE
  •  
  • Local time:01:26 PM

Posted 31 May 2014 - 11:26 PM

Oops, I meant to say speakers.  haha  Anyways, I have both disabled and disconnected devices checked, and still no luck.  How do I reinstall my driver?



#6 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:26 AM

Posted 03 June 2014 - 09:13 AM

Try rolling back the driver first http://pcsupport.about.com/od/windows7/ht/roll-back-driver-windows-7.htm


Tekken
 


#7 Miroku16

Miroku16
  • Topic Starter

  • Members
  • 307 posts
  • OFFLINE
  •  
  • Local time:01:26 PM

Posted 04 June 2014 - 10:38 PM

But which one do I choose.  Their are several listings.  The one for sound?



#8 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:26 AM

Posted 04 June 2014 - 11:33 PM

Oops, I meant to say speakers.  haha  Anyways, I have both disabled and disconnected devices checked, and still no luck.

 

Can you confirm on what speakers you need to use before pointing to which driver we need to roll back?


Tekken
 


#9 Miroku16

Miroku16
  • Topic Starter

  • Members
  • 307 posts
  • OFFLINE
  •  
  • Local time:01:26 PM

Posted 05 June 2014 - 12:40 PM

I don't know.  I have never done this before.  The only speakers I want to work are the ones from my tv when it is linked to my computer's hdmi.  Does it have anything to do with the computer's drivers to feed sound from the computer to the tv using projector mode?



#10 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:26 AM

Posted 05 June 2014 - 10:34 PM

Oops, I meant to say speakers.  haha  Anyways, I have both disabled and disconnected devices checked, and still no luck.

 

Do you have HDMI device as an option to enable or found under playback devices?


Tekken
 


#11 Miroku16

Miroku16
  • Topic Starter

  • Members
  • 307 posts
  • OFFLINE
  •  
  • Local time:01:26 PM

Posted 07 June 2014 - 08:39 PM

Unfortunately, I do not.  It is linked to my tv and shows everything on it that the computer screen shows.  But, as a playback device, my tv appears non-existent to my computer.



#12 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:26 AM

Posted 07 June 2014 - 10:47 PM

Can you go to device manager and expand System devices. Look for HDMI Audio Controller or something similar and see if its flag or disabled either way?


Tekken
 


#13 Miroku16

Miroku16
  • Topic Starter

  • Members
  • 307 posts
  • OFFLINE
  •  
  • Local time:01:26 PM

Posted 08 June 2014 - 10:50 PM

That worked! Thanks!  How do I keep it from disabling again?



#14 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,230 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:03:26 AM

Posted 08 June 2014 - 11:25 PM

Thanks guys... I've been watching this thread, have come across this a couple of times. :thumbsup2:



#15 badr0b0t

badr0b0t

  • Members
  • 328 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Canada
  • Local time:01:26 PM

Posted 09 June 2014 - 02:26 PM

That worked! Thanks!  How do I keep it from disabling again?

 

I'm late to this party, but if you right-click on Playback tab under Control Panel >>> Sound settings, select "Show Disconnected Devices" and it will always be there even when not in use.


sig07.gif?psid=1

                                                           (Click sig to enlarge.)                                                    

 





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users