Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Black Screen of Death Win7-Pro


  • Please log in to reply
3 replies to this topic

#1 abacus_x

abacus_x

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:11:03 PM

Posted 26 May 2014 - 07:50 AM

Hello great bleeping computer community!

 

For the last month or so ive been battling with an issue that has left a lot of people scratching their heads.

 

Yes ive been greeted with the Black Screen of Death by my trusty laptop!!!

 

I will try to be as informative as i can.

 

Disclaimer: Im quite experienced in using, troubleshooting fixing etc windows systems so treat accordingly. (For your own convenience and mine!) I am however not a certified expert as my expertise is in another sector of the IT business. In any case im just laying that on the table to make things easier for all of us.

 

Ok, issue presented it self after a normal and full day of using my Lenovo X230 i5 8gb RAM etc etc.After logo and before login screen, a black screen hangs there with the mouse pointer active and working but nothing else. Hard drive seems to be working as well.

 

I have literally tried EVERYTHING! 

 

- Last known good Config does not work

- Safe mode presents exactly the same symptoms. 

- I did not have system restore (very stupid of me i know.)

- I dont have lenovo's rescue partition since i re-partitioned my hdd and have multibooted Ubuntu with Windows etc.

- Startup repair finds no errors!

- SFC finds some stuff, fixes them, but same issue.

- Checked registry key Shell and WinLogon and both include the right values. 

- ctrl-alt-del does not bring up task manager.

- Sticky keys does not have a link for advanced settings so that i can open explorer or msconfig or etc.

- No virus on system as i kept really good care of my system, and checked it after the issue with SEVERAL rescue/bootdisks. (I also worked in the anti-virus industry) but please DO give me your suggestions.

 

Maybe i tried more stuff and just forgot to add them.

 

I know that the best and easiest way is to re install windows but i will not give in! I wont have that as my last resort..Yet! :)

 

So one thing that did work was when i found a way to change the default executable that comes up when pressing CTRL+SHIFT+ESC when on the black screen. I changed it to msconfig and tried disabling some services. Black screen reappeared but i could no longer bring msconfig up!

 

I am thus looking for that way to change the default executable that comes up when pressing CTRL+SHIFT+ESC to change it again back to something else like explorer.exe or task manager or anything else that could allow me to play around there. Please if someone knows how let me know as i completely forgot where and what to change!!!

 

I have full access to the HDD from my ubuntu partition and from the setup disk from CMD.

 

Any suggestions are very very appreciated!

 

Thank you!


Edited by abacus_x, 26 May 2014 - 07:52 AM.


BC AdBot (Login to Remove)

 


#2 abacus_x

abacus_x
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:11:03 PM

Posted 26 May 2014 - 11:03 AM

LOW AND BEHOLD Everybody!!

 

I fixed it but without knowing what exactly i did so thats where some help will be needed so that i can prepare an article...

 

I renamed C:\Windows\system32\config\software to Software_OLD and C:\Windows\system32\config\software.bak to software. And there we go im in!

 

Now comes the hard part. Anybody can explain why exactly?

 

Thanks! 



#3 abacus_x

abacus_x
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:11:03 PM

Posted 26 May 2014 - 12:16 PM

Ok, seems i need to recover my corrupted registry. I know in Windows XP this was done by looking for _restore folders in System Vlume Information folkder but in win 7 there arent any.

 

Any pointers?



#4 abacus_x

abacus_x
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:11:03 PM

Posted 26 May 2014 - 12:37 PM

Im talking to myself here but oh well this may help someone before i write something official.

 

I guess the backup registry hives are in C:\Windows\system32\config\regback

 

Got SOFTWARE from there and replaced the one i had in C:\Windows\system32\config all good !






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users