Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


No g2ldr, and blank screen with cursor otherwise, a Boot\BCD error occurs

  • Please log in to reply
1 reply to this topic

#1 koiboi


  • Members
  • 1 posts
  • Local time:06:37 PM

Posted 24 May 2014 - 12:06 AM

I ran into a computer problem a week back, saying that my system was unable to start due to "boot critical file ci.dll is corrupt." I tried restarting to no avail, as well as recovery options. This is due to the fact that I do not have administrator access to my own computer. So, I purchased the EasyRE after reading multiple reviews testifying to its ease and help in solving nearly everyone's problems. It sounded too good to be true, and I guess it really was. Upon trying to fix my problems, it would simply stall, even if I left it alone for  up to 8 hours at a time; no resolution of my problems were made. Now, my computer upon booting, displays this message. "No g2ldr" 


I ordered recovery media from my manufacturer, Lenovo, but when using it, it gets as far as loading its files, before I am met with a blank screen with a cursor on it. The CD in question is an OS recovery disc for Windows 7. Sometimes, I am met with a screen that tells me that a recent hardware or software change may be causing the problem, and the problem is a Boot\BCD error. So, I do not have access to the windows command prompt, but I do have access to the EasyRE command prompt. Could I repair the BCD or find a solution while in this system?


PS: I don't think I have a virus, having used the Avira rescue system to scan my drive for viruses/trojan horses.

BC AdBot (Login to Remove)



#2 hamluis



  • Moderator
  • 54,995 posts
  • Gender:Male
  • Location:Killeen, TX
  • Local time:05:37 PM

Posted 24 May 2014 - 12:28 PM

Info On No G2ldr Message



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users