Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How to disable Time Warner DNS redirect on a Linux system.


  • Please log in to reply
3 replies to this topic

#1 od13

od13

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:10:26 PM

Posted 23 May 2014 - 12:30 PM

I am using Luna OS Elementary with the latest version of firefox. My first Linux experience. I am truly enjoying it, and also the Linux community that always has an answer for any issue. However, when I misspelled something in the address bar, I get redirected to a Time Warner search engine which I quickly shut down and start all over again. I have searched for hours in the internet on how to stop this malicious (I consider it a virus) intruder from taking over my browser. I have found instructions on how to disable for a windows system, but nothing for Linux. Can anyone help? Please, and thank you.



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,989 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:01:26 AM

Posted 23 May 2014 - 01:14 PM

Can you change the DNS server addresses in your Router to the Open DNS servers?

 

http://www.opendns.com/


Edited by JohnC_21, 23 May 2014 - 01:14 PM.


#3 jonuk76

jonuk76

  • Members
  • 2,178 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Wales, UK
  • Local time:06:26 AM

Posted 23 May 2014 - 02:10 PM

It sounds like your ISP's DNS server is redirecting you when you mis-type a URL.  If so, that's not a virus, or even anything to do with your browser.  It's an intentional "enhancement" added by your ISP.  DNS servers are what are responsible for translating friendly URL's like www.bleepingcomputer.com into IP addresses.

 

Worth noting that Open DNS also redirects you to a search page if you mistype a URL (at least the free service which is what I'm currently using).  Here is what happens when I typed a nonsensical URL:

 

V7OBuIS.png

 

If you want to use a different DNS server from whatever your ISP assigns, you can either change it in the router settings, which will change it for every device that connects through the router.  Or you can change the network settings on just the computer you are using.  I don't know the distribution you are using but here is how you do it through the Ubuntu GUI (should be similar on other distro's):

 

1) Click/right click the network icon in the information panel choose "Edit Connections"

 

2) Choose whatever connection you are currently using (in my case "wired") and click "Edit".

 

wGvzOoJ.png

 

3) Choose the IPv4 settings tab

 

NEUcp1E.png

 

4) If it's currently on Automatic (DHCP) change to "Automatic (DHCP) addresses only"

 

wV9xe3i.png

 

5) Add the DNS servers you want to use to the appropriate line, seperated by a comma.  Here I've set my DNS servers to Comodo Secure DNS.

 

lOur6Ze.png?1

 

6) Save and close the settings dialog.  To test I open a browser and mis-type a URL, and now it is re-directing to the Comodo Secure DNS page.

 

VwSdEX6.png


Edited by jonuk76, 23 May 2014 - 02:11 PM.

7sbvuf-6.png


#4 NickAu

NickAu

    Bleepin' Fish Doctor


  • Moderator
  • 13,247 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:127.0.0.1 Australia
  • Local time:03:26 PM

Posted 23 May 2014 - 07:18 PM

After trying the above.

Nuke the oldFirefox profile. Start again.

This script moves the old profile to another location,

You should be able to copy and paste this into a termininal.

Buntu based OS.

cd ~/.mozilla/firefox/
export FFPROFILE=`cat profiles.ini | grep "Path=" | sed 's/^Path=//'`
mv $FFPROFILE $FFPROFILE.BAK
rm profiles.ini

When Firefox next launches, it will create a new profile.


Save bookmarks, saved passwords, etc

After firefox has created the new profile, you can go to

~/.mozilla/firefox/ in nautilus and copy back some of the files into the new profile and then deletes the profile configuration file so that Firefox has to create a new profile. Start by closing Firefox and then punch these lines into a terminal:

cd ~/.mozilla/firefox/
export FFPROFILE=`cat profiles.ini | grep "Path=" | sed 's/^Path=//'`
export OLDFFPROFILE=`ls -1 | grep .BAK`
cp $OLDFFPROFILE/*.sqlite $FFPROFILE/



Edited by NickAu1, 23 May 2014 - 08:45 PM.

Arch Linux .
 
 Come join the fun, chat to Bleeping computer members and staff in real time on Discord.
 
The BleepingComputer Official Discord Chat Server!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users