Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Different Saints Row:The Third problem?


  • Please log in to reply
1 reply to this topic

#1 Sogin

Sogin

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:05:13 PM

Posted 21 May 2014 - 11:26 AM

So, I had to put my SR3 down to Medium..I dunno why given my specs, but whatever. In high the Cutscenes ran fine, now they run awful...Skipping a lot, not freezing for a moment but just skipping.. Can anybody tell me wtf is going on? Specs: Graphics Card: Nvidia GTX 645. Processor: i7-4770 3.4ghz. Ram: 8GB. Hard Drive: 1TB. OS: Windows 7 Home Premium 64-bit. Thanks in advance.



BC AdBot (Login to Remove)

 


#2 Sogin

Sogin
  • Topic Starter

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:05:13 PM

Posted 21 May 2014 - 02:21 PM

I also keep getting a message after playing from my Computer asking to go into Windows 7 Basic mode because performance was down. =/






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users