Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem With Opening Ports


  • Please log in to reply
6 replies to this topic

#1 anonymous1

anonymous1

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:47 AM

Posted 24 May 2006 - 09:43 AM

I'm having problems with opening ports in my rauter. Before I reinstalled my PC, everything worked fine. I opened the ports in the built-in XP firewall, I opened the ports in my rauter configuration, and it worked. After I configured these ports in my old setup (before I reinstalled windows etc), a technician guy installed a small hub between the rauter and my pc to let our printer be shared in the network. I don't know if that causes the problem of ports not beeing opened or not, but I don't really have any clue at the moment.

The situation is as follows:

1) I disable my XP firewall so that couldn't cause the problem
2) I make my internal IP static because I can remember that the rauter setup didn't always react that well to my internal ip (I don't know if making it static will solve this, but a dynamic ip didn't help either)
3) I open the ports in my rauter config like I used to, using my static internal IP
4) The program that use the ports doesn't work optimal like it would when the ports would be open, and an external port scan tells me that every port is closed.

Does anyone have a clue what the problem might be? Thanks in advance

Edited by anonymous1, 24 May 2006 - 09:44 AM.


BC AdBot (Login to Remove)

 


#2 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:09:47 AM

Posted 24 May 2006 - 11:59 AM

Im sort of curious why a tech would install a hub in addition to a router? My router will allow for six components to be connected; I would imagine your router has more than one connections, otherwise it would pretty much just be a modem. Of course, I am not there to see what your setup is like, so maybe there is a good reason. I can see why you would be having weird problems though.

So what does your setup look like?

-->Modem------>Router----->hub---->Computers??

Where are the other computers plugged into?

#3 anonymous1

anonymous1
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:47 AM

Posted 24 May 2006 - 12:40 PM

I think it's because the router only has 2 ports and the hub has more, and since we have 3 computers...

The setup is like:

router->hub->pcs (3 pcs)

I just read some more about finding the right static IP (http://forum.portforward.com/YaBB.cgi?board=Knowledge;action=display;num=1116577357), and maybe that is the problem. I just tried using an IP outside the DHCP range (which is in my case 192.168.1.10 till 192.168.1.50, so I used 192.168.1.51) but it didn't seem to work either.

EDIT: the other computer are plugged into the hub if Im correct

Edited by anonymous1, 24 May 2006 - 01:21 PM.


#4 Snapper

Snapper

  • Members
  • 550 posts
  • OFFLINE
  •  
  • Location:Newfoundland
  • Local time:11:47 AM

Posted 24 May 2006 - 09:31 PM

check out a firmware update for your router while you are in the midst of reconfiguring it. they put them out every now and then to address different issues<if u need help with that post back>, if you have the proper ports open for the application you are using, after a flash if it dosen't work still, disable the port forwarding first, then try putting your static ip in the DMZ. if you get no better results, try removing the router from the equasion, put your computer directly on the modem right to the net. so you have nothing between you and the net, (no router,hub). this will tell you if you need to focus on the router or if it is within your computer. you just formatted your computer? did u do all the windows updates as well?
please post back, someone will be able to furthur assist you
Google...Google.....browse..read

#5 acklan

acklan

    Bleepin' cat's meow


  • Members
  • 8,529 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Baton Rouge, La.
  • Local time:09:47 AM

Posted 24 May 2006 - 10:43 PM

On your router (rauter) there will be a MDI\MDIx switch. Enable the DMIx feature. If your router does not have a MDIx, you will need to connect the router to the hub via crossover cable.

http://www.ne.jp/asahi/welcome/netland/ass...s0110/port4.jpg
"2007 & 2008 Windows Shell/User Award"

#6 anonymous1

anonymous1
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:10:47 AM

Posted 25 May 2006 - 05:02 AM

This was really weird. I got it working now, but there were some NAT policy ports open under the advanced tab from my router page. Some ports apparantly never got removed in the NAT section while I did remove them under the normal section of port forwarding, so that I had the same ports forwarding to 2 computers instead of 1. Anyway, I did a reset to manufacturing values and inserted the port forwarding again, and it worked. Thanks for your time anyway, really appreciated :thumbsup:

#7 acklan

acklan

    Bleepin' cat's meow


  • Members
  • 8,529 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Baton Rouge, La.
  • Local time:09:47 AM

Posted 26 May 2006 - 07:46 AM

I am glad it worked out. We are here anytime you need us.
"2007 & 2008 Windows Shell/User Award"




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users