Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Saints Row:The Third lag issues?


  • Please log in to reply
No replies to this topic

#1 Sogin

Sogin

  • Members
  • 95 posts
  • OFFLINE
  •  
  • Local time:05:22 PM

Posted 20 May 2014 - 07:47 PM

So, I'm confused. =P I went on "Can you run it?" my computer meets fast, when I let the game auto-detect it puts everything on Ultra settings but I moved it to High just because. It plays awesome when I first open it, barely any lagging now and then when a lot of stuff is going but for games like GTA and Saints Row that's not new. BUt after time i start to lag, before my Computer was telling me my Computer is running slow when I was in Saints Row:The Third asking to go into Windows 7 Basic display mode. But I looked at the specs and none of this makes sense to me.. My specs are: Nvidia GTX 645. Intel i7-4770 3.4ghz 8 core processor. 8GB of ram. 1TB Harddrive. Windows 7 Home Premium 64-bit OS. Anybody have an idea?



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users