Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Program compatability stopped working


  • This topic is locked This topic is locked
7 replies to this topic

#1 clinton.brits

clinton.brits

  • Members
  • 11 posts
  • OFFLINE
  •  

Posted 18 May 2014 - 05:26 AM

I run windows 7 and have done so for the last few years. I run old apps like delphi and they've always worked with compatability settings.

I got a bit of a fright when the app didn't load and immediate cleaned the system of malware and viruses using microsoft security essentials and malwarebytes.

On a closer look it wasn't all my applications, just the ones needing compatability settings. I restarted my computer in safe mode and the software worked.

I went back into normal mode to see why it wasn't working(since there's no error, it just shows the loading mouse cursor and nothing comes of it).

When I open the task manager, the process is there for a short while but then disappears. It is replaced by a pcaui.exe which is apparently the program compatability using 56k memory.

I've run regTweaker hoping there was a problem with the program compatability assistant and that it might fix it but no luck.

Any suggestions?

BC AdBot (Login to Remove)

 


m

#2 ElfBane

ElfBane

  • Members
  • 775 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:01:55 AM

Posted 18 May 2014 - 06:28 AM

Can you re-establish the Compatibility? (r-click, Properties, Compatibility tab)



#3 clinton.brits

clinton.brits
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  

Posted 18 May 2014 - 06:35 AM

The compatability tab is working. The settings are still there from when it worked and you can change them as well. It seems like something is preventing it from doing its job when in normal mode and instead the PCA just hangs and never runs the application.

#4 clinton.brits

clinton.brits
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  

Posted 18 May 2014 - 07:40 AM

Most sources still point to malware eventhough what I'm using can't find it. I took a suggestion off another thread about using unhooker to remove possible rootkits.

I see that it gives a log. Does anyone know how to sort the good hooks from the bad?

#5 ElfBane

ElfBane

  • Members
  • 775 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:01:55 AM

Posted 18 May 2014 - 07:41 AM

Try elevating the privilege, select 'run as administrator' in the Compatibility tab.



#6 clinton.brits

clinton.brits
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  

Posted 18 May 2014 - 07:49 AM

I've elevated priveledges and changed security settings to full control as well.

#7 ElfBane

ElfBane

  • Members
  • 775 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Florida
  • Local time:01:55 AM

Posted 18 May 2014 - 08:04 AM

Then my only suggestion is to uninstall and reinstall the legacy programs, and see if you can re-establish compatibility that way.



#8 hamluis

hamluis

    Moderator


  • Moderator
  • 54,839 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:11:55 PM

Posted 18 May 2014 - 01:59 PM

OP has open malware topic at http://www.bleepingcomputer.com/forums/t/534747/hidden-driver-rootkit/ .

 

Pending resolution of that topic, this topic is closed to avoid further confusion.

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users