Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Primary Battery Not Identified


  • Please log in to reply
1 reply to this topic

#1 Justin Studio 1745

Justin Studio 1745

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:10 AM

Posted 15 May 2014 - 08:12 PM

On startup, my Dell Studio 1745 told me that the battery experienced a permanent failure. I figured it was just a routine expiration of the battery. I ordered a new battery, attached it, and plugged in my ac adapter (not the source of my problem - I tried an identical replacement). I still get the message on startup before Windows loads that the primary battery cannot be identified. The computer will run on the battery without the charger, and it will also run on the charger without the battery. I have been doing research and a few solutions required an update to the BIOS. I am currently using A03, and I have the setup for A04 saved to my computer. When I try to run it, I get the error that the battery is not for Dell, although it is a Dell battery. If I try to run the BIOS flash without the battery, I get the message that I must have the battery and the adapter attached before flashing the BIOS. I have even tried some so-called, simple "reset trick" by shutting off the computer, removing the battery and the adapter, and pressing and holding the power button for 5-10 seconds. That did not do anything. I have run the diagnostics by pressing f5 instead of f1 on the message screen about the battery not being identified, and nothing came up. Technical support for Dell just suggested I try to get my computer repaired because it may either be my motherboard or "charger board," and I highly doubt that because I have not even used the laptop after March 2010 until three years later, and only briefly. I bought the computer at the end of 2009. My warranty has expired, and Technical Support told me my computer has "reached the end of its life." Apparently computers are not designed to last for more than a few years? I have basically no confidence in Dell Technical Support.

 

If I do need a repair, what might the problem be and what can I expect to pay?

 

I have tried reinstalling Windows, I don't think I'm missing any drivers - my device properties shows no "!" 's. Is there a battery driver I need? I seem to have a faint recollection of seeing a 'Dell Composite Battery' driver somewhere while reinstalling drivers, but nothing like that shows up when I enter my service tag on the Dell support webpage and view the relevant drivers.

 

Again, the battery and/or the adapter are ruled out as the issue.

 

The tray at the bottom right of my desktop says 61% available (plugged in, not charging).

 

Specs:

OS Name Microsoft Windows 7 Home Premium
Version 6.1.7600 Build 7600
Other OS Description  Not Available
OS Manufacturer Microsoft Corporation
System Name -------------
System Manufacturer Dell Inc.
System Model Studio 1745
System Type x64-based PC
Processor Intel® Core™2 Duo CPU     T6600  @ 2.20GHz, 2200 Mhz, 2 Core(s), 2 Logical Processor(s)
BIOS Version/Date Dell Inc. A03, 3/1/2010
SMBIOS Version 2.5
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume1
Locale United States
Hardware Abstraction Layer Version = "6.1.7600.16385"
User Name ---------------
Time Zone ----------------------
Installed Physical Memory (RAM) 4.00 GB
Total Physical Memory 3.96 GB
Available Physical Memory 2.80 GB
Total Virtual Memory 7.92 GB
Available Virtual Memory 6.66 GB
Page File Space 3.96 GB
Page File C:\pagefile.sys

 


Edited by Justin Studio 1745, 15 May 2014 - 08:30 PM.


BC AdBot (Login to Remove)

 


m

#2 JohnC_21

JohnC_21

  • Members
  • 21,685 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:10:10 AM

Posted 16 May 2014 - 08:10 AM

Hello, and Welcome

 

People have reported success using the forceit switch at the command prompt. Also, after the BIOS update, the battery started charging again. Type cmd, right click and run as administrator. Your adapter should be plugged in and battery installed.

 

WARNING: a bad flash could brick your computer.

 

http://club.myce.com/f7/how-update-bios-dell-laptops-without-battery-260714/

 

Read through this Dell thread.

 

If you would like to see your battery ID type and charging capacity close all programs and type cmd at the search box, right click run as administrator and type

powercfg -energy -output c:\energy.html

After about 60 seconds a report will be generated. Double click the C:\energy,html file


Edited by JohnC_21, 16 May 2014 - 08:10 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users