Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cd/dvd Drive Not Working Right


  • Please log in to reply
11 replies to this topic

#1 SuzanneMarie

SuzanneMarie

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Rhyl, North Wales
  • Local time:06:20 AM

Posted 23 May 2006 - 02:14 PM

I don't know how long I have had the problem because I don't usually use my PC for listening to CD's or watching DVD's but when I tried to listen to a Cd today the sound was all funny and choppy the same when I tried to watch a Dvd. It works fine for playing games and installing software, it only plays up when I try to listen to cd's/watch Dvd's. I looked at the device manager and it says everything is working fine. Music and video I already have on the hard drive plays fine I play it through Windows Media Player 10. I have Windows XP. Please help. Thank You :thumbsup:

BC AdBot (Login to Remove)

 


m

#2 DaveM59

DaveM59

    Bleepin' Grandpa


  • Members
  • 1,355 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:TN USA
  • Local time:12:20 AM

Posted 23 May 2006 - 06:33 PM

Assuming you have Windows XP: Click Start/Control Panel/System/Hardware. Click on the "+" and then double-click on Primary IDE controller. Click on the Advanced Settings tab. Repeat for Secondary IDE controller. I don't know which channel(s) your optical drives are on, but for any channel that has a device attached to it, Transfer mode for both devices should be set to "DMA if Available" and Current Mode should be Ultra DMA x (a number between 2 and 5). If any channel is set to PIO only, try to reset it to DMA if available. Report what you find.

#3 SuzanneMarie

SuzanneMarie
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Rhyl, North Wales
  • Local time:06:20 AM

Posted 24 May 2006 - 06:31 AM

Thank You DaveM59. I did as you suggested I have three primary and three secondary IDE channels.
All the primary channels were set as you suggested, but one of the secondary channels was set to PIO mode only and in the current transfer mode it read PIO Mode. so I changed this to DMA if available but it still says PIO mode in the current Transfer Mode and I still have funny sound and Picture. :thumbsup:

#4 stevealmighty

stevealmighty

    Bleepin' WormBreath


  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Upstate NY
  • Local time:01:20 AM

Posted 24 May 2006 - 08:41 AM

Hi SuzanneMarie! Could you please tell us what model/make computer you have (Dell Dimension 1234/HP 1234 etc. etc.).

Do you know if your computer has a sound card, or is it integrated sound? What about the video (add on card or integrated)? If you dont' know, it's ok, giving us your computer information is good enough (we'll look it up online :thumbsup: ).

Could you please click on Start>settings>control panel. Now, click on the "System" icon and a window will pop up. Now, click on the "Hardware" tab then click on "Device Manager". Is there any yellow exlamation points or red question marks? If so, please let us know what they are next to.

Start with these things then we'll go from there! :flowers:
War produces veterans, wounded both physically and mentally. They have sacrificed for us.....and it is now our job to help these veterans, as they have already helped us in ways we will never know, in ways that we cannot fathom, and in ways that we take granted every day.
Posted Image

#5 SuzanneMarie

SuzanneMarie
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Rhyl, North Wales
  • Local time:06:20 AM

Posted 24 May 2006 - 10:27 AM

Hello Stevealmighty! Here is the information that you requested:
I have a Mesh Computer with an AMD Athlon 64 Processor 3500+
My sound card is Realtek AC97 Audio
I looked at the device manager and there are no yellow exclaimation marks or red question marks by anything :thumbsup:
Thank you for your help

#6 stevealmighty

stevealmighty

    Bleepin' WormBreath


  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Upstate NY
  • Local time:01:20 AM

Posted 24 May 2006 - 11:57 AM

Do you have the CD that the drivers are on for the sound? If you do, then try uninstalling the current drivers (may have to be done using "Add and Remove programs" in the control panel), then reinstall the drivers again.

If this doesn't work, then go back into the device manager, click on the + next to "Sound, video and game controllers". Look for something that says Realtek audio drivers. Right click on it and click "update drivers".

Have you had your computer open recently? If you have a soundcard, you might have losened the wire that runs from the cd drive to the soundcard. However, I believe that realtek audio is onboard, but can't be 100% sure.

Let me know how you fare with this!
War produces veterans, wounded both physically and mentally. They have sacrificed for us.....and it is now our job to help these veterans, as they have already helped us in ways we will never know, in ways that we cannot fathom, and in ways that we take granted every day.
Posted Image

#7 SuzanneMarie

SuzanneMarie
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Rhyl, North Wales
  • Local time:06:20 AM

Posted 25 May 2006 - 07:28 AM

Don't have the Cd with the drivers on. I tried uninstalling the drivers for my CD/DVD drive and re-installing them but I am still having the same problem. Don't know if it's a problem with my sound card because anything I have already on the Hard drive plays fine(Video and Sound). My lovely boyfriend phoned the manufacturer Mesh and they were not much help the best they could offer was to recall it back and test it.
But if you think that it is worth me trying to update the drives for the sound card I am willing to give it a try.
(if anything to stop from losing my PC for who Knows How Long) Thank you very much for your help :thumbsup:
Just remembered....no I haven't opened the case at all it's a fairly new computer only had it a few months.

Edited by SuzanneMarie, 25 May 2006 - 07:31 AM.


#8 stevealmighty

stevealmighty

    Bleepin' WormBreath


  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Upstate NY
  • Local time:01:20 AM

Posted 25 May 2006 - 09:59 AM

Well, let's try this first; Go back into the "Device Manager". Where it says "CD/DVD drives", click on the "+" symbol to the left. Find the CD drive (it will be the only one unless you have another CD/DVD drive), right click on it and click "Uninstall". Let it uninstall, then restart your computer. When windows restarts, it will automatically (re)install the drive. Not sure if this will fix it, but it's worth a shot.

Let me know if this works for you. If not, we'll go from there!
War produces veterans, wounded both physically and mentally. They have sacrificed for us.....and it is now our job to help these veterans, as they have already helped us in ways we will never know, in ways that we cannot fathom, and in ways that we take granted every day.
Posted Image

#9 Nordic Avenger

Nordic Avenger

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:20 AM

Posted 26 May 2006 - 11:28 PM

Hi, I'm also having the same problem. I have two drives; a CD-RW and a DVD-ROM drive... I started having problems shortly after a recent Windows XP update, I don't know if it's related. At any rate, I've followed all the advice in this thread and still no luck.

I'm gonna go read some other posts and see if I can find a fix, else please help!

#10 Nordic Avenger

Nordic Avenger

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:02:20 AM

Posted 27 May 2006 - 12:05 AM

I found this webpage and after following the instructions therein I was absolved of my problem. Be warned it does involve mucking about in the registry so you may want to have someone who knows what they're doing take care of it. I don't know a thing about the Registry but I don't care if I mess up my system so I went ahead and did it anyway.

SUCCESS! :thumbsup:

Without further ado; clicky.

#11 SuzanneMarie

SuzanneMarie
  • Topic Starter

  • Members
  • 44 posts
  • OFFLINE
  •  
  • Location:Rhyl, North Wales
  • Local time:06:20 AM

Posted 27 May 2006 - 08:33 AM

Thank You Nordic Avenger. I am getting closer to it being back to normal, tried the link you gave and it helped but in the setting for current transfer mode the primary channel says Ultra DMA Mode 5 and the secondary channel says Ultra DMA Mode 4. I don't know if these are supposed to be the same?? The playback sound is alot better than it was but it's still a bit clicky. (It's not the cd I tried lots of them) :thumbsup:

#12 The Shadow

The Shadow

  • Members
  • 64 posts
  • OFFLINE
  •  
  • Location:Florida, USA
  • Local time:01:20 AM

Posted 27 May 2006 - 11:35 AM

The newer (version) your Media Player is,,,,the larger the program and the more system resources it takes up.
People just love to update things like MP, but they never add more ram, cpu speed, etc. to run the newer versions. The result is a MP that jerks, jitters and stalls.

I've seen this so many times on older PC's when people upgrade to MP 9 or 10.
Just de-installing either of those versions and going back to v. 7.1 solved the problem.

Also shutting down all other running programs before running MP can make for a smoother play.

Try that, just once, for grins and giggles. That includes any AV or AS programs.

Good Luck and Happy Computing,
The Shadow :thumbsup:
For those wanting, or needing the Norton Removal Tool,
it's latest version is available Here:
http://service1.symantec.com/SUPPORT/tsgen...005033108162039

"The only bad backup is the one you decided NOT to make" Annonymous




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users