Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Problem with Google security certificate


  • Please log in to reply
8 replies to this topic

#1 Gileraracer

Gileraracer

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:12:00 AM

Posted 13 May 2014 - 02:14 AM

Hello Guys,

 

i have a few PCs running with Windows 7. All PCs are up to date, Windows 7 Enterprise 32 bit.

 

A few weeks ago a strange error occured. On some of them (just a few, maybe 5%) there suddenly was a problem with the security certificate when i tried to visit google.com

 

 

Shouldn' this certificates be updated automatically? Unfortunatly i am not really into this topic. It definitly is a local problem on the pc, no mather which user i try, always the same problem.

If i log in with the same user to another PC where the problem doesn't exist everything is fine.

 

Maybe anyone has a solution for this problem, is there a way to manually update these security certificates?

 

 

Thx and Regards,

Dom

Attached Files


Edited by Gileraracer, 13 May 2014 - 02:18 AM.


BC AdBot (Login to Remove)

 


#2 Kilroy

Kilroy

  • BC Advisor
  • 3,486 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:04:00 PM

Posted 13 May 2014 - 08:41 AM

Have you checked the certificate?  Is this in a work environment?  If your proxy acts as a man in the middle it may need to be added to the certificate authorities on these machines.

 

A lot of certificates were replaced after April 8th due to Heartbleed.  It looks like Google issues their own certificates.



#3 Gileraracer

Gileraracer
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:12:00 AM

Posted 13 May 2014 - 09:18 AM

Hello RKilroy and thanks for your answer.

 

it is a work environment with around 100 PCs. Only a couple of them got this problem, thats why i assumed that there cannot be any problem with the proxy since all of the machines use this proxy.

 

i ran rootsupd.exe on one of these machines but the error wasn't fixed.



#4 larryhyman

larryhyman

  • Members
  • 34 posts
  • OFFLINE
  •  
  • Local time:06:00 PM

Posted 13 May 2014 - 09:55 AM

make sure your time and date are right on all pc's that want to connect to Google by ssl



#5 donetao

donetao

  • Members
  • 270 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:00 PM

Posted 13 May 2014 - 11:53 AM

Hello! Here's away around that annoying certificate problem until IE gets it fixed.

1. Click the Tools->Internet Options menu item.

2. Click the Advanced tab.

3. Scroll down to Security.

4. Uncheck the "Check for Server Certificate Revocation" checkbox.

5. You might also want to uncheck the checkbox above it for Publisher's revocation

6. Click OK.



#6 Wafflemonger

Wafflemonger

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:00 PM

Posted 13 May 2014 - 01:01 PM

You may wish to attempt to clear the cache and restart the PC. Also, attempting to visit the site from different browsers can produce different results. My work uses FF, Chrome and IE (User preference) and some issues that appear in FF are not present in Chrome and vice versa.



#7 donetao

donetao

  • Members
  • 270 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:00 PM

Posted 13 May 2014 - 02:16 PM

Hello! If Setting the time and date and up dating to the latest version of the browser doesn't solve the problem, then you may want to disable the option in IE as I described above. As far as I know Firefox and chrome don't allow you do disable certificate verification. Make sure  you have the latest version. I'm sure they will get it solved before long. There are a lot of changes going on the internet. Some are good and some I'm not sure what's going on. We will have to live with it. As far as I know there is only one internet!



#8 wing987

wing987

  • Members
  • 177 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Payette, ID
  • Local time:04:00 PM

Posted 13 May 2014 - 02:58 PM

Given that heatbleed caused as many problems as it did, any site that did not change their certificate would be untrustworthy.  That being said, most sites use a verifying authority, in the case of google they issue and verify their own certificates.  This normally is automatic and the user never see's the certificate change. However, you can check the vertificate and ensure it is issued by, and verified by google (not Googlie, goigle, or anything CLOSE but not quite right) then you can add that certificate to the trusted root certificates in IE (which is used by more than just IE). If you find that the certificate is not accurate, which is what your computer is telling you, then you will want to check that you do not have an issue with DNS poisioning and that your are legitimately accessing google.com's IP address.

 

I know it is unlikely, but you might have had a probelm with heartbleed, or your computer may have just not caught up to the changes.


-- Windows 7 Ultimate on custom built system, Windows 10 on under powered laptop. Sophos UTM 9, Ubuntu Server and Windows Server 2008 R2. HyperV Virtualization --

 

"The hottest places in hell are reserved for those who in a period of moral crisis maintain their neutrality," John F. Kennedy


#9 Gileraracer

Gileraracer
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:12:00 AM

Posted 14 May 2014 - 02:17 AM

Damn this problem starts getting strange...

 

 

of course i checked date / time, everything fine with that. Even unchecking "Check for Server Certificate Revocation" and the on above didn't fix the problem, still the certificate error.

 

I deleted the local User profile (cached AD profile) and readded it on the same PC an the problem was gone ... everything fine on this machine now.

 

But why should a user profile make problems with certificates?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users