Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Flash Drive not working in Windows 7 PC (But works in another Win7 Machine)


  • Please log in to reply
1 reply to this topic

#1 Genetic517

Genetic517

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:15 PM

Posted 05 May 2014 - 09:32 PM

 

hello everyone, hope you guys can help me.

problem: im not able to view my files on my Sandisk 8gb flash drive. i plug it in, i hear the device sound, but nothing else happens. if i go into disk management the device is there, and i also see it properly installed in device manager. ive tried my plugging in my phone (have a ext. sd card) and a external hard drive and both work just fine. i plug this flash drive into my other windows 7 pc and it pops up instantly.

What ive tried to fix issue:

1. i removed the drivers and tried to reinstall. once i uninstall and reinstall the flash drive works perfectly the first time i plug it in , but then once i remove and plug it back, im back to square one

2. ive ran drivecleaner to completely remove EVERY usb driver install, no joy.

3. ive tried changing the drive letter, no go.

4. i formatted the flash drive twice in fat32 format

5. motherboard drivers are up to date, all windows updates installed

6. i ran virus/spyware/malware scan. nothing found

Any help would be greatly appreciated (seriously, i need this working!) . thank you in advance for your time and help.

- Justin

 

edit: just forgot to add the flash drive works properly if i boot into safe mode.


Edited by Genetic517, 05 May 2014 - 10:07 PM.


BC AdBot (Login to Remove)

 


m

#2 czarboom

czarboom

  • Members
  • 608 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Central Texas
  • Local time:05:15 PM

Posted 06 May 2014 - 02:28 AM

Do you have admin rights when you plug in your USB drive?  If not that can throw issues with windows.

 

Dont plug in your phone at all, reboot try the USB again.  Try taking it out and plug it in again.  Make sure your safely uninstall the USB drive, don't just rip it out.

 

Did you try all the USB ports? 

 

Does the device show up in the device manager when it stops working?  If there is a yellow symbol near it go to scan disc website and see if there are drivers there for it.

 

Other things can be your phone, it can mess up USB drivers.  Look at the website of the phone for updates to drivers.

 

If all else fails you can download and reinstall your chipset and BIOS drivers.  A error could be causing it.  A refresh can fix it sometimes. (do a backup and restore with recovery disk before you do this just in case something happens).

 

good luck and let me know if you need anything else


CZARBOOM 
 
"Never Stop Asking Questions, Question Your Environment, Question Your Government, above all Question Yourself.  We all lose when you Stop asking Why?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users