Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Block internet access for one PC in thIs system


  • Please log in to reply
4 replies to this topic

#1 NorbertA

NorbertA

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Germany, Black Forest Mountains
  • Local time:07:53 AM

Posted 04 May 2014 - 08:28 AM

Hi,

 

I am operating a small home network with three computers and one printer all connected by WLAN to a router and then to the internet. One of the PCs is running on XP, and I want to keep it that way, for some of my older programs do not run under W7 or W8. As XP is no longer supported by Windows patches, I think it a good idea to shut it off from the internet. But how?

 

I could just shut off the WLAN-manager - but once in a while I need to have this PC connected to the system for access to the printer. And it is the safety of this PC I am concerned about during the time while it is connected to the network.

 

My wife and me, we are the only users, so it is not a matter of blocking users from willingly accessing the internet, but I would want to have blocked all the background jobs and automatic updates and information seekers  and whatever else hooks up to the internet on its own.

 

How to set about?

 

- disable automatic updates of course

- uninstall progs under the suspicion of doing background jobs with the internet

 

Anything else?

Any way to make sure I got them all?


Edited by hamluis, 12 May 2014 - 07:43 AM.
Moved from XP to Networking - Hamluis.


BC AdBot (Login to Remove)

 


#2 klink1956

klink1956

  • Members
  • 79 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Rochester, New York
  • Local time:01:53 AM

Posted 04 May 2014 - 05:13 PM

Hi NorbertA,

I have the same deal going on.All I did was re-set the permisions manually on my firewall. I blocked everything but my printer, it worked like a charm.

When I don't have a need for my printer I just block all internet connections. Right click and done.

I used Privatefirewall small,easy to use and free.

Somebody may have a better idea and if so I may change my approach.

Bob

 
Where ever you go.................. There you are

#3 NorbertA

NorbertA
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Germany, Black Forest Mountains
  • Local time:07:53 AM

Posted 06 May 2014 - 02:30 AM

Thanks Bob.

 

I will do just the same.

 

Norbert



#4 NorbertA

NorbertA
  • Topic Starter

  • Members
  • 14 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Germany, Black Forest Mountains
  • Local time:07:53 AM

Posted 12 May 2014 - 07:05 AM

Somebody gave me the idea to block the PC in question from accessing the internet by configuring the router.

 

And this works just fine. You should look up the router documentation, for this is not a very straightforward business, at least as it occurred to me on my not too new router. THe option can be found under Security/Filters. Filters had to be activated and provided with a rule ('block access at all times'), then I could select my PC and then set the ports that should be blocked ( I selected all TCP and UCP ports).

 

I can still access the printer but not the internet from this PC.

 

Mission accomplished.



#5 cessna172

cessna172

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:06:53 AM

Posted 18 May 2014 - 03:37 PM

Set ip address in tcp/ip properties assign static ip for your network but put the dns server as 192.168.0.0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users