Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB file system corrupted to RAW


  • Please log in to reply
1 reply to this topic

#1 unseen wombat

unseen wombat

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:11:45 AM

Posted 01 May 2014 - 02:15 PM

Please help me. Somehow my USB thumb drive's file system type got changed to RAW, and now every time I try to open it it says I need to format it.

Google search for "USB recover raw" yielded absolutely worthless advice. Every thread or blog I read recommended software that tells me it can't recognize the file system on the disk, or if it does manage to even see the disk, it says it can't find any files. I find it hard to believe that the data is completely gone, as windows realizes that it's a 16gb sandisk cruzer, but it just won't open the files.

Can someone give me a REAL solution to this? I tried about half a dozen "data recovery" programs: ZAR, easeUS, 4care, iCardRecovery, Recover My Files... IDK what else.

Even M3RAWtoFAT32 which is supposed to be SPECIFICALLY for converting USB drives that have been corrupted to RAW just stares at me blankly and my disk isn't even recognized.

Please help. I have backed up the data, but not as often as I should have. The most recent backup is like from 8 months ago.

 

Some guy on a slightly less-than-reputable forum told me that I can use some command line code in dd for windows: dd count=1 bs=512 if=/dev/zero of=/dev/sdx && sync

I have no idea what any of that even means, and I worry that it might be something like the "delete system 32" gag. He said that it rewrites the first 512 MB of the drive to MBR, whatever that means.

Is that a viable way of getting my disk to work or getting my data back?

Sorry if this is in the wrong sub-forum, if so, please move it to the right one.


Edited by hamluis, 01 May 2014 - 04:11 PM.
Moved from XP to External Hardware - Hamluis.


BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 22,919 posts
  • ONLINE
  •  
  • Gender:Male
  • Local time:11:45 AM

Posted 01 May 2014 - 03:08 PM

dd count=1 bs=512 if=/dev/zero of=/dev/sdx && sync

 

 

I believe the above command would wipe your partition table and you would not want to do that. Because you have tried many recovery programs and nothing worked, the following may not work either but you can give it a try. Follow the instructions here. You can download the last free version of Parted Image Magic here. You will have to create a bootable CD using Imgburn or other burning software that can burn an image. When installing imgburn, make sure to opt out of any optional software. Do not write anything back to the flash drive if you do not see your files and make sure you are scanning the flash drive and not your internal hard drive(s).


Edited by JohnC_21, 01 May 2014 - 04:17 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users