Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Java installed, but Scottrade Streaming Quotes not opening


  • Please log in to reply
8 replies to this topic

#1 Spaceship

Spaceship

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:03:35 AM

Posted 19 April 2014 - 01:25 PM

Hello all and thank you for the interest in my problem.

 

I just bought a new Asus computer (Asus Q501LA) with Windows 8.1 operating system. I downloaded and installed Java and based on the tests on Java website it seems to be working. I tested here: http://www.javatester.org/version.html and here: http://java.com/en/download/uninstallapplet.jsp

It says I have Java version 7 update 55.

 

Now the problem is that when I try to open Scottrade Streaming Quotes which is a Java based platform, then the Java installation starts again and after the installation nothing happens. I have Java enabled on all browsers and I tried it with Internet Explorer, Firefox and Google Chrome. Latest versions of everything. Each time I try to open Scottrade Streaming Quotes, Java set-up/installation starts and after that is finished, the Streaming Quotes still does not open. No error messages or anything.

 

Has anyone had a similar problem or knows how to help? I already uninstalled my antivirus and firewall (AVG), because originally it was causing some problems. Then I uninstalled Java and installed again. Did multiple restarts in between the different uninstallations and installations. What should I do now?

 

Thank you!

 



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 23,281 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:35 AM

Posted 19 April 2014 - 03:05 PM

Hello, and Welcome

 

You can try a couple of things. First, open up control panel and if you have Windows 7 or Vista, select Icon view (Large or Small). Double click the Java icon and select the Security tab. Press Edit Site List, press ADD and enter your Https// Scottrade Url in the dialog window.

 

If that doesn't work, lower the Security settings to Medium. But, I would advise you change it back after leaving Scottrade. I believe Firefox disables Java as default (in Add-ons > Plugins).



#3 Spaceship

Spaceship
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:03:35 AM

Posted 19 April 2014 - 04:10 PM

Hello John, thank you. I tried all this now, but it didn't help.



#4 JohnC_21

JohnC_21

  • Members
  • 23,281 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:35 AM

Posted 19 April 2014 - 04:12 PM

I am not sure what the problem would be? You may want to contact Scottrade support and ask them. I know I have had some problems getting java apps to load right.

 

Edit Have you seen this page for configuration of browsers? Not sure if will help though.


Edited by JohnC_21, 19 April 2014 - 04:17 PM.


#5 Spaceship

Spaceship
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:03:35 AM

Posted 19 April 2014 - 04:23 PM

Thank you. I was wondering if the issue has something to do with Windows 8.1? I previously used the Scottrade Streaming Quotes on Windows XP and it worked well. I also found someone else who posted a solution to a similar problem: https://www.facebook.com/Scottrade/posts/10152274970820372 I wonder if the program normally works on Windows 8.1 and is there a simple solution or do I have to do what is described in the link...

 

If I don't get it to work then I'll contact Scottrade support on Monday and ask them.



#6 JohnC_21

JohnC_21

  • Members
  • 23,281 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:35 AM

Posted 19 April 2014 - 04:29 PM

Did you see my previous post. I linked to Scottrade on how to config the browsers. Not sure if it work though. Yea, I am not familiar with Windows 8.1 but I know it has had a lot of issues especially in regards to drivers.

 

Before you go through the steps in the link you provided, I would contact Scottrade first. If they cannot resolve the problem then you can try the steps listed but I would backup any important data first. Better yet, I would make a disk image with something like Macrium Free if you have an external drive to save the image to. Macrium Free lets you create a bootable disk to restore the computer in case the computer does not boot do to a corrupted file system or malware.

 

I did notice that the DirectX link the poster linked to showed system requirements and Windows 8.1 was not included.

 

Edit: Windows 8.1 comes with DirectX 11.2 but I am not familiar with it enough to know if it has backwards compatibility

 

Edit Edit:  The poster may be on to something by installing DirectX9 components. Maybe this is needed to run your Streaming Quotes.

 

http://support.microsoft.com/kb/179113

 

Install DirectX End-User Runtime if your application or game requires an earlier version of DirectX Some applications and games require DirectX 9. However, your computer includes a more recent version of DirectX. If you install and then run an application or game that requires DirectX 9, you might receive an error message such as "The program can't start because d3dx9_35.dll is missing from your computer. Try reinstalling the program to fix this problem."

To resolve this issue, go to the following Microsoft website to install DirectX End-User Runtime:

Note When you run this package, no change is made to your version of DirectX, Direct3D 9, Direct3D 10.x, Direct3D 11.x, DirectInput, DirectSound, DirectPlay, DirectShow, or DirectMusic.

 


Edited by JohnC_21, 19 April 2014 - 04:44 PM.


#7 Spaceship

Spaceship
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:03:35 AM

Posted 22 April 2014 - 09:56 PM

Problem solved!

 

I called Scottrade technical support and their instructions helped. The solution was to open Control Panel > Default Programs > Associate a file type or protocol with a program. There I had to find the file extension .jnlp from the list and change the Current Default to Java Web Start Launcher. Simple! Works now. :)



#8 boopme

boopme

    To Insanity and Beyond


  • Global Moderator
  • 73,078 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NJ USA
  • Local time:03:35 AM

Posted 23 April 2014 - 02:00 PM

Thanks for posting back your solution that may help another in this situation.


How do I get help? Who is helping me?For the time will come when men will not put up with sound doctrine. Instead, to suit their own desires, they will gather around them a great number of teachers to say what their itching ears want to hear....Become a BleepingComputer fan: Facebook

#9 yvrao

yvrao

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:11:35 PM

Posted 18 November 2014 - 08:22 AM

Java Verify failure  unable to Configure Java Control Panel does not open ( Fix : ) 
this is a regular ( windows 7 bug related ) problem after successful installation of Java ( jre ) and fresh installation of Windows7 64bit or 32bit on my laptop or desktop.  what worked perfectly for me was setting  COMPATIBILITYMODE=WINDOWSNT  to make windows launch the JP2LAUNCHER.EXE  and  JAVAW.EXE  files properly.
jp2launcher.exe windowsNT compatibilty solves Java Verify failure problem at  https://www.java.com/en/download/installed.jsp   
javaw.exe windowsNT compatibilty solves unable to open or Configure Java Control Panel problem.
 
    *  search for JAVAW.EXE   inside  c:\program files\java\....\bin   
          or  c:\program files(x86)\java\.....\bin\
    *  right-click mouse on  JAVAW   application icon logo
    *  click  PROPERTIES
    *  click  COMPATIBILITY
    *  tick the checkbox at COMPATIBILITY MODE
    *  choose  WINDOWS NT service pack
    *  click APPLY or click OK
Now, the Configure Java Control Panel will start opening and working.
 
 
    *  search for JP2LAUNCHER.EXE   inside  c:\program files\java\....\bin   
          or  c:\program files(x86)\java\.....\bin\
    *  right-click mouse on  JP2LAUNCHER
    *  click  PROPERTIES
    *  click  COMPATIBILITY
    *  tick the checkbox at COMPATIBILITY MODE
    *  choose  WINDOWS NT service pack
    *  click APPLY or click OK
Now, the Verify Java will be successful at  https://www.java.com/en/download/installed.jsp 
 
 
if we find 2 or 3 versions of JP2LAUNCHER and JAVAW when we search, then we must repeat the above for all of them.
 
 
in the Configure Java Control Panel Advanced tab we can set "Do not check" certificate revocation and disable security verification. and in the Security tab we may Edit Site List... for the Exception Site List  ( add URLs to  unblock sites )





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users