Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Device Icon No Longer Appears


  • Please log in to reply
25 replies to this topic

#1 gben123

gben123

  • Members
  • 84 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:44 AM

Posted 11 April 2014 - 11:30 AM

On my Lenovo Win7 laptop, the icon for a USB device no longer appears when I plug that device in. Consequently I can't be certain that it is safe to disconnect. This happens with all devices. I do get a beep upon plugging the device in and it is recognized in Windows Explorer.



BC AdBot (Login to Remove)

 


#2 Roodo

Roodo

  • Members
  • 760 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:44 AM

Posted 11 April 2014 - 11:55 AM

Start, Run, paste this line and click OK:

C:\WINDOWS\system32\rundll32.exe shell32.dll,Control_RunDLL hotplug.dll

This will bring up the add remove wizard.



#3 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,358 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:44 AM

Posted 11 April 2014 - 11:56 AM

Let's rebuild the icon cache and see if this resolves the issue.
 
1)  Restart your computer, click on Start to open the Start menu, click on All Programs, then Accessories.  You will now see Command Prompt, click on this to open the Elevated Command Prompt.  You will see an image like the one below.
 
commandprompt_zps212bc71a.png
 
2)  In the Command Prompt, copy and then paste each of the following commands one at a time and then press Enter after each command. 
 
ie4uinit.exe -ClearIconCache
 
taskkill /IM explorer.exe /F
 
DEL "%localappdata%\IconCache.db" /A
 
shutdown /r /f /t 00    Notice:  This command will close Explorer and restart the computer when complete.
 
3)  The IconCache.db should now be rebuilt 

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#4 gben123

gben123
  • Topic Starter

  • Members
  • 84 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:44 AM

Posted 11 April 2014 - 01:06 PM

This set of commands produced no change. I should add that the eject option when I right-click the device in an explorer window does not show up. Not certain exactly when this behavior began. I'm also noticing now that two USB ports don't show the device in My Computer even though I hear a beep upon inserting the USB cable of the device. However a third plug that is for some other interface but can also receive a USB plug does cause the device to appear in My Computer but still no icon or eject option



#5 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,358 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:44 AM

Posted 11 April 2014 - 01:17 PM

While I do a little more looking around please try using the hidden icons in order to use the Safely Remove Hardware and Eject Media.  There is a white diamond in the taskbar close to the clock, if you click on this it will open the hidden icons.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#6 gben123

gben123
  • Topic Starter

  • Members
  • 84 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:44 AM

Posted 11 April 2014 - 01:29 PM

Are you talking about the little popup that shows the icons not on the taskbar? That's just it, the icon isn't there either:

 

I tried pasting a screenshot of the popup but when I tried to post it it wouldn't accept it so there's a Word file attached with the image pasted in it.



#7 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,358 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:44 AM

Posted 11 April 2014 - 01:33 PM

You can post the screenshot in your next post as an attachment.  
 
Just below the area where you write text in a post there is the Post button, to the right of this is More Reply Options
 
Post2_zpsf05c0430.png
 
When you click on More Relpy Options  you will see Attach Files and Browse, click on Browse, this will open Pictures on your computer, click on the image you made with the, then click on Attach This File, then Add Reply.
 
BCreply1_zpsc36d42fc.png 

Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#8 gben123

gben123
  • Topic Starter

  • Members
  • 84 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:44 AM

Posted 11 April 2014 - 01:34 PM

That's what I did



#9 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,358 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:44 AM

Posted 11 April 2014 - 01:44 PM

The only thing I could image is that the file is too large.  You could try posting here via a host website like photobucket.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#10 gben123

gben123
  • Topic Starter

  • Members
  • 84 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:44 AM

Posted 11 April 2014 - 01:56 PM

Try again.

 

Turns out it wouldn't let me attach that kind of file (God only knows why) and I didn't see the error message. Here it is again

Attached Files



#11 Roodo

Roodo

  • Members
  • 760 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:44 AM

Posted 11 April 2014 - 01:56 PM

Go to My Computer (right click) > Manage > Services and Applications > Services

Search the list for the following entry "Plug and Play" and double click on it.

The properties window should appear.

IS the Startup Type set to "Automatic"?



#12 gben123

gben123
  • Topic Starter

  • Members
  • 84 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:44 AM

Posted 11 April 2014 - 02:12 PM

Yes



#13 dc3

dc3

    Bleeping Treehugger


  • Members
  • 30,358 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Sierra Foothills of Northern Ca.
  • Local time:09:44 AM

Posted 11 April 2014 - 02:26 PM

Let's try the simplest first.  Open the Control Panel and click on Notification Area Icons and look at the bottom of the page for Always show all icons and notifications on the taskbar.  There is a check box just in front of it, make sure there is not a check mark in it.

 

Go to this website and scroll down to Option 2.


Family and loved ones will always be a priority in my daily life.  You never know when one will leave you.

 

 

 

 


#14 gben123

gben123
  • Topic Starter

  • Members
  • 84 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:44 AM

Posted 11 April 2014 - 02:34 PM

The device does not appear in the 'Safely Remove Hardware' popup even though it is present in My Computer



#15 gben123

gben123
  • Topic Starter

  • Members
  • 84 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:44 AM

Posted 12 April 2014 - 06:15 PM

I looked into other options in the article and what I find doesn't jive with what the article shows. Here's a screenshot of device properties after installing the regisitry files shown in the article

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users