Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Canon printer showing "offliine" now


  • Please log in to reply
6 replies to this topic

#1 Dborns

Dborns

  • Members
  • 201 posts
  • OFFLINE
  •  
  • Local time:02:29 AM

Posted 06 April 2014 - 04:46 PM

I have an asus running windows 8 that I got all setup and had working fine.  I was able to print wirelessly to my Canon printer with it for a few days, but now when I try it won't work.  The printer shows up under all the printers, and it has a green check next to it, but its showing offline.  If I try to print, a pop up box shows the same thing, that its offline.  I've tried shutting the printer off and on, but that does nothing. 

 

Thanks for any suggestions.



BC AdBot (Login to Remove)

 


#2 Kilroy

Kilroy

  • BC Advisor
  • 3,411 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Launderdale, MN
  • Local time:02:29 AM

Posted 07 April 2014 - 09:28 AM

Best suggestion would be to uninstall and reinstall the printer on the computer.  Normally I recommend setting a static IP address for network printers.  This prevents not being able to print if the printer receives a different IP address.  Normally the IP address should be outside your normal DHCP range.



#3 Dborns

Dborns
  • Topic Starter

  • Members
  • 201 posts
  • OFFLINE
  •  
  • Local time:02:29 AM

Posted 07 April 2014 - 04:14 PM

Thank you for your reply.  I'll try the uninstall/ install procedure. 



#4 FrankOtheMountaiN

FrankOtheMountaiN

  • Members
  • 529 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NY
  • Local time:03:29 AM

Posted 07 April 2014 - 10:09 PM

I'm guessing that your printers (WIFI) IP changed too. You should set it to an IP that never changes (static) when you are installing it. I have a printer at work (that we rent out), so I never set it to static IP, and it shows up as offline when I go to use it (at work). You could change the printers IP/port on the fly, but 1st you have to know the IP that the printer is currently using. You can use NetScan for that. It's free.

 

Next go to control panel/devices & printers/ right click on your offline cannon, & select "printer properties".

Select the "port" tab, then press the "configure port" button.

Under the "printer name or ip address", enter your printers new ip as observed in Netscan. I don't think you can rename the "port name", which is probably the old IP, but that doesn't matter for functionality. Hit OK, and the printer should pop online now.

 

It easier to set the printers IP to static (on the cannons menu). Just thought you might want a long winded workaround!


Edited by FrankOtheMountaiN, 07 April 2014 - 10:10 PM.


Frank O' The Mountain
Doing more stupid before 5AM than most people do all day.


#5 Dborns

Dborns
  • Topic Starter

  • Members
  • 201 posts
  • OFFLINE
  •  
  • Local time:02:29 AM

Posted 09 April 2014 - 09:52 PM

Thanks for the suggestions!.


Edited by Dborns, 09 April 2014 - 09:59 PM.


#6 Dborns

Dborns
  • Topic Starter

  • Members
  • 201 posts
  • OFFLINE
  •  
  • Local time:02:29 AM

Posted 13 April 2014 - 03:48 PM

Ok, last week I was still having issues where my notebook was showing "offline" and "not connected" on the canon mg3200 printer.  A friend was over, and went through the computer so fast, I didn't see what he did, but it was changed back. 

Even after taking the notebook to work for a few days, and bringing it home, it would "find" the printer and work ok.  But now again, this morning after bringking he computer home from work, it showed it offline again.  I ended up removing the printer from the notebook in control panel, and hooked up the usb cable to it.  It automatcally set everything back up again and worked fine. 

So the issue seems to be an intermittent problem when I take the computer from home and it tries to reconnect to everything.  It doesn't find the printer when I search for available devices, and now it looks like I'll have to reconnect the usb everytime.

 

So I left the usb connected, and it printed fine.  But when I disconnect the usb, it goes offline and not connected.  So for some reason, its not finding the wi-fi.  Our other laptop prints to it just fine through wifi.

 

Any suggestions?


Edited by Dborns, 13 April 2014 - 03:53 PM.


#7 FrankOtheMountaiN

FrankOtheMountaiN

  • Members
  • 529 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NY
  • Local time:03:29 AM

Posted 13 April 2014 - 10:26 PM

You need to learn how to set a static IP for your wireless connection on your printer. You have several devices fighting over the same IP.

 

I'll try to keep it short.

 

OK, you have ONE external/outside world (WAN) IP address assigned by your provider. eg 92.34.123.456 One cable line/one IP.

Each device you use requires a separate IP address. They cannot share the same IP. so....

You use a router to divy up your one IP into sub IPs. (You might have a modem/router combo from your provider).

The router gives itself it's own internal (LAN) IP address (eg 192.168.1.1). This is your internal/inside home network.

So by default, the router is set to automatically give devices on your network IPs (DHCP) when they come onto the network.

The default range is usually something like 192.168.1.100 through 192.168.1.255

 

Let's say your laptop is the 1st thing to come on the network. The router (gateway) will assign your laptop 192.168.1.100.

Now let's say you have 2 other computers join the network. They would get 192.168.1.101 and 192.168.1.102,

providing they are all powered on, and on the network. Now the printer enters the network and gets 192.168.1.103.

 

Here's where it get's fun. You set up your printer to automatically get an IP address during it's setup, so it grabbed the 1st one available,

which was 192.168.1.103 in our scenario. Now say one computer (192.168.1.101) leaves the network/powers off and printer powers off.

 

Now you turn the printer on, and it gets assigned the 192.168.1.101 IP.  Then you turn on the laptop, and it gets assigned 192.168.1.103.

The IPs have now switched, and the Windows is still looking for the printer on the old original IP of 192.168.1.103, but it's not there anymore.

 

The way to stop the insanity is to set static IPs on your devices, or at least on your printer. Go into your printers setup menu and find the area about it's IP address. You want to switch it from DHCP to static, or manual IP. Set the suffix to something a bit higher than the 1st few available #s. For example, 192.168.1.122.  This way it's not conflicting/fighting with other (lower IP #) devices over the same IP.

 

I set device on my network as static, so each device has and retains it's own IP.

You can do the printer setup again, but this time pick the option to manually set the IP.

If you use netscan (link above), you can see the general range of IPs on your network. 

Now the printer will always show up as online. Make sense?


Edited by FrankOtheMountaiN, 13 April 2014 - 10:29 PM.


Frank O' The Mountain
Doing more stupid before 5AM than most people do all day.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users