Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Canon printer showing offline and won't print thru wifi


  • Please log in to reply
20 replies to this topic

#1 Dborns

Dborns

  • Members
  • 201 posts
  • OFFLINE
  •  
  • Local time:07:12 AM

Posted 04 April 2014 - 05:22 PM

I have an asus running windows 8 and a canon mg3200 printer.  When I first got the asus, I had it setup correctly and could print wirelessly to the canon printer.  Today, I tried to send a document over wifi, and I have a pop up box showing that the printer is "offline".  If I go to the control panel, its showing the printer and that its the default printer, but its also showing "offline".  I've turned the printer on and off with no change.  The wifi light is lit on the printer, and our other laptop which is connected wirelessly prints to it just fine.  How can I get the printer back "online"? 

 

Any suggestions?



BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:12 AM

Posted 04 April 2014 - 05:35 PM

Under Devices and Printers, double click your printer. A window should pop up. In the menu bar click Printer and make sure Use Printer Offline is not checked.


Edited by JohnC_21, 04 April 2014 - 05:35 PM.


#3 Dborns

Dborns
  • Topic Starter

  • Members
  • 201 posts
  • OFFLINE
  •  
  • Local time:07:12 AM

Posted 04 April 2014 - 06:18 PM

Ok, I tried that and can't get that far.  I don't know if its different because its windows 8 or not but heres what I can do:

Control panel to "hardware and sounds" to "devices and printers"

The printers show up and the canon is pictured with a green checkmark on it, but if you scroll over it, a small popup box comes up and says, "Status: offline, status: not connected". 

If I right click on the canon printer, the only line checkmarked is "set as default printer", but theres nothing about "use printer offline".



#4 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:12 AM

Posted 04 April 2014 - 07:25 PM

I am not that familiar with 8 but double click the printer with the green checkmark. Does a window pop up?

Edited by JohnC_21, 04 April 2014 - 07:25 PM.


#5 Dborns

Dborns
  • Topic Starter

  • Members
  • 201 posts
  • OFFLINE
  •  
  • Local time:07:12 AM

Posted 04 April 2014 - 07:51 PM

Yes if you can read this, its what comes up:

photo_zps85481bd6.jpg



#6 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:12 AM

Posted 04 April 2014 - 08:03 PM

Sorry, I thought Windows 8 would be similar to Windows 7. I guess not. I will investigate this further unless somebody on the Forum knows how to place the printer online in Windows 8.

 

Edit: See this link. You right click the printer with the green checkmark. Select See What's Printing and then click Printer in the Window.

 

http://www.sysprobs.com/how-to-set-printer-online-in-windows-8-offline


Edited by JohnC_21, 04 April 2014 - 08:09 PM.


#7 Dborns

Dborns
  • Topic Starter

  • Members
  • 201 posts
  • OFFLINE
  •  
  • Local time:07:12 AM

Posted 04 April 2014 - 08:46 PM

Ok, I did that, and the "use printer offline" isn't checked.  If I go back to the printer in devices, its still showing offline and not connected.



#8 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:12 AM

Posted 04 April 2014 - 08:49 PM

The only thing I can think of is to uninstall and reinstall the printer driver.

 

Edit: Have you tried rebooting the computer after this issue appeared?

 

From Canon Support.  Has a good setup guide link to a pdf.

 

http://forums.usa.canon.com/t5/Wireless-Networking/MG3200-Pixma-Printer/m-p/71493#U71493


Edited by JohnC_21, 04 April 2014 - 09:16 PM.


#9 philken

philken

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:12 PM

Posted 15 October 2014 - 08:40 AM

Hi - were you sucessful with this - I have just encountered the same probem with my canon MP640



#10 Ivy74

Ivy74

  • Members
  • 219 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Behind a keyboard
  • Local time:08:12 AM

Posted 15 October 2014 - 10:51 AM

First things first:

9x's out of 10 the IP of the network printer changed. The home printers tend to get around this issue by using the full package software that looks for it by MAC address as well as IP and updates your machine as it changes. The best solution is to set a static IP on the printer itself but I won't get into that too much right now.

 

The ideal solution is not just unistall the drivers and reinstall but uninstall the entire software suite to the printer reboot then reinstall.

 

Also, to rule out IP it's best to Ping it (Google ping an IP). How to determine the IP there is many ways but if you are lucky and Google the printer model it might list a way.

 

Also, a printer that you connect to via IP (WIFI or wired) will NOT show on Device Manager unless there is something knew I don't know about.


Edited by Ivy74, 15 October 2014 - 10:53 AM.

***Note***

My job has blocked Europe by the firewall which means I can't access this site from the office anymore. So I will barely be here if at all. In case you cared.  :smash:


#11 rickjames8

rickjames8

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:12 AM

Posted 23 February 2015 - 08:32 PM

Ivy74-

 

Thank you!!  You may have just solved a problem that has plagued us for a long time now!   Our Canon printer worked perfect for a while, then some days it just would not print.  The idea that it was a dynamic IP issue never occurred to me.  I changed it to static and now it works perfect.  

 

For anyone who doesn't get this static/dynamic concept:  Every device on your wifi network is given a number, called an IP address.  When your printer is turned on, it says hello to your router, and asks for a new IP (this is called dynamic IP).  The router gives it a number, let's call it "...10". When your laptop looks for your printer for the first time, it finds it at "...10" and remembers that number.  When the printer shuts down for the day, it lets go of that number.  So when your kid logs on with an iPad and that iPad says to the router "I need a number" the router gives the iPad "...10".   So then the printer comes on later and says "I need a number" and it gives it "...11".   Then your laptop tries to print, it looks for the printer at "...10", doesn't see it and thinks it's offline.  Like Ivy74 said, software should account for this, but in my case it has not.  So you need to change your printer to instead say to your router "Hey, I'm the printer and I want number "...50" (this is called static IP), or some number higher than the number of devices in your house.  Then have your laptop find the printer again as if finding it for the first time, they'll find it at "...50" and it will always be at "...50".

 

Here's how to do that on my printer, which is an MG5400 series.  

 

(For the record, IP addresses are in the format: 192.168.1.50 (I abbreviated the examples above))

 

Setup --> Device Settings -->  LAN Settings -->  Other Settings --> TCP/IP Settings --> IPv4 --> Yes --> IP address --> Manual Setup -->

 

192.168.001.050 (050 can be any number you want it to be from 0-255, but I recommend something high enough to avoid conflicts)

255.255.255.000

192.168.001.001

 

Hit the back button repeatedly to back out to main menu.

 

This has worked for me.  



#12 reast82

reast82

  • Members
  • 18 posts
  • OFFLINE
  •  
  • Local time:05:12 AM

Posted 26 February 2015 - 08:47 PM

WS means you have a web services driver installed. remove the printer and reinstall as wired or LAN connection, not wireless (I know, it seems counter intuitive). Let me know if you need more help.



#13 luar3d

luar3d

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:12 AM

Posted 06 March 2015 - 06:31 PM

rickjames8,

 

I have the same exact problem right now but I'm not sure how to go about it with my Canon MG3200 series printer. Does anyone know where to find this as described above by rickjames8?

 

Where is this:   Setup --> Device Settings -->  LAN Settings -->  Other Settings --> TCP/IP Settings --> IPv4 --> Yes --> IP address --> Manual Setup -->

 

Thanks.



#14 JohnC_21

JohnC_21

  • Members
  • 24,668 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:07:12 AM

Posted 07 March 2015 - 11:54 AM

One thing you may try. I am not sure if it will work though. Find the IP of the printer. Open a browser and type the IP in the address bar. You should get the Web interface of the printer. From there you may be able to change the IP to a fixed IP address.

#15 callbox

callbox

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:12 AM

Posted 26 May 2015 - 08:24 PM

just fix mine you must create a homegroup  for it  and HAVE THE  the WINDOWS services >  PnP- X ip bus Enumerator.. active /start  ON






4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users