Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cisco Switch and Linksys Router Configuration help!


  • Please log in to reply
6 replies to this topic

#1 briggs&straton

briggs&straton

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:02:46 PM

Posted 20 March 2014 - 10:18 PM

Hello there,
 
So I have been working on this configuration for a couple of days now and I am just stumped.
 
 
I just received a Cisco Catalyst ws-c3750g-48ps switch (great switch by the way), I dont have a fully managed router to go with it though.  So what I am try to do it using my Linksys E3000 router as my gateway out to the internet.  Here is the configs I have running on the switch:

 

Building configuration...

Current configuration : 2928 bytes
!
version 12.2
service config
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
enable secret 5 $1$N37I$irvqwCUVtPjYWGrHgSUJY1
enable password xxxxx
!
no aaa new-model
switch 1 provision ws-c3750g-48ps
system mtu routing 1500
vtp domain F8
vtp mode transparent
ip subnet-zero
ip routing
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2
!
vlan 1004
 bridge 1
!
vlan 1005
 bridge 1
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 ip dhcp relay information trusted
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
 switchport access vlan 2
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface GigabitEthernet1/0/29
!
interface GigabitEthernet1/0/30
!
interface GigabitEthernet1/0/31
!
interface GigabitEthernet1/0/32
!
interface GigabitEthernet1/0/33
!
interface GigabitEthernet1/0/34
!
interface GigabitEthernet1/0/35
!
interface GigabitEthernet1/0/36
!
interface GigabitEthernet1/0/37
!
interface GigabitEthernet1/0/38
!
interface GigabitEthernet1/0/39
!
interface GigabitEthernet1/0/40
!
interface GigabitEthernet1/0/41
!
interface GigabitEthernet1/0/42
!
interface GigabitEthernet1/0/43
!
interface GigabitEthernet1/0/44
!
interface GigabitEthernet1/0/45
!
interface GigabitEthernet1/0/46
!
interface GigabitEthernet1/0/47
 ip dhcp relay information trusted
!
interface GigabitEthernet1/0/48
!
interface GigabitEthernet1/0/49
!
interface GigabitEthernet1/0/50
!
interface GigabitEthernet1/0/51
!
interface GigabitEthernet1/0/52
!
interface Vlan1
 ip address 10.10.0.1 255.255.255.0
 ip helper-address 10.10.0.50
!
interface Vlan2
 ip address 72.15.0.1 255.255.255.0
 ip helper-address 10.10.0.50
!
ip default-gateway 10.10.0.3
ip classless
ip route 72.15.0.0 255.255.255.0 10.10.0.0
ip route 72.15.0.0 255.255.255.0 10.10.0.3
ip http server
!
!
control-plane
!
!
line con 0
 logging synchronous
line vty 0 4
 password xxxxx
 logging synchronous
 login
line vty 5 15
 password xxxxxxx
 logging synchronous
 login
!
end
 

 

 

I have my Server (Windows Server 2012 R2) running the DNS, DHCP, and AD DS.  On my DHCP server I have a superscope with two scopes, one is running the 10.10.0.0 IP Range and the other is the 72.15.0.0 both have a subnet mask of 255.255.255.0. 

 

I have accomplished to put a switchport Gigabitethernet 1/0/10 on VLAN 2 that I have setup and then linked back to the DHCP server, it pulls the IP Address like it should which is:

 

IP: 72.15.0.2

Mask: 255.255.255.0

Default Gateway: 10.10.0.3 (linksys router static ip)

DNS: 10.10.0.3; 10.10.0.50 <---- (DHCP server ip)
 

So now, when I am on the 72.15.0.0 scope on my computer I cannot get out onto the internet, but I can ping everything inside my LAN.  I did a TraceRoute Internal and External and nothing.  If I login to the router via web I can TraceRoute out.  When I TraceRoute out to google from CMD it stops at the router.  I can also ping both VLAN's on either one.  So this has to be a router issue. 

 

I guess you can say that I am confused on how I need to set the router up for VLAN 2 to get out to the internet. 

 

If someone could be of any assistance that would be great!!!



BC AdBot (Login to Remove)

 


m

#2 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:46 PM

Posted 21 March 2014 - 12:19 AM

75.15.0.0 is not a private IP. That can be the start of someone's IP address on the internet. You need to use private IP addesses. 


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#3 briggs&straton

briggs&straton
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:02:46 PM

Posted 21 March 2014 - 10:28 AM

Ok thanks. I'll definitely try that. Thank you.

#4 briggs&straton

briggs&straton
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:02:46 PM

Posted 21 March 2014 - 12:36 PM

ugh, I cant pull DHCP on vlan 2 anymore..



#5 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:46 PM

Posted 21 March 2014 - 01:25 PM

post up your new config, another set of eyes and all that =)


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#6 briggs&straton

briggs&straton
  • Topic Starter

  • Members
  • 20 posts
  • OFFLINE
  •  
  • Local time:02:46 PM

Posted 22 March 2014 - 01:11 PM

 

!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
switch 1 provision ws-c3750g-48ps
system mtu routing 1500
ip subnet-zero
ip routing
ip domain-list 8.8.8.8
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Loopback0
 ip address 10.10.2.1 255.255.255.0
!
interface GigabitEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,2,100
 switchport mode access
!
interface GigabitEthernet1/0/2
 switchport mode access
!
interface GigabitEthernet1/0/3
 switchport mode access
!
interface GigabitEthernet1/0/4
 switchport mode access
!
interface GigabitEthernet1/0/5
 switchport mode access
!
interface GigabitEthernet1/0/6
 switchport mode access
!
interface GigabitEthernet1/0/7
 switchport mode access
!
interface GigabitEthernet1/0/8
 switchport mode access
!
interface GigabitEthernet1/0/9
 switchport mode access
!
interface GigabitEthernet1/0/10
 switchport mode access
!
interface GigabitEthernet1/0/11
 switchport mode access
!
interface GigabitEthernet1/0/12
 switchport mode access
!
interface GigabitEthernet1/0/13
 switchport mode access
!
interface GigabitEthernet1/0/14
 switchport mode access
!
interface GigabitEthernet1/0/15
 switchport mode access
!
interface GigabitEthernet1/0/16
 switchport mode access
!
interface GigabitEthernet1/0/17
 switchport mode access
!
interface GigabitEthernet1/0/18
 switchport mode access
!
interface GigabitEthernet1/0/19
 switchport mode access
!
interface GigabitEthernet1/0/20
 switchport mode access
!
interface GigabitEthernet1/0/21
 switchport mode access
!
interface GigabitEthernet1/0/22
 switchport mode access
!
interface GigabitEthernet1/0/23
 switchport mode access
!
interface GigabitEthernet1/0/24
 switchport mode access
!
interface GigabitEthernet1/0/25
 switchport mode access
!
interface GigabitEthernet1/0/26
 switchport mode access
!
interface GigabitEthernet1/0/27
 switchport mode access
!
interface GigabitEthernet1/0/28
 switchport mode access
!
interface GigabitEthernet1/0/29
 switchport mode access
!
interface GigabitEthernet1/0/30
 switchport mode access
!
interface GigabitEthernet1/0/31
 switchport mode access
!
interface GigabitEthernet1/0/32
 switchport mode access
!
interface GigabitEthernet1/0/33
 switchport mode access
!
interface GigabitEthernet1/0/34
 switchport mode access
!
interface GigabitEthernet1/0/35
 switchport mode access
!
interface GigabitEthernet1/0/36
 switchport mode access
!
interface GigabitEthernet1/0/37
 switchport mode access
!
interface GigabitEthernet1/0/38
 switchport mode access
!
interface GigabitEthernet1/0/39
 switchport mode access
!
interface GigabitEthernet1/0/40
 switchport mode access
!
interface GigabitEthernet1/0/41
 switchport mode access
!
interface GigabitEthernet1/0/42
 switchport mode access
!
interface GigabitEthernet1/0/43
 switchport mode access
!
interface GigabitEthernet1/0/44
 switchport mode access
!
interface GigabitEthernet1/0/45
 switchport mode access
!
interface GigabitEthernet1/0/46
 switchport mode access
!
interface GigabitEthernet1/0/47
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 1,100,101
 switchport mode access
 ip dhcp relay information trusted
!
interface GigabitEthernet1/0/48
 switchport mode access
!
interface GigabitEthernet1/0/49
 switchport mode access
!
interface GigabitEthernet1/0/50
 switchport mode access
!
interface GigabitEthernet1/0/51
 switchport mode access
!
interface GigabitEthernet1/0/52
 switchport mode access
!
interface Vlan1
 ip address 10.10.0.1 255.255.255.0
!
interface Vlan2
 no ip address
 ip helper-address 10.10.0.50
!
interface Vlan100
 no ip address
!
interface Vlan101
 ip address 10.10.1.1 255.255.255.0
!
ip default-gateway 10.10.0.3
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.0.3
ip route 10.10.0.0 255.255.255.0 Vlan100
ip route 10.10.1.0 255.255.255.0 Vlan101
ip http server
!
!
control-plane
!
!
line con 0
 logging synchronous
line vty 0 4
 logging synchronous
 login
line vty 5 15
 logging synchronous
 login
!
end
 

I have done a little messing around since the last post.

 

Thanks.



#7 easyrider2

easyrider2

  • Members
  • 85 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:London, UK
  • Local time:07:46 PM

Posted 22 March 2014 - 01:51 PM

Hi, you get yourself an interesting task:-)

First off, do you need so many vlans? I would first set things up with only one (native) vlan and then see if it's working. On GigabitEthernet 1/0/1 & 1/0/47 you should have switchport mode trunk rather than access if you want to use trunking.

Is there any reason why you are using ip classless?
Can you ping 10.10.0.3 from your switch? If yes, can you ping / traceroute from the switch to the Internet? e. g. 8.8.8.8? Which vlan did you set as native?

Best regards.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users