Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Complicated Problem


  • Please log in to reply
No replies to this topic

#1 brillo

brillo

  • Members
  • 80 posts
  • OFFLINE
  •  
  • Location:Terrebonne, Oregon
  • Local time:11:49 AM

Posted 16 May 2006 - 02:29 PM

Hello Bleepers

Coming here rather than a Flight Sim forum because at least part of this problem is in the comp. I think, and you guys know that stuff better. FS AutoStart is a program that shuts down unnecessary programs and services to maximize resources for playing Flight Simulator 2004. Almost everybody I know uses FSAS to start up FS2004. Today, in pre-selecting programs for FSAS to shutdown or leave running, the first one on the display list (alphabetical order) of running programs is "csrss.exe" (client server runtime process, Microsoft Corp. File v. 5.1.2600.2180 created 1/18/2006 6KB). The path is not shown. The path is shown for all other programs. It's icon is a folder, the only program with that icon. I did not select csrss.exe to shutdown when FSAS starts FS2004. I left csrss.exe running.

Then, in starting up FSAS (to shut down all the programs and services that I have specified and start FS2004), the log shows a red warning message (all others are grey showing programs and services as they are shut down by FSAS). Red message says (paraphrase) can not find path for csrss.exe. This is interesting because I have not told FSAS to shut down csrss.exe so it doesn't need to shut it down or do anything to it. FSAS continues to shutdown everything I have told it to shut down, all the way to starting the main program FS2004 (fs9.cfg.exe). Then nothing happens. And nothing works. The mouse, keyboard commands, nothing works, the desktop with the FSAS window showing "starting up fs9.cfg.exe. I have to shutdown everything. Not even task manager works for shutdown. The FSAS settings are the same as before when it worked every time.

The csrss.exe file is in i386. Date of csrss.exe cereation corresponds to the date I bought the computer, i.e., when it was built. Csrss.exe show up in i386 as a file with a generic file icon, not a folder as it shown in FSAS. Googling csrss.exe says it can be a masked virus and should be in the system folder, anywhere else is suspicious. Although I checked a couple other files the guide said should be in system folder and they were also in i386 and no other symptoms of a virus are evident in comp. functions. I ran McAfee, Spybot, Ewido, windows defender, spy sweeper, ->nothing.

I use CCleaner judiciously; however, I do think I have unknowingly "cleaned" out some stuff in the past that I needed, e.g., index.dat files.

I have dropped a few "unnecessary" startup programs and a few services recently. But FSAS has worked fine after that. Also, FS2004 works fine when started on its own, without FSAS. But of course without as much free RAM as when using FSAS.

I don't know if this info is sufficient to point me in a direction to solve this problem, but if someone has an idea, let me know.

Rob

Edited by brillo, 16 May 2006 - 02:32 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users