Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Getting internet to work on win 98?


  • Please log in to reply
9 replies to this topic

#1 Lewb

Lewb

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:15 AM

Posted 18 March 2014 - 11:21 AM

Hello, was wondering if anyone could help me trying to get internet to work via Ethernet on an old Windows 98SE Computer has a ethernet Card installed with the latest drivers (Accton en1207d-tx PCI fast ethernet adapter) Also the lights next to the ethernet socket seem to be lit up an says "This device is working properly" in device manager have tried a few guides but when ever i type in "ipconfig" in MS-DOS Prompt it says IP Address : 0.0.0.0,  Subnet Mask 0.0.0.0 an I'm pretty sure they have to have some values in? Any ideas how i can get this working? Thanks in advanced. 



BC AdBot (Login to Remove)

 


#2 dls62

dls62

  • Members
  • 623 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Berkshire, UK
  • Local time:03:15 AM

Posted 18 March 2014 - 12:36 PM

Hi,

Can you please open a MS-DOS Prompt and enter the following command:

ipconfig /all > C:\netconf.txt

Then open the netconf.txt file and copy and paste the entire contents into your reply.



#3 Lewb

Lewb
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:15 AM

Posted 18 March 2014 - 01:11 PM

Thanks for the reply couldn't get it to give me the .txt file but heres what comes up for ipconfig /all 

 

Windows 98 IP Configuration

Host Name . . . . .  . .  . . . . . . . .  :B8Z5C6

DNS Servers . . . . . .  . . . . . . . . . :

Node Type . . . . . .  .  . . . . . . . . . : Broadcast

NetBIOS scope ID . . . . . . . . . . . :

IP Routing Enabled .  . . . . . . . . . : No

WINS Proxy Enabled . . . . . . . . . : No

NetBIOS Resolution Uses DNS . : No

 

0 Ethernet Adapter :

Description . . . . . . . . . . . . . . . . . .: PPP Adapter

Physical Address . . . . . . . . . . . . . : 44-45-53-54-00-00

DHCP Enabled . . . . . . . . . . . . . . .: Yes

IP Address . . . . . . . . . . . . . . . . . .: 0.0.0.0

Subnet Mask . . . . . . . . . . . . . . . .: 0.0.0.0

Default Gateway . . . . . . . . . . . . . :

DHCP Server . . . . . . . . . . . . . . . .:255.255.255.255

Primary WINS Server . . . . . . . . . .:

Secondary WINS Server . . . . . . . :

Lease Obtained . . . . . . . . . . . . . .:

Lease Expires . . . . . . . . . . . . . . ..:



#4 dls62

dls62

  • Members
  • 623 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Berkshire, UK
  • Local time:03:15 AM

Posted 18 March 2014 - 02:00 PM

Click the Start button, point to Settings, and then click Control Panel.

Click on the Network Neighborhood icon.

On the Configuration tab, check that Client for Microsoft Networks and TCP/IP are present (if not they need to be installed using the Add button), and that 'Primary Network Logon' is set to Windows Logon.

Click on TCP/IP and then click on the Properties button.

Verify that 'Obtain an IP address automatically' on the IP Address tab is selected. If not, select the radio button next to it, click OK and then Restart the computer.

Check whether you can access the internet. If not, please re-run ipconfig /all and post the results in your reply.



#5 Lewb

Lewb
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:15 AM

Posted 18 March 2014 - 02:53 PM

Thanks for the reply Client for microsoft networks and TCP/IP are already present and obtain IP Address automatically is already checked still just getting The page cannot be displayed on the web browser an comes up with "Internet explorer could not open the search page" if i try to go to any other web url. Also ipconfig /all is still the same. Thanks. 



#6 dls62

dls62

  • Members
  • 623 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Berkshire, UK
  • Local time:03:15 AM

Posted 18 March 2014 - 03:11 PM

The problem is this entry:

 

DHCP Server . . . . . . . . . . . . . . . .:255.255.255.255

 

The DHCP Server address is normally the IP address of the router, so with the current setting you are not going to get connected.

 

Click Start and select 'Run'.  Type winipcfg and press Enter.

 

In the window that appears click on 'Release All' and then 'Renew All'.  If it has worked you will see a new IP address in the window.



#7 Lewb

Lewb
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:15 AM

Posted 18 March 2014 - 03:18 PM

Thanks again for the reply but when i go to that window an click "Release all" Then "Renew all" nothing seems to happen still saying 0.0.0.0 Any ideas why this would be? Thanks 



#8 dls62

dls62

  • Members
  • 623 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Berkshire, UK
  • Local time:03:15 AM

Posted 18 March 2014 - 03:21 PM

Ok, lets try this:

  • Click Start.
  • Select Settings and click Control Panel.
  • Click the Network Neighborhood icon.
  • For each TCP/IP entry select it and click Remove.
  • Once all TCP/IP entries are removed click OK.
  • Restart the computer.
  • Click Start.
  • Select Settings and click Control Panel.
  • Click the Network Neighborhood icon.
  • Click Add.
  • Choose Protocol and click Add again.
  • In the Manufacturers box choose Microsoft. In the Network Protocols box choose TCP/IP. Click OK.
  • Click OK in the Network window.
  • When prompted to restart the computer choose Yes.


#9 Lewb

Lewb
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:02:15 AM

Posted 18 March 2014 - 03:34 PM

That did the trick thanks a lot for all your help :) 



#10 dls62

dls62

  • Members
  • 623 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Berkshire, UK
  • Local time:03:15 AM

Posted 18 March 2014 - 03:35 PM

You're welcome.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users