Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Crossfire Option Not Displaying In Catalyst Control Center!

  • Please log in to reply
2 replies to this topic

#1 Lewisrowezer


  • Members
  • 5 posts
  • Local time:12:37 PM

Posted 17 March 2014 - 10:26 PM

I recieved an amazing reply which helped me out last time with my motherboard (I was having issues with my BIOS)


Now I'm having horrible issues with enabling crossfire. I'm running with two Radeon HD 6970 cards.


Before I reset my BIOS my Crossfire was running fine, now it will not display in Catalyst so I cannot enable it.


Strangely enough both cards are showing up on SpeedFan. Iv'e used "Display Driver Uninstaller" and re-installed the latest drivers (Non-beta) with no success.


The PCI-E slot on one of my cards is SLIGHTLY bent, but if it was broken, surely one of the cards would fail to display on SpeedFan?


I even have access to the temperatures of the cards. I will attach images.


Thank you for taking your time to read this and hopefully help, Have a nice day!

Attached Files

BC AdBot (Login to Remove)


#2 Lewisrowezer

  • Topic Starter

  • Members
  • 5 posts
  • Local time:12:37 PM

Posted 17 March 2014 - 11:10 PM

Iv'e solved part of the issue. I switched the cards around. The other part of the issue? Well, now that Iv'e switched them around - I'm not recieving any feedback from SpeedFan. According to SpeedFan, my second GPU is running at 0 Degrees! What could be the problem?

#3 killerx525


    Bleepin' Aussie

  • Members
  • 7,220 posts
  • Gender:Male
  • Location:Melbourne, Australia
  • Local time:10:37 PM

Posted 18 March 2014 - 04:26 AM

G'day mate, im not sure why Speedfan is displaying the 0 Degrees but have you tried looking at the temperature of the 2nd GPU through the AMD Vision Center also know as Catalyst Control Center which is located at the taskbar(bottom right corner)?

System1: CPU- Intel Core i7-5820K @ 4.4GHz, CPU Cooler- Noctua NH-D14, RAM- G.Skill Ripjaws 16GB Kit(4Gx4) DDR3 2133MHz, SSD/HDD- Samsung 850 EVO 250GB/Western Digital Caviar Black 1TB/Seagate Barracuada 3TB, GPU- 2x EVGA GTX980 Superclocked @1360/MHz1900MHz, Motherboard- Asus X99 Deluxe, Case- Custom Mac G5, PSU- EVGA P2-1000W, Soundcard- Realtek High Definition Audio, OS- Windows 10 Pro 64-Bit
Games: APB: Reloaded, Hours played: 3100+  System2: Late 2011 Macbook Pro 15inch   OFw63FY.png

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users