Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

External Hard drives unresponsive


  • Please log in to reply
2 replies to this topic

#1 Mr_Ymmit

Mr_Ymmit

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:58 AM

Posted 13 March 2014 - 09:37 PM

Hey all, I have 2 external hard drives hooked up to my computer. Today they both stopped responding at the same time, here's what I've noticed:

 

-I was able to eject 1 of them (E:) through the safely remove dialog, but the other didn't respond

-One drive (H:) shows its free space meter, while the other just lists itself as NTFS

-The drive that shows its space meter will display the files and folders in the root directory, but the folders appear empty/the files don't work. 

-The drives both still appear while unplugged, and you can even still see the root directory while that drive is unplugged.

-I have tried restarting, and the drives both work on my other box.

 

Here's what the drive list looks like, even with E: and H: disconnected.

ThkpAv9.png

 

Any ideas would be greatly appreciated!


Edited by Mr_Ymmit, 13 March 2014 - 09:37 PM.


BC AdBot (Login to Remove)

 


#2 MakeItBetter

MakeItBetter

  • Members
  • 53 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:58 PM

Posted 13 March 2014 - 10:58 PM

These instructions assume Windows OS (recent, like win7, win8...others may work as well)...

...that the drives are being attached via USB

...that the drives are hard drives

 

Let's take the simplest approach first:...which is powering down everything and then re-booting.

This has fixed more than one situation of drives not being recognized...in fact, I used a similar approach when in an interview with the HR rep at Apple Compputer MANY years ago (yes, it worked, and yes, I got the job.)

 

Power down everything...computer and drives...

...wait for a good 15-30 seconds or longer after all the appropriate lights have gone off...

(sometimes the OS does various things before shutting down...so you want to make sure power is OFF -- and then start the waiting time.)

 

Now...power your computer up...

 

...add your drives (one at a time)...and see if that helps...

 

 

Now, if that doesn't work...

 

  1. Gather a bit of information...

a. go to device manager and see what you can see under disk drives (with the drives attached)...

b. under device manager, look also under "Universal Serial Bus Controllers

 

2.  After that, I would probably go back to device manager for the appropriate hard drive(s) under "disk drives"... and select "update driver software"...

 

3. I would equally apply the "update driver software" to the appropriate usb devices that show up under device manager "Universal serial bus controllers"

 

Ultimately, you may need to search online for help specific to your DRIVE (e.g., manufacturer)...and even then it may take a bit of poking around...

 

I had a usb thumb drive which wasn't being recognized and found some instructions that involved manipulating the registry...they DID work...however, it took me a bit when I went back to re-find the instructions...

 

I'm still trying to sort out what's the difference between doing things like...but these would be things to try if the other suggestions don't work...

 

...sfc /scannow

...restoring from a restore point...

 

...before trying either though, I would run a scandisk/chkdsk

 

To be honest, given that both drive stopped working at the same time, and assuming they are probably the same kind (mfr) of drives, I'm guessing something happened to the driver software...

 

Hope this helps, please report back!

 

Cheers!

 

Jann


Edited by MakeItBetter, 13 March 2014 - 11:21 PM.


#3 Mr_Ymmit

Mr_Ymmit
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:58 AM

Posted 13 March 2014 - 11:09 PM

After trying to shut down, it hanged on the shutting down screen for a while and then I got a BSOD for DRIVER_POWER_STATE_FAILURE
Rebooted, tried to boot to safe mode, got another BSOD

Tried to boot normally, used the startup recovery tool and it seems to have worked, the drives are recognized now. Thanks for your suggestions!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users