Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

net framework install problem


  • Please log in to reply
5 replies to this topic

#1 cwmax2000

cwmax2000

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:05:47 AM

Posted 07 March 2014 - 09:53 AM

I can not install net framework 4.0. I tried the Mrfixit, and the repair tools. I have attached the failure log. Vista home prem 32 bit.
I don't know what to do now....thanks in advance...Cmax :crazy: 

Attached Files


HP Pavilion m9040n
Q6600 2.4 Quad
Windows Vista Home Preminum 32 Bit
3 Meg RAM
NVIDIA GeForce GTS 250
TV Tuner
Kapersky Internet security 2011

BC AdBot (Login to Remove)

 


#2 JohnC_21

JohnC_21

  • Members
  • 24,827 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:47 AM

Posted 07 March 2014 - 11:12 AM

If you ran the fixit (method 1)on this page, continue on to the other methods (2 & 3)

 

http://support.microsoft.com/kb/976982


Edited by JohnC_21, 07 March 2014 - 11:12 AM.


#3 cwmax2000

cwmax2000
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:05:47 AM

Posted 08 March 2014 - 05:17 AM

If you ran the fixit (method 1)on this page, continue on to the other methods (2 & 3)

 

http://support.microsoft.com/kb/976982

ok tried... 1st problem states the .net framework clean up tool is not a win 32 application. so I went on. I installed the frame 1.1, then 1.1 service pack, good so far...then on the 3.5 it ask to repair or uninstall. I chose repair. then restarted and tried to windows update...failed code 643....what now?...thanks for your help.... (i am loading the shotgun, so the computer better start acting right!!!! LOL)  Cmax  :flamethrower:


HP Pavilion m9040n
Q6600 2.4 Quad
Windows Vista Home Preminum 32 Bit
3 Meg RAM
NVIDIA GeForce GTS 250
TV Tuner
Kapersky Internet security 2011

#4 JohnC_21

JohnC_21

  • Members
  • 24,827 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:47 AM

Posted 08 March 2014 - 08:29 AM

Unistall all of the Net Frameworks again from high to low. Then use the cleanup tool from this site. It you get the win32 application, try it in safe mode. The Win32 application error can be the result of multiple issues. After the cleanup tool. Only install V3.5 SP1 because that will also download .NET Framework 2.0 SP2 and the .NET Framework 3.0 SP2. Forget about 1.1 Then install V4

http://blogs.msdn.com/b/astebner/archive/2009/04/20/9557946.aspx

When you install the .NET Framework 3.5 SP1, it will also install the .NET Framework 2.0 SP2 and the .NET Framework 3.0 SP2 behind the scenes.  You cannot use the .NET Framework 3.5 SP1 unless you also have the .NET Framework 2.0 SP2 and 3.0 SP2 installed.  Therefore, you will not be allowed to uninstall the .NET Framework 2.0 SP2 or 3.0 SP2 if you have the .NET Framework 3.5 SP1 installed.  If you try to uninstall those versions of the .NET Framework, their uninstall processes will block and tell you that they are needed by another application on your system.

The .NET Framework 1.0 and .NET Framework 1.1 can be installed side-by-side with the .NET Framework 2.0, 3.0 and 3.5.  Most applications that were created for the .NET Framework 1.0 or 1.1 will automatically use the .NET Framework 2.0 instead if it is installed on the system.  In most cases, that means you do not need to keep the .NET Framework 1.0 or 1.1 installed on your system if you already have the .NET Framework 2.0 installed.

 

 

Here is the link to 3.5SP1. It's the 2.8MB stub installer.

 

 



#5 cwmax2000

cwmax2000
  • Topic Starter

  • Members
  • 12 posts
  • OFFLINE
  •  
  • Local time:05:47 AM

Posted 08 March 2014 - 02:33 PM

ok the clean tool worked, install sp3.5 1...worked...then 4.0 failed. I attached failed log....thanks for your help

 


Edited by hamluis, 11 March 2014 - 12:03 PM.
Removed unnecessary quote - Hamluis.

HP Pavilion m9040n
Q6600 2.4 Quad
Windows Vista Home Preminum 32 Bit
3 Meg RAM
NVIDIA GeForce GTS 250
TV Tuner
Kapersky Internet security 2011

#6 JohnC_21

JohnC_21

  • Members
  • 24,827 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:47 AM

Posted 08 March 2014 - 02:47 PM

I don't see the attached file. I will be away a little bit. One thought. You might try disabling your internet security and try the install.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users