Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Linux PC is under some kind of whois DOS attack.


  • This topic is locked This topic is locked
2 replies to this topic

#1 gmeruser123

gmeruser123

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:03:39 PM

Posted 04 March 2014 - 09:31 PM

OS: Slackware 64, Linux

My current firewall: http://pastebin.com/zEYS0XfA

When I disconnect the internet completely there aren't any attempted outgoing connections. When the link is back up, there are numerous inbound attempts to connect to protected services on ports 1433, 3389, 5000, 23, 21, 22, etc. That's not such a big deal as I have seen this type of traffic since I've been using Wireshark. I've concluded that everyone who is an attacker is always going to attack vulnerabilities. With there being so many of them, the traffic will be non-stop. So I've blocked just about every port possible, so much so that my normal traffic suffers from limitations. But there is one persistent attacker which seems to have infiltrated my Linux PC and possibly the Windows PC that it protects.

All traffic from this attacker seems to be obfuscated with some kind of overlaying traffic. tcpdump is almost useless in this scenario as I have no idea what port the traffic is coming in through or if at all. The reason I believe this is because psad (port scan attack detection) detects the attacker and blocks the traffic but the port and source address that gets blocked is completely different than the port and address that's advertised in the system logs. The port and addresses that do get reported are outgoing whois lookups through TCP port 43 and to whois server addresses. I tried capturing traffic to all of the ports above in addition to singling out port 43 but while there is always some traffic on the above ports there is no detectable traffic on port 43 or to any of the whois addresses.

There is no trace of port 43 in netstat. I've tried unhide-tcp, unhide-linux26 proc, unhide-linux26 dev, unhide-linux26 brute and nothing shows up anywhere.

There were a few files with user "10" and group "14".

/var/spool/uucppublic
/usr/bin/uux
/usr/bin/uuname
/usr/bin/uustat
/usr/bin/uucp
/usr/bin/cu
/usr/sbin/uuxqt
/usr/sbin/uucico

It's possible those numbers belong, to a user and group I've deleted for their vulnerabilities in the past or, to an attacker. I believe it to belong to an attacker because "all" of the user's owned programs had the SUID or group bits set.

I have removed the SUID's from the executables but the attack is still going on. I could probably just change my IP and it will likely go away if there isn't some hidden backdoor installed. But if I do that I will not be able to troubleshoot the problem and stop it from occurring again.

My next steps are to lock down the PC with Selinux or some other MAC style access control and harden the OS further. Slackware doesn't support Selinux or Apparmor. And the current version of grsecurity seems a bit too out of date. I might just be brave enough to compile the latest stable kernel with grsecurity's latest stable kernel "test patch." If I'm unable to compile and enable any of these security measures in the kernel properly then I may have to leave Slackware for CentOS or some other security enabled distro like Gentoo.

I believe this attack to have been started after having visited and used GRC's Shield's Up.

2 minutes later 5 outbound attempts to port 43 occurred. An hour later, outbound attempts to connect from my PC to various places and various protected ports including port 22, 135, 139, 5060 and a bunch of others occurred. Then port 43 seemed to have been selected as the best vulnerable port because next thousands of attempts occurred outbound to that port.


Update: I've reinstalled Slackware's binaries. After doing so, the user 10 and group 14 with SUID set in certain binaries returned. Apparently, the binaries ship in this vulnerable state. The attack is still currently in progress.

Update: I'm moving to Gentoo. Slackware is great but the security options are lacking.

Edited by gmeruser123, 05 March 2014 - 01:00 AM.


BC AdBot (Login to Remove)

 


#2 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,233 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:12:39 AM

Posted 05 March 2014 - 03:31 PM

Very interesting article....



#3 quietman7

quietman7

    Bleepin' Janitor


  • Global Moderator
  • 51,486 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Virginia, USA
  • Local time:10:39 AM

Posted 05 March 2014 - 10:34 PM


Your log(s) is posted here.

Now that your log is posted, you should NOT make further changes to your computer (install/uninstall programs, use special fix tools, delete files, edit the registry, etc) unless advised by a Malware Response Team member...nor should you continue to ask for help elsewhere. Doing so can result in system changes which may not show in the log(s) you already posted. Further, any modifications you make on your own may cause confusion for the member assisting you and could complicate the malware removal process or make things worst which would extend the time it takes to clean your computer.

From this point on the Malware Response Team should be the only members that you take advice from, until they have verified your log as clean.

Please be patient. It may take several days to get a response because the Malware Response Team members are very busy working logs posted before yours. They are volunteers who will help you out as soon as possible. Once you have posted your log and are waiting, please DO NOT "bump" your post or make another reply until it has been responded to by a member of the Malware Response Team. Generally the staff checks the forum for postings that have 0 replies as this makes it easier for them to identify those who have not been helped. If you post another response there will be 1 reply. A team member, looking for a new log to work may assume another Malware Response Team member is already assisting you and not open the thread to respond.

If HelpBot replies to your topic, please follow Step One and CLICK the link so it will report your topic to the team members.

To avoid confusion, I am closing this topic.

Good luck with your log.
.
.
Windows Insider MVP 2017-2018
Microsoft MVP Reconnect 2016
Microsoft MVP Consumer Security 2007-2015 kO7xOZh.gif
Member of UNITE, Unified Network of Instructors and Trusted Eliminators

If I have been helpful & you'd like to consider a donation, click 38WxTfO.gif




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users