Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

On-board Audio Refuses to Play


  • Please log in to reply
24 replies to this topic

#1 IronSid

IronSid

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:12:01 PM

Posted 04 March 2014 - 03:46 PM

Hey guys,

 

On-board audio refuses to play sound and has refused to play no matter what fix I've tried. I can see the bar in the volume mixer rise when playing YouTube videos or playing music, though no sound comes through my headphones. Frankly, at this point, I've no idea what else to attempt. I've tried every single fix I can think of and nothing works.

 

My system:

Windows 7 Home Premium

ASUS M5A78L-M LX Plus Motherboard

Realtek ALC892 on-board audio

GeForce GTX 650 graphics card

1TB HDD

4GB RAM

 

Fixes I've Attempted:
-Ensured that "Speakers" are set as default device.
-Ensured that on board audio in the BIOS is enabled.
-Ensured that my sound isn't muted via both volume mixer and settings in the play back tab.
-Tried plugging the head phones in both the front and rear ports.
-Tried different sets of head phones.
-Ensured that Realtek drivers are installed
-Switched between both AC97 and HD Audio in the BIOS settings.
-Uninstalled Realtek drivers and let Windows install its own drivers.

Any help would be greatly appreciated. I'm honestly stumped at this point.


Edited by IronSid, 04 March 2014 - 03:50 PM.


BC AdBot (Login to Remove)

 


#2 Alex&Vanko

Alex&Vanko

  • Banned
  • 1,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 PM

Posted 04 March 2014 - 05:26 PM

Hey,

The Realtek driver must be from here - http://www.asus.com/Motherboards/M5A78LM_LX_PLUS/#support

What is the situation in Start Menu-Control Panel-Device Manager under sound,video and game controllers,right click on realtek.

Are audio codecs all right?



#3 IronSid

IronSid
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:12:01 PM

Posted 04 March 2014 - 05:35 PM

Yeah, I got the audio driver from the disc that came when I bought the mobo.

 

Under the Realtek HD Audio under device manager, in the general tab, the device is enabled. Supported formats tab has DTS Audio, Dolby Digital, and Microsoft AMA Pro Audio checked. Sample rates has 48.0 kHz checked. In the levels tab, Realtek Digital Output is at maximum at 100. Nothing is checked in the enhancements tab. In the advanced tab, default format is 2 channel, 16 bit, 48000 kHz (DVD Quality). Both options under exclusive mode are both checked.

 

Not sure what you mean by audio codecs. Never came across the term until now.



#4 Alex&Vanko

Alex&Vanko

  • Banned
  • 1,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 PM

Posted 04 March 2014 - 05:49 PM

Uninstalled Realtek drivers and let Windows install its own drivers.

Now what is the situation.If it the same I suggest to uninstall it and do and download where I have shown you.Is there Audio control panel in the driver of Realtek?

You have only headphones and speakers not?



#5 IronSid

IronSid
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:12:01 PM

Posted 04 March 2014 - 06:15 PM

Just installed the driver from that link you showed me. Before that, yeah, I did uninstall the Realtek drivers and let Windows install its own and no sound played. There isn't a control panel for the Realtek driver, just the volume mixer and that's it.

 

In the playback tab in sound, I have only Realtek Digital Output showing. If I plug in my headphones in the rear ports, speakers show.


Edited by IronSid, 04 March 2014 - 06:17 PM.


#6 Alex&Vanko

Alex&Vanko

  • Banned
  • 1,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 PM

Posted 04 March 2014 - 06:29 PM

You must uninstall existing driver and not let Windows to make its own.And install this one from website - http://www.asus.com/Motherboards/M5A78LM_LX_PLUS/#support

And then I think Audio control panel will appear.Do you have windows sound when you logins?



#7 JohnC_21

JohnC_21

  • Members
  • 23,591 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:01 PM

Posted 04 March 2014 - 06:38 PM

I am not sure about the ASUS version of Realtek HD manager but if you go to the Windows 7 control panel and select large icons from the drop down box instead of category, you should see an icon to access the Realtek HD manager.

#8 Alex&Vanko

Alex&Vanko

  • Banned
  • 1,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 PM

Posted 04 March 2014 - 06:45 PM

Realtek HD manager - and you have it,but nothing here to control.What kind of manager is that?Or don`t have it.Tell me what you see not what should be.



#9 IronSid

IronSid
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:12:01 PM

Posted 04 March 2014 - 06:54 PM

Sorry, I mistakenly installed the wrong driver from that website you linked me, Alex. I corrected it and now installed the latest driver from the ASUS website. I now have the HD Audio Manager after correcting my mistake. I didn't have sound when I logged in. Here's my settings in it:

 

Device Advanced Settings:

Tie up same type of input jacks option is checked.

 

Information:

Audio Driver Version: 6.0.1.6526

DirectX Version: DirectX 11.0

Audio Controller: HD Audio

Audio Codec: ALC887

Language: Auto

 

Speaker Configuration Tab:

Stereo

Front Left and Right is checked

Main Volume - 100%

 

Sound Effects Tab:

Environment - None

Equalizer - None

 

Room Correction Tab:

15ft 0dB -Left Speaker

15ft 0dB  -Right Speaker

 

Default Format Tab:

24Bits, 48000 Hz (Studio Quality)


Edited by IronSid, 04 March 2014 - 06:54 PM.


#10 Alex&Vanko

Alex&Vanko

  • Banned
  • 1,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 PM

Posted 04 March 2014 - 07:01 PM

Now do you have sound?



#11 IronSid

IronSid
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:12:01 PM

Posted 04 March 2014 - 07:04 PM

Nope, no sound. Though I can see the volume bar rise when sound is playing. I just can't hear it.



#12 Alex&Vanko

Alex&Vanko

  • Banned
  • 1,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 PM

Posted 04 March 2014 - 07:12 PM

So look around inside this manager.Also Windows audio options.


Edited by Alex&Vanko, 04 March 2014 - 07:13 PM.


#13 IronSid

IronSid
  • Topic Starter

  • Members
  • 9 posts
  • OFFLINE
  •  
  • Local time:12:01 PM

Posted 04 March 2014 - 07:57 PM

Double checked everything in the audio manager, the windows playback tab, and the volume mixer. Everything is at 100% and nothing is muted. Still stumped on what to do now. The drivers seem to be working fine with the volume bar rising up and down, it's just a matter of it getting to actually play.



#14 JohnC_21

JohnC_21

  • Members
  • 23,591 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:01 PM

Posted 04 March 2014 - 08:09 PM

I am not sure how your HD control panel looks but make sure "Disable front panel jack detection" is checked.

 

14-realtek-hd-audio-manager-big.jpg



#15 Alex&Vanko

Alex&Vanko

  • Banned
  • 1,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:09:01 PM

Posted 04 March 2014 - 08:25 PM

If you are going to put Headphones into infront panel it must be enable.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users