Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows Desktop Manager


  • Please log in to reply
6 replies to this topic

#1 Lonelyduck

Lonelyduck

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:11:45 AM

Posted 02 March 2014 - 07:24 AM

Hi. When I start my computer, an error message pops up saying:
"Windows desktop manager has stopped working and was closed"
When I try to run desktop manager from services.msc the same error message pops up instantly.
Due to the error. None of my Windows AERO effects work and some games that I used to be able to play do not start at random. For example Far Cry 3 doesn't work despite that I used to be able to play it but Just Cause 2 works just fine. (It doesn't show any error messages. It just doesn't start)
 
WDM error started when I plugged in an external video card without uninstalling the original one first a few months ago
 
I have tried:
-CMD sfc/scannow
-CCleaner
-Troubleshooting
-updating video drivers
-Uninstalling and reinstalling video drivers
When I uninstalled my video driver I noticed a huge drop in computer performance and resolution. When I reinstalled the drivers everything went back to "normal" except WDM obviously
 
My operating system is Windows 7
Solutions?


BC AdBot (Login to Remove)

 


#2 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:07:45 PM

Posted 02 March 2014 - 07:47 AM

have you updated DirectX... I know it's a longshot.



#3 Lonelyduck

Lonelyduck
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:11:45 AM

Posted 03 March 2014 - 02:00 AM

Actually I haven't. I'll try that and report back



#4 Lonelyduck

Lonelyduck
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:11:45 AM

Posted 03 March 2014 - 02:14 AM

I have the latest DirectX installed, but when I went to check it out in "dxdiag" it says that Direct3D-acceleration is turned off.

When I went to Control Panel-Appearance and Personalization-Adjust screen resolution- Advanced settings-Troubleshoot the Change settings button was greyed out and I couldn't change my hardware acceleration to full as it says in http://windows.microsoft.com/en-us/windows7/diagnosing-basic-problems-with-directx



#5 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,234 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:07:45 PM

Posted 03 March 2014 - 04:12 PM

I would remove and re-install Directx, fiddle with it till you get it working.

 

It seems like that could be your issue.



#6 Lonelyduck

Lonelyduck
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:11:45 AM

Posted 05 March 2014 - 04:40 AM

I found that I could fix DirectX by using REGEDIT and changing the "SoftwareOnly" key from "1" to "0" in the HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Direct3D\Drivers. However when I try to do that, there is no "SoftwareOnly" thing to be found.

I only found: Base, Description, GUID files alltogether in \Drivers\

 

EDIT: There were 3 folders in the \Drivers\ folder: Direct3D HAL, Ramp Emulation, RGB Emulation. None of them contained "SoftwareOnly"


Edited by Lonelyduck, 05 March 2014 - 04:44 AM.


#7 Lonelyduck

Lonelyduck
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:11:45 AM

Posted 10 March 2014 - 12:08 PM

Hi I just wanted to drop by to say that I've fixed it.

I downloaded DriverMax and updated everything using that.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users