Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Slowed Browser, choppy video loading, potential cause Adware SavingsBull


  • Please log in to reply
No replies to this topic

#1 Neo-Geo Demacian

Neo-Geo Demacian

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:34 AM

Posted 27 February 2014 - 11:30 PM

Hello.

 

I've been having trouble removing the adware SavingsBull from my computer, and I believe that it's slowing down my browser and making videos load very choppy, and pages as well. I've tried removal with an up-to-date Malwarebytes Anti-Malware, but every time I remove it from quarantine, the same programs, registries, and processes are created again.

 

I'm not entirely sure if there's anything else, but if you can help me with this I'm sure things will turn out. Thank you for your assistance.

 

EDIT: Problem seems to be resolved, closing the process manually and removing the infected objects seems to have stopped it entirely. I see no trace of it on my system.


Edited by Neo-Geo Demacian, 28 February 2014 - 03:52 PM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users