Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop using incorrect Graphics Card


  • Please log in to reply
10 replies to this topic

#1 BenBenBenBe

BenBenBenBe

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:03:25 PM

Posted 26 February 2014 - 03:12 AM

Howdy.  It seems as though my laptop is using the incorrect graphics card for games (for example, Skyrim):

 

http://i.imgur.com/LrSvN14.png

 

When I access the nVidia control panel, it assures me that my nVidia NVS 4200m (rather than the integrated Intel chip) is the default:

 

http://i.imgur.com/NxthH2R.png

 

I've done most of the troublshooting that I'm comfortable doing (manually selecting nVidia as the chosen graphics card for Skyrim, etc.) but I haven't messed with the BIOS or anything b/c I'm just not "good enough with computers".

 

I tried googling but there were like 48394 answers, all of which were a bit daunting and none of which seemed to help.  

 

Attached is my system specs:

 

 

 

Attached Files



BC AdBot (Login to Remove)

 


#2 Alex&Vanko

Alex&Vanko

  • Banned
  • 1,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:25 PM

Posted 26 February 2014 - 03:41 AM

Start menu->control panel->device manager,left click onto display adapter then right click upon intel graphic chip and disable it.Use Nvidia in a further purposes.But I didn`t find this notebook model an external videocard has.



#3 BenBenBenBe

BenBenBenBe
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:03:25 PM

Posted 26 February 2014 - 03:47 AM

Start menu->control panel->device manager,left click onto display adapter then right click upon intel graphic chip and disable it.Use Nvidia in a further purposes.But I didn`t find this notebook model an external videocard has.

 

When I do this, my screen turns black and I need to hard shut-down, run in safe mode and re-enable.  



#4 Alex&Vanko

Alex&Vanko

  • Banned
  • 1,394 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:25 PM

Posted 26 February 2014 - 04:22 AM

That means you don`t have a Nvidia graphic card and the only one is Intel HD 3000 graphic.



#5 BenBenBenBe

BenBenBenBe
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:03:25 PM

Posted 26 February 2014 - 04:47 PM

That means you don`t have a Nvidia graphic card and the only one is Intel HD 3000 graphic.

 

http://i.imgur.com/JZVpooB.png

 

Lol, I'm not that stupid.



#6 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 7,129 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:08:25 PM

Posted 26 February 2014 - 06:24 PM

Let's all be calm here ! 

 

Your laptop does appear to have two video cards, but I may have found a solution to the query that is bothering you. A review of your nVidia card suggests that it was designed primarily with a view to business use, and is not optimised for gaming. One thing it definitely doesn't have, according to the specs listed by nVidia is Physx support, you can check this here :

 

http://www.nvidia.com/object/nvs_techspecs.html

 

I know nothing about Skyrim, but I do know that a  lot of games require Physx support. If Skyrim is one of them, that is probably why your computer is switching over to the Intel drivers when you play it - even if they are notionally less capable.

 

Chris Cosgrove



#7 BenBenBenBe

BenBenBenBe
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:03:25 PM

Posted 26 February 2014 - 06:48 PM

Neat - so the card is useless when the game requires PhysX support because of the laptop model?  

 

Edit: or the game simply can't use the graphics card because it isn't "PhysX capable"?  If so, why does the integrated Intel chip work?  


Edited by BenBenBenBe, 26 February 2014 - 06:51 PM.


#8 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 7,129 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:08:25 PM

Posted 27 February 2014 - 07:29 PM

 

If so, why does the integrated Intel chip work?

 

For a guess, because the Intel graphics support Physx better, or more nearly. Try googling it for its specs.

 

Chris Cosgrove



#9 JohnC_21

JohnC_21

  • Members
  • 24,666 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:03:25 PM

Posted 27 February 2014 - 09:06 PM

Hello, See this article on the Nvidia Optimus that your computer uses. It is supposed to switch between the intel card and the Nvidia card depending on how intensive the graphics are. You can disable Optimus in BIOS so the Nvidia chip is used all the time but your computer will use more battery and it will get hotter. So it's best to enable after game play.



#10 BenBenBenBe

BenBenBenBe
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:03:25 PM

Posted 01 March 2014 - 04:10 AM

Thanks for the reply.  Is there a more convenient way to disable/re-enable Optimus than to fiddle with the bios each time?



#11 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 7,129 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:08:25 PM

Posted 01 March 2014 - 06:07 PM

If you decide to change the settings in BIOS, this should be permanent until you change them again. Just select 'Save changes and exit' once you have changed your settings.

 

Chris Cosgrove






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users