Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Using a wired router without Internet through router ...


  • Please log in to reply
43 replies to this topic

#1 PBzeer

PBzeer

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where the boat is
  • Local time:02:06 AM

Posted 25 February 2014 - 06:57 PM

... won't let me connect to Internet through wifi.

 

FIrst off, I'm running two Win 7 pro laptops, one 32 bit, the other 64. I do not have access to a landline (on a boat). I intially set up my LAN by direct ethernet connection. This worked fine, except for the "unidentified network" hassle. Got a switch, but still unidentified network. Took the switch back and got a wired router. Solved the unidentified network problem, but it won't let me connect to the Internet by wifi (although I can connect to the wifi network).

 

I assume there must be some sort of conflict between the router assigned IP's and the WiFi assigned ones, since as soon as I unplug from the router, I have Internet. (Have no problem with Internet when directly connected)  When connected direct, I get 169.254.33.X autoconfig IP's for the LAN, with 192.168.1.X on the WiFi. When using the router, I get the 192.168.1.X for both LAN and WiFi.

 

I'd like to be able to use the router, as I have a third laptop I'd like to be able to occasional connect to the LAN, so I assume I have to use a static IP somewhere. Unfortunately, that's the limit of my knowledge. Any suggestions?



BC AdBot (Login to Remove)

 


m

#2 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:06 AM

Posted 25 February 2014 - 08:55 PM

I do not have access to a landline (on a boat). I intially set up my LAN by direct ethernet connection.

 

huh?


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#3 czarboom

czarboom

  • Members
  • 608 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Central Texas
  • Local time:01:06 AM

Posted 26 February 2014 - 01:54 AM

So let me get this right.

Your on a boat, and want to use your router to 1 direct connect to the internet, and 2. to access wifi when you dont want to do that. 

Got some questions.

  1. What are you pluggin your router into for incomming connection?  (not out going to your computers)
  2. Are you using a wifi P2p or Ad Hoc network?
  3. Depending on the router (need make and model) it could need to be configured, a software/firmware update, or other setting changed or enabled.  need more info
  4. You can try to set up your network.  Go into each computer and
    1. Go to Start and in the RUN box type CMD and hit enter
    2. then type ipconfig /release           then hit enter
    3. type inconfig /renew                     hit enter
    4. Does this work once all devices are done?
  5. Lastly just to be sure, are your WiFi settings on your computer on, and running.  Check the Wifi adapter settings by
    1. Right click in the bottom right on your wifi or network adapter icon, if none is there go to Start, control pannel, Network and Internet, Network and Sharing Center.
    2. In the top left side click on Change Adapter settings and under Wireless Network Connection right click and select connect, or enable if its Off/ grayed out.
    3. You might have to restart the laptop and your router before they will connect.  If you have to do this, unplug your router first, wait 1 min, plug in and wait for 30 sec, then turn on your computers.

Over all we need more info, such as router, type and model, and a detailed description of what your trying to do.  Such as.

I have a router that uses wifi its a Linksys E-xxxx (number here).  The incoming internet is from a ethernet cable, and I have 3 windows 7 laptops that I want to use wifi on.  Why do they not work, and what you have tried to do about it

 

good luck


CZARBOOM 
 
"Never Stop Asking Questions, Question Your Environment, Question Your Government, above all Question Yourself.  We all lose when you Stop asking Why?

#4 PBzeer

PBzeer
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where the boat is
  • Local time:02:06 AM

Posted 26 February 2014 - 04:33 AM

No, not using the router for Internet. There's no modem to attach it to. I'm using the router to create a home network that Win 7 can identify so it doesn't make it a public network by default.

 

Let me go back to the beginning ....

 

I connected my two laptops directly by ethernet cable to make a home network. This worked fine (including my WiFi internet connection), other than that Win 7 refuses to "identify" the home network, thus making it a public network by default. While I can change the location type to a private network (home), it still remains an unidentified network. Thus, any interruption to the network (shutdown, reboot, for instance) and I have to change the location type again, back to home. Windows keeps the home network unidentified because it says there is no valid IP.

 

That is the problem I got the router for (as well as possible future expansion to include an NAS). I tried a switch first, but that didn't solve the unidentified network problem.

 

The router solved the unidentified network problem, but in doing so, keeps me from making a WiFi internet connection (my only option for Internet). I can connect to the WiFi network, and it says I have Internet Access, but I can't connect to anything on the Web. If I unplug from the router, then I can access the Web. The only reason for this, that I can think of, is that the IP's the router assigns on the home network, conflict with the IP of the wireless connection.

 

In Setup 1 (direct cable connection) I have a wired home network and a wireless Internet connection. The LAN (home network) uses IP's of 169.254.33.X, while the WAN (WiFi) uses an IP of 192.168.1.X. Both networks work fine. (other than the unidentified network hassle)

 

In Setup 2 ( wired router, not wireless) both networks (LAN and WAN) use 192.168.1.X IP's. So I either have LAN, or WAN, but not both, as I do in Setup 1. (but the unidentified network hassle is solved). This indicates to me, an IP conflict between the LAN and WAN.

 

Logic says to assign the router a static IP of 169.254.33.X (X=0?), so that it assigns the two laptops IP's of 169.254.33.X (at least I assume it would assign them 169 IP's). What I don't know, are the ramifications of doing that, nor any other (default gateway, for instance) numbers I would need to assign.

 

Again, the router has no part in connecting to the Internet, through the router.



#5 czarboom

czarboom

  • Members
  • 608 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Central Texas
  • Local time:01:06 AM

Posted 26 February 2014 - 08:02 AM

ok,

So what you want to do it keep your LAN (local area network) as is, but be able to connect via WiFi and have those groups all work and talk to each other through Windows Home Group for file sharing etc.  No internet access at all, correct?. 

 

You keep saying in one connection configuration you can access the internet.

I can connect to the WiFi network, and it says I have Internet Access, but I can't connect to anything on the Web. If I unplug from the router, then I can access the Web.

 

 

But that you have nothing to plug the router into, no modem, phone line etc.  So where are you getting your internet from?

 

What I take away from this is that you want WAN (Wide area Network, e.g. the Internet) or outbound to the real world while having your LAN (computers inside your private network) still work and talk to each other.  Do you want those to have internet access as well... I assume not.  If so, then by plugging in your router, and hooking up each computer to it all device set to DHCP they will connect to the internet.  Then you can use password enabled file sharing to gab and push whatever you want. 

If you want a LAN and internet access then follow below.

 

So first off you got your IP structure wrong.  In a private network setup you cannot run 169.xxx.xxx.xxx IPs, these are not reserved for Private IP status.  There are only 3 types that can be used for that they are

192.168.x.x
172.16.x.x
10.x.x.x

Meaning in a normal modem, router, computer setup.  Your IP to the internet (this is the WAN side of your router) would be something like 168.111.123.112 (i made that up). 

But your internal Private IP (the LAN side of your router) would be a private IP.  Something like 192.168.1.212

 

Your router knows this and that could start your problem from the start.  So lets fix this by following the below steps.

 

networking 101. (using static IPs to configure a LAN and WAN with share)

 

First off are you trying to use DHCP?  If so we need to stop that on the computers BUT NOT on the Router.

Make sure that windows is managing your connections, and not a 3rd party application like RealTeck, or Dell wifi/lan etc.

Also check each device to make sure they all have the same system time, if not NO WORKGROUP will ever work.  In a static IP windows has no internet to set the time against.  Check years seconds etc.

 

Now lets configure your router.

go to your router's administration page and configure the built in DHCP server.

We will allow DHCP to do its job but limit the IPs allowed to be configured.  Ill do 20 but you can choose whatever you want

 

Router example

192.168.1.0 Subnet of 255.255.255.0

Router IP is 192.168.0.1 (the routers IP)

192.168.0.2 to .22 (this gives us 20 DHCP reserve IPs to use, you can change this to what fits your needed)

192.168.0.100 to 122 (this is the static IPs for our computers or whatever we want)

 

Go into your network adapter for each device your connecting and you need to manually set the network up.

The issue your having is when your add the router its not a WiFi conflict its a gateway issue/ DHCP issue

 

so I will use the private IP of 192.168.0.100 to 122 range for this (being that 192.168.x.x cannot be assigned to public IPs.)

Computer 1                                                                   Computer 2

IP 192.168.0.100                                                           IP 192.168.0.101

Subnet 255.255.255.0                                                    Subnet 255.255.255.0

Gateway 192.168.1.1                                                     Gateway 192.168.1.1

DNS 192.168.1.1                                                            DNS 192.168.1.1

 

After you did all of this, see if you can talk to each-other.

on each device, (not the router)

go to start, run,

type CMD

when the black screen starts type the following (this example is done from computer 1)

 

ipconfig /all

a list of network info will display, make sure your IP, DSN etc is correct.  Then type

ping 192.168.1.1

some text will run, you should see 4 packets sent 4 received.

then

ping 192.168.1.101

same thing here, it should send and receive. 4 of 4.  If not then something is not configured right.

then type

echo 192.168.1.101

it should return the same IP you typed.

 

Also make sure of the following issues that can mess this all up.

1.  Make sure windows firewall is either disabled or that you allow the IPs through your firewall on both computers and all devices.

2.  Disable antivirus when setting this up.

3.  After all is set and saved you might have to turn off both computers, and the router.  Plug back in the router, wait for it to boot up, then turn on your computers.

4.  Make sure your share center is sharing with your other devices, and done in Admin mode. 

 

If using a WiFi device this works the same, but you would configure the WiFi adapter on your Router the same way, and your device your using will need another IP for it.

 

So now to WAN, this is only for access to the internet.  If your looking for connecting your wireless devices you need to use wLAN setting in your router.  If your going out bound then (to the internet) with DHCP it will do it without your needing to configure.

But, if there is no internet your trying to get to then you need to go to the wireless or wLAN tab in your router,

and using the same private IP lists configure each WiFi adapter or device, using the same steps.

 

 

Let me know if this is what your talking about, because that is what I think you wanted.

 

Remember, LAN is you inside network, WAN is the internet, and wLAN is a wireless inside network, if you have a laptop with WiFi on it, you will need to configure both adapters.  Ethernet(gigabit controller) and your WiFi adapter.

 

If your not using your router to get internet, then how are you getting it if at all.


CZARBOOM 
 
"Never Stop Asking Questions, Question Your Environment, Question Your Government, above all Question Yourself.  We all lose when you Stop asking Why?

#6 PBzeer

PBzeer
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where the boat is
  • Local time:02:06 AM

Posted 26 February 2014 - 10:18 AM

I get Internet by connecting via the Atheros AR9002WB-1NG Wireless Network Adapter and the home network connection through the Atheros AR8152/8158 PCI-E Fast Ethernet Controller. I'm not trying to give both laptops the same Internet connection, merely using the Wifi on each one for it's own Internet connection.

 

In other words, the home network is by cable, the Internet is by wireless connection to the marina wifi access point (hot spot). The router is not used for, nor has no part in getting me Internet access (the WAN port on it is empty). This means I have two connections going (multiple networks on the Network and Sharing Center window).

 

 

Attached Files



#7 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:06 AM

Posted 26 February 2014 - 11:13 AM

Ok I understand now. I just didn't get wired but no wire to land lol.

 

Just change the IP address in the LAN settings on the router to:

 

192.168.2.1

255.255.255.0

 

and set the wired NICs to 192.168.2.3 and 192.168.2.4 It won't conflict with the WiFi addresses. And turn off the wireless portion of your router or people will try to connect to yours lol


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#8 PBzeer

PBzeer
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where the boat is
  • Local time:02:06 AM

Posted 26 February 2014 - 11:57 AM

So, it is an IP conflict that's blocking my Internet access when connected to the router? (And, it's a simple wired 4 port router, no wireless)



#9 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:06 AM

Posted 26 February 2014 - 12:31 PM

I believe so yes. If both routers give the same IP addresses then there will be a conflict. 

 

But I just thought of something, while you can use 169.254.x.x that may be the issue with the unidentified network. That group of IP addresses are used when a DHCP server can't be found. You could try the crossover cable with the 192.168.2.x addresses and see if it works. But either way, the IP addresses are conflicting. 


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#10 PBzeer

PBzeer
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where the boat is
  • Local time:02:06 AM

Posted 26 February 2014 - 01:25 PM

Well, I changed the LAN settings on the router, trying both your suggestion, and with the 169 range. Neither makes a difference. Still no wireless internet when connected to the router.



#11 PBzeer

PBzeer
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where the boat is
  • Local time:02:06 AM

Posted 26 February 2014 - 01:44 PM

Not only did it not solve the problem, now I can't get back in the router.


Edited by PBzeer, 26 February 2014 - 01:44 PM.


#12 PBzeer

PBzeer
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where the boat is
  • Local time:02:06 AM

Posted 26 February 2014 - 02:40 PM

Apparently, the router gateway takes precedence over the wireless gateway for access to the internet. Would it be possible to just disable the WAN port on the router?



#13 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:06 AM

Posted 26 February 2014 - 04:25 PM

what address are you using to get into the router?

 

why would anything be plugged into the WAN port? You use it to connect to a modem but you don't use a modem you use the wireless provided by the marina.

 

Is the DHCP server turned off in your router? 

 

I have never tried running both a wired and wireless network actively at the same time.

 

When you connect wired, you still have wifi connection or is it disabled? I know you said you lost internet but disabled is not the same as losing.

 

EDIT: in reading more about this the reason you got unidentified network with the crossover is because there was no default gateway set. I'd say go back to what worked and just make the DG on both PC's the other's IP address but you mention a NAS and another laptop so stick with the router.


Edited by CaveDweller2, 26 February 2014 - 05:16 PM.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#14 PBzeer

PBzeer
  • Topic Starter

  • Members
  • 22 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Where the boat is
  • Local time:02:06 AM

Posted 26 February 2014 - 06:12 PM

When Win 7 configures the home network between two directly connected computers, it doesn't assign a default gateway, a DNS server or WINS server, as there is no internet connection available through the home network. When I connect the home network through the router, or if I assign the necessary addresses manually when directly connected, as near as I can figure, having a default gateway on the home network prevents wireless internet access, as it wants to connect through the home network, rather than the wireless connection. So, although I can connect to the wifi network itself, that's where the connection ends. Basically, as near as I understand it, the internet can't "see" me.

 

WiFi, whether through the marina, or a cell company data plan, is the only internet option here. There are no phone lines for DSL, nor does our limited cable TV have an internet option. (I could get a dish, but that's a bit impractical for me)

 

It appears to me, that my particular problem is unsolvable. Without a default gateway, Win 7 evidently won't identify my home network, but, if I have a default gateway, then I can't access the internet through the wireless connection.

 

I appreciate the advice from CaveDweller and czarboom. Thank you for your time and effort.



#15 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:06 AM

Posted 26 February 2014 - 06:54 PM

Don't give up just yet.

 

Ok not being able to have your laptops plugged in AND getting wifi is normal for windows. But the fact it doesn't completely disable your wifi is not how it works by default. I am assuming that is what you meant by "So, although I can connect to the wifi network itself, that's where the connection ends. Basically, as near as I understand it, the internet can't "see" me." You get that when plugged in correct? What should happen is you plug in and your PC disables the wifi but won't reverse it when you unplug.

 

If you set the router's LAN IP address as 192.168.2.1 and leave the DHCP on, any thing plugged in will get a 192.168.2.X address and be on the same network. And that will be a different network than the 192.168.1.x you get from the marina's wifi. If it works for transferring files then you just need to unplug it to re-connect to the internet. That is assuming I'm right that your wifi doesn't get disabled.


Edited by CaveDweller2, 26 February 2014 - 06:54 PM.

Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users