Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Having problems with my WiFi


  • Please log in to reply
28 replies to this topic

#1 420Troll

420Troll

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 25 February 2014 - 12:13 AM

Im having problems with my WiFi and dont really know what to do. Im running windows 7 ultimate 64bit. And have a TP-Link WN722N USB Adapter. The problem Im having is anytime I try to download anything or try to stream a video my connection is dropped and I have to disable and re enable my WiFi adapter. I talked to TP Link and installed the driver they suggested and still have the same problems. This is my second adapter from them (RMA the first one) and now they want me to send this one back for yet another adapter. I dont want to keep wasting money on shipping when I think that its a problem on my end and not the adapter. Can anyone please help me with trouble shooting this problem to see if it is in fact a problem with the adapter or if its something wrong on my end? 

 

System specs

Motherboard, MSI FM2-A85XA-G65

CPU- AMD A10 6800K Quad-Core 4.4 GHz

Memory- Crucial Ballistix 2x4GB Tactical Tracer and Corsair XMS3 2x4GB

Power Unit- APEVIA Warlock Power 750W 


Edited by hamluis, 25 February 2014 - 01:33 PM.
Moved from Win 7 to Networking - Hamluis.


BC AdBot (Login to Remove)

 


#2 OldPhil

OldPhil

    Doppleganger


  • Members
  • 4,084 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island New York
  • Local time:04:10 AM

Posted 25 February 2014 - 04:13 AM

Could be an issue with your modem or router and not the adapter.


Honesty & Integrity Above All!


#3 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:03:10 AM

Posted 25 February 2014 - 02:52 PM

Could be the wireless radio built inside the router malfunctioning.It could also be your security scheme that you are using. I would disable wireless security temporarily to see if it helps. Also is there any other computer on the same wireless network? If so, is it experiencing the same problems?


"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#4 420Troll

420Troll
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 25 February 2014 - 04:00 PM

Thanks OldPhil and chrisd87 for your reply. chrisd87 I tried changing the security and still no improvement. It still keeps disconnecting my WiFi when I try to stream videos. And I have one other pc (well a friends laptop) that connects to my WiFi and when hes here and connects his pc has no problems what so ever.  



#5 OldPhil

OldPhil

    Doppleganger


  • Members
  • 4,084 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Long Island New York
  • Local time:04:10 AM

Posted 25 February 2014 - 04:14 PM

You could try flushing the DNS, sure can't hurt!

 

Click the Start button.

Enter cmd in the Start menu search field.

Right-click on Command Prompt and select Run as Administrator.

Type the following command and press Enter: ipconfig /flushdns

If the command was successful, you will see the following message:

Windows IP configuration successfully flushed the DNS Resolver Cache.

Edited by OldPhil, 25 February 2014 - 04:15 PM.

Honesty & Integrity Above All!


#6 420Troll

420Troll
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 25 February 2014 - 04:21 PM

@Oldphil did the DNS flush and still same problem.



#7 420Troll

420Troll
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 25 February 2014 - 04:30 PM

when I talked to the lady from TP-Link she had me open cmd and type "ipconfig /flushdns" and when that didnt seem to work she had me open the cmd and type "netsh int ip reset" and neither one seemed to have worked. 



#8 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:03:10 AM

Posted 25 February 2014 - 04:30 PM

Since your friend doesn't experience any issues, that eliminates the router. You could have him use your wireless adapter on his computer, and see if it disconnects him. You could try setting your DNS servers to use OpenDns and not your router. Set your primary to 208.67.222.222 and secondary to 208.67.220.220 and see if it helps.

 

Another command to try is to open command prompt and type netsh winsock reset


Edited by chrisd87, 25 February 2014 - 04:33 PM.

"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#9 420Troll

420Troll
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 25 February 2014 - 05:02 PM

@chrisd87 I wont be able to try my friends laptop until this weekend, but I will try that when I get the chance to. As for the "netsh winsock reset" command I just did that and reset. Now when I go to stream a video its not disconnecting my WiFi anymore but seems to loading it really slow. As for the changing to an OpenDns Im an idiot at all this and not to sure as to how to do that. Could you tell me a step by step way of doing this? And I just want to say thanks to you and Oldphil for all you help. I really appreciate it!!! 



#10 bwasi

bwasi

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:04:10 PM

Posted 25 February 2014 - 07:07 PM

I hv the sam issu with my TP Link Wireless adapter. yesterday after googling found this possible solution..

go to device manager

go to adapter - properties - right click properties - power managemnt - UNcheck save power

then go to Universal Composite Dev - USB Root Hub - right click - power - UnCHeck save power 

there are 2 USB roots.

Tell us the progress



#11 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:03:10 AM

Posted 25 February 2014 - 08:02 PM

1.Click Start-Control Panel

2. Go to Network and Sharing Center

3. Click change adapter settings on left

4. Find your wireless adapter and right click-properties

5.Find TCP/IPv4 and click it then choose properties.

6. Where is says Obtain DNS servers automatically, choose to use the following:

7. Enter 208.67.222.222 for primary-top one and 208.67.220.220 for secondary-bottom

8.Click ok then ok again.

9. See how your performance is.


"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#12 420Troll

420Troll
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 25 February 2014 - 08:58 PM

@bwasi I did what you said and unchecked the save power on the adapter but couldnt find "Universal Composite Dev" but I went into "Universal Serial Bus controllers" and found five not two "USB Root Hub" and unchecked the save power on those.

#13 420Troll

420Troll
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 25 February 2014 - 09:01 PM

@Chrisd87 I did what you said and changed the DNS servers.Now my internet is beyond slow. It is taking forever to load this page so I can send this reply

#14 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:03:10 AM

Posted 25 February 2014 - 09:04 PM

That shouldn't of slowed it down... This is starting to sound more like a driver issue.


"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#15 420Troll

420Troll
  • Topic Starter

  • Members
  • 13 posts
  • OFFLINE
  •  
  • Local time:04:10 AM

Posted 25 February 2014 - 09:15 PM

@chrisd87 Thats exactly what I have been thinking. When I talked to the lady from TP-Link she had me download and install the driver from Atheros web site and told me NOT to used the ones from there own site. Whic I found a little odd. But I have been installing so many different drivers for this could it be that while Ive uninstalled the other drivers to install a new driver something may have been corrupted preventing any new driver to be installed correctly?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users