Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Excel 2010~2003 to 2007 debacle


  • Please log in to reply
6 replies to this topic

#1 timmah33

timmah33

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:10:49 PM

Posted 24 February 2014 - 01:43 PM

    I have done this twice now, and still haven't figured out the resolution.  I have office 2003 installed on windows 7 pro machines. The users then try to open excel 2010 spreadsheets, and they wont open because they are not compatible. But there is an office 2007 patch. I know, I use it on all the desktops that have office 2003, but I forgot to in these two cases. 

  So once I have the problem corrected, I have the fix, and I wont do it again.

 

 The problem. The office 2003 .xls file wouldn't open. I decided the file association was missing so on the .xls excel spreadsheet I highlighted it then right click>Properites>change.

Then i go to Browse C>local disk>Program files (X86)>microsoft office>office 14>excel. The association is wrong. I have tried to uninstall office and re install, but that did not help at all. I realized after i did this that the office 2007 compatibility pack wasnt installed so i installed the patch, but that didn't help either.

 The problem is that the xls is trying to associate with the xlxs,... i think.

 

 I am basically trying to dis-associate the .xls with any program and start over. I thought that it might be a registry setting? I have no idea anymore. Any ideas? I can't be the only one who has ever done this?

 

Thank you in advance for any help you might be able to provide



BC AdBot (Login to Remove)

 


#2 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,428 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:04:49 AM

Posted 24 February 2014 - 08:37 PM

First of all, welcome to BC !

 

Try coming at your problem from a different direction. Go into Windows Explorer and pick on one of your Excel 2003 files - any one will do. In Windows Explorer RIGHT click on the name of this poor innocent file. In the menu that will open, click on 'Open with...', this will bring up the 'Open with' dialogue box.

 

In the centre of the box you will see an Excel icon. Do NOT click on this, instead click on 'Browse' at the bottom right hand side, and browse to excel.exe (Office 2003). The path is :- C:\Program files (or Program files(x86) if 64 bit systems)\MS Office\Office 11.

 

Office 2003 is listed as OFFICE 11. Here you will find an excel.exe file with the familiar icon beside it. Click on this to select it, then put a tick in the box on the other side of the 'Open with' dialogue box, the one that says 'Always use this to open files of this type'. You have just changed the attribute of all the Excel files in your system, and they should now all open in Excel 2003.

 

You are correct, you need the 2007 compatibility pack to open 2007 and later files in 2003, and there will be a pause of a few seconds while the software translates from .xlsx to .xls, but it always works for me.

 

Chris Cosgrove



#3 timmah33

timmah33
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:10:49 PM

Posted 26 February 2014 - 08:38 AM

That is what i did with the 2010 excel spreadsheet that was received through the users email. I saved it then did exactly as you said, right click on the office 2010 file then C>Program Files(x86)>Microsoft Office> Office11>excel. It does not work.

 

 I think the problem is that I tried to associate the excel 2010 file with office 2003 excel before i installed the compatibility pack, now it reads the 2010 wrong.

 

I then dissociated  the 2010 file with a program called Unassoc. This removes file associations that were created by the user, not by default, (pretty handy little program). The I uninstalled the 2007 compatibility pack and re-booted. 

 

 No i should have a clean slate?.? Maybe?

 

At restart i installed the compatibility pack and still nothing. The xlxs file still shows no default program to open it with.

 

Still not sure what the problem is. 

Thanks for all  the help so far Chris, I appreciate it.

Any ideas anyone?



#4 dls62

dls62

  • Members
  • 623 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Berkshire, UK
  • Local time:04:49 AM

Posted 26 February 2014 - 11:03 AM

Download Types and install it on one of the machines where the files open properly.

 

Run the program and select the file type .xls, then click on Properties (the gear icon).  Go through each of the tabs and note the settings.  Then do the same for .xlsx.

 

Now install Types on one of the machines where the files do not open correctly and check the .xls and .xlsx file types to ensure that they have the same settings, changing them where needed.

 

See if that solves the issue.



#5 timmah33

timmah33
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:10:49 PM

Posted 26 February 2014 - 11:50 AM

dls62, Going to try it right now. I will let you know the results.

Thanks again for the help



#6 timmah33

timmah33
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:10:49 PM

Posted 27 February 2014 - 01:55 PM

Thanks , I tried that, but it didnt work.

Im still trying to solve this problem and will keep you posted.

Thanks



#7 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,230 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:01:49 PM

Posted 27 February 2014 - 11:35 PM

You can try to do this by starting Excel from the Run dialog box on the Windows Start menu using the /regserver switch. Open the Run dialog, then enter

Excel.exe /regserver

and click OK. This causes Excel to set itself back to "factory defaults" on all levels. You may need to include the entire path to Excel:

"C:\Program Files\Microsoft Office\Office14\Excel.exe" /regserver

 

Of course, change the path to the correct value on your machine.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users