Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Desktop Gadgets gone


  • Please log in to reply
9 replies to this topic

#1 bludshot

bludshot

  • Members
  • 657 posts
  • OFFLINE
  •  
  • Local time:08:32 AM

Posted 22 February 2014 - 06:01 AM

I can't get my desktop gadgets to appear. They used to work, now they seem to be gone. When I try to add the clock back, nothing happens :|



BC AdBot (Login to Remove)

 


#2 bludshot

bludshot
  • Topic Starter

  • Members
  • 657 posts
  • OFFLINE
  •  
  • Local time:08:32 AM

Posted 22 February 2014 - 05:22 PM

Windows Sidebar is not even listed in start menu accessories. ?



#3 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,904 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:02:32 PM

Posted 22 February 2014 - 05:36 PM

Right click on a blank piece of desktop (ie, one with no icons) and towards the bottom of the menu that pops up you will see 'Gadgets'. Click on this, and a pop-up box full of the available gadgets will appear. Pick the one(s) you want, or even search on-line for more.

 

Chris Cosgrove



#4 bludshot

bludshot
  • Topic Starter

  • Members
  • 657 posts
  • OFFLINE
  •  
  • Local time:08:32 AM

Posted 22 February 2014 - 05:55 PM

I was doing that many times, but no gadgets would appear.

 

Turns out that internet explorer 11 broke the display of gadgets for anyone running higher DPI. If you run higher DPI than normal, the gadgets simply won't appear at all. Microsoft knows that it broke this, but they apparently don't care enough about people with vision problems, so they aren't fixing it.

 

This website has the solution: http://www.ghacks.net/2013/11/18/fix-gadget-display-issues-ie11-installation-windows-7/ which involves editing the gadget.xml file.

 

That will get the gadget to display again, but it won't obey the DPI setting. So now my legally blind friend gets a tiny clock...  gg MS

 

EDIT: I might try "CrossGL Clock", a free scalable clock program as a decent alternative. EDIT EDIT: meh, nah that clock is no good because since it's not a gadget, it disappears if you click on show desktop. I just stuck with the regular clock, and oh well, too bad if its smaller.


Edited by bludshot, 23 February 2014 - 12:15 AM.


#5 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 6,904 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:02:32 PM

Posted 23 February 2014 - 05:46 PM

I'm glad you have identified where the problem lies, even if you haven't 'fixed' it.

But you have me confused in one way. I would have thought that for someone who is visually handicapped you would want screen resolution set to a lower figure, rather than a higher one. After all, a higher dpi figure on the same size of screen makes things appear smaller. Or is this a misprint ?

Chris Cosgrove

#6 phil_carter

phil_carter

  • Banned Spammer
  • 8 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:32 AM

Posted 24 February 2014 - 06:59 AM

I had the same issue with my gadgets...I try many things to fix it and finally i re-install my PC :D It worked now all gadgets appear just fine :)



#7 petewills

petewills

  • Members
  • 1,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:02:32 PM

Posted 24 February 2014 - 08:27 AM

Default Windows 7 Gadgets
 
1. Open the Control Panel (category view), then click on Appearance & Personalization.
2. Click the 'Restore desktop gadgets installed with Windows' button 
3. This will bring up the Desktop Gadgets window with a message stating 
'All Windows and administrator installed gadgets have been restored'
4. When finished, just close the Desktop Gadgets and Control Panel windows.
 
To get them back, see Chris's Post#3.
 
You could try the MS Fixit 50907
 


#8 bludshot

bludshot
  • Topic Starter

  • Members
  • 657 posts
  • OFFLINE
  •  
  • Local time:08:32 AM

Posted 01 March 2014 - 07:52 AM

But you have me confused in one way. I would have thought that for someone who is visually handicapped you would want screen resolution set to a lower figure, rather than a higher one. After all, a higher dpi figure on the same size of screen makes things appear smaller. Or is this a misprint ?

 

I wasn't talking about changing the resolution, I was talking about Window's so called DPI settings. The best screen resolution even for someone with vision problems is the native resolution of the lcd. Then you just zoom in on things or make them bigger. That way they are still (usually) clear.

 

Here is the DPI setting screen, and I set mine to a "higher" setting of 150%. It's probably a misuse, or at least a convoluted use, of the term DPI, considering that the small and large text both have the same amount of dots per inch in terms of pixels and screen resolution...

253770d1360038932-dpi-display-size-setti



#9 bludshot

bludshot
  • Topic Starter

  • Members
  • 657 posts
  • OFFLINE
  •  
  • Local time:08:32 AM

Posted 01 March 2014 - 08:00 AM

@phil_carter, in this case reinstalling windows would not have fixed the problem (except in the sense that reinstalling windows would reset the custom DPI setting back to 100% and then the gadgets would appear again). But as soon as you put the DPI back to 150% they would disappear again because of the known issue with DPI and gadgets.

 

@petewills, hehe, come on pete you didn't even read my followup post apparently. Thanks though...   And that fixit will completely disable gadgets btw.



#10 petewills

petewills

  • Members
  • 1,378 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Birmingham, UK
  • Local time:02:32 PM

Posted 01 March 2014 - 08:18 AM

I read everything before I posted.  I didn't look at the link you gave, as it involved editing the gadget file and I had hoped that the general advice given would help.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users