Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Adaptors don't work with Windows 7 PCs ?


  • Please log in to reply
4 replies to this topic

#1 ecuyetx

ecuyetx

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:16 AM

Posted 20 February 2014 - 02:38 AM

I have now bought 4 different brands, D-Link, Netgear, Asus and TP-Link.
I have tried to install them (not all of them, but a combination) in 4 different PCs running Windows 7 and none of them work.
They all say there is a driver problem, and diagnosis says the Wireless Adaptor is experiencing problems.
Is it just me or is there a major problem with Windows 7 and USB Wireless Adaptors?

I am not unfamiliar with PCs or Wireless networking, and in at least one case the PC was fine with XP but under Windows 7 the adaptor did not work. It was a new adaptor.

I have been on many forums and have tried many solutions, including all the obvious like download the latest drivers but no joy.
There are lots of people who seem to post that they are having similar problems, but others seem to suggest they have got them to work. Well I would like to know how?

Any views or experience would be very much appreciated, I feel like a lone voice on the wilderness.

Tony E.



BC AdBot (Login to Remove)

 


#2 CaveDweller2

CaveDweller2

  • Members
  • 2,629 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:16 PM

Posted 20 February 2014 - 03:25 AM

What is the make and model of your PC? Did it come with Win7 on it? Do you have a link to these other people with the same problem?


Hope this helps thumbup.gif

Associate in Applied Science - Network Systems Management - Trident Technical College


#3 chrisd87

chrisd87

  • Members
  • 811 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:NC
  • Local time:09:16 PM

Posted 20 February 2014 - 11:19 AM

Depends on how old the adapters are and if they're certified to work in Windows 7.


"Like car accidents, most hardware problems are due to driver ɹoɹɹǝ."

 


#4 Chris Cosgrove

Chris Cosgrove

  • Moderator
  • 7,139 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Scotland
  • Local time:02:16 AM

Posted 22 February 2014 - 07:48 PM

The problem is usually the drivers for the adapters. I have Netgear adapter which I bought on the retailer's advice that it would work on 64 bit Win 7. It was about a year later that Netgear brought out a driver for 64 bit Win 7.

 

You best bet is to go to the manufacturers' web-sites and download the appropriate drivers, and make sure you are getting 32 or 64 bit as required. But having said that, due to stupidity on my part, I had to do a Windows re-install some time after I got the Netgear drivers and, without installing the dedicated drivers, it just worked straight out of the Windows driver collection !

 

Chris Cosgrove



#5 jhayz

jhayz

  • BC Advisor
  • 6,922 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:10:16 AM

Posted 23 February 2014 - 12:30 AM

Please post how you are installing these USB adapters exactly including the models next time.


Tekken
 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users