Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

SteelSeries Siberia frost v2 Playback issue


  • Please log in to reply
3 replies to this topic

#1 Klaved

Klaved

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:03 PM

Posted 18 February 2014 - 12:18 AM

I am having an issue where i hear in my headset everything that my mic picks up. I have unchecked the playback button in the microphone properties. I using windows 7 and am presumably using up to date drivers.



BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,541 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:03 PM

Posted 21 February 2014 - 03:00 PM

Uninstall the audio drivers (using Device Manager)...then reinstall them.  It doesn't matter if they are current or not...if they are damaged.  One way to tell is uninstall/reinstall.

 

Louis


Edited by hamluis, 21 February 2014 - 03:01 PM.


#3 Klaved

Klaved
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:07:03 PM

Posted 22 February 2014 - 08:30 PM

They are not damaged. I have uninstalled and reinstalled many times and it continues to happen.

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,541 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:03 PM

Posted 28 February 2014 - 12:19 PM

I'd say that you need to contact support, http://steelseries.com/support .

 

FWIW, see FAQ at http://steelseries.com/products/audio/steelseries-siberia-v2-frost-blue#faq .

 

Louis






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users