Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Computer looking at wrong hard drive on boot

  • Please log in to reply
1 reply to this topic

#1 DWatson


  • Members
  • 8 posts
  • Local time:07:52 PM

Posted 10 February 2014 - 04:35 AM

I have to switch the computer of at the mains. When i came to switch it back on i get an error bootmgr is missing, so i put the windows 7 dvd in drive and windows starts.


I have three hard drives two internal and 1 external, what the pc is doing is looking on the HDD that does not have Windows on (J = Disk 0) but windows is on (C = Disk 1).


How can i change these around so that i do not need the DVD in the drive all the time.


I think i can use Disk Management, but i have forget how to do this

BC AdBot (Login to Remove)


#2 dls62


  • Members
  • 623 posts
  • Gender:Male
  • Location:Berkshire, UK
  • Local time:08:52 PM

Posted 10 February 2014 - 05:21 AM

Start your computer and press F8 to access the Advanced Boot Options menu. Select Repair Your Computer.


Select the Command Prompt option.


Type bootrec /rebuildbcd and press Enter.


The scan should identify your correct Windows installation and you will be asked to Add installation to boot list?  Type Y and press Enter.


You should see the message The operation completed successfully.


Restart your computer.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users