Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Can't turn Laptop off. - Win auto restarts on shutdown


  • Please log in to reply
14 replies to this topic

#1 Skydie

Skydie

  • Members
  • 353 posts
  • OFFLINE
  •  
  • Local time:09:09 AM

Posted 03 February 2014 - 06:06 PM

Laptop Model : Asus N550JV

OS: Win 8.1 

 

 

Previously I shut down my laptop, win button + x -> shutdown, the laptop turns off and then reboots itself. I turned off 'automatically restart': http://www.pcworld.com/article/2050341/what-to-do-if-your-pc-shuts-down-and-automatically-reboots.html

 

Now the laptop doesn't turn off, screen goes past the 'Windows is shutting down' goes black and the power button (physical) remains lit - after 10 minutes. I've had no choice but to turn it off cold. I've also turned off 'fast boot' and changed the power settings so that shutdown means shutdown - not sleep. I've even reset the UEFI to default settings. The one thing I haven't done is set fast boot off on UEFI. 

 

Any ideas? Thanks. 

 



BC AdBot (Login to Remove)

 


#2 Netghost56

Netghost56

  • Members
  • 973 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:09 AM

Posted 04 February 2014 - 09:52 AM

Run powercfg /lastwake in the RUN window and it should tell you what is causing the reboot. It's mostly likely a driver issue, so I would make sure everything is up to date.



#3 Skydie

Skydie
  • Topic Starter

  • Members
  • 353 posts
  • OFFLINE
  •  
  • Local time:09:09 AM

Posted 04 February 2014 - 11:26 AM

Thanks for the reply Netghost. I did this and the message in CMD was 'Wake History County - 0'. 


Edited by Skydie, 04 February 2014 - 11:27 AM.


#4 Netghost56

Netghost56

  • Members
  • 973 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:09 AM

Posted 04 February 2014 - 01:12 PM

Hmm. Try this:

1. Open an elevated command prompt (run as Administrator).
2. At the command prompt type powercfg -lastwake and press ENTER.
3. If there is any wake history, your output may look like this:

Code:

Wake History Count - 1

Wake History [0]
              Wake Source Count - 1
              Wake Source [0]
                              Type: Device
                              Instance Path: USB\ROOT_HUB\<device instance ID>
                              Friendly Name:
                              Description: USB Root Hub
                              Manufacturer: <Standard USB Host Controller>


Here we can see that the last wake source was from a USB root hub. This is common when you wake the machine manually via the keyboard or mouse - as you are not waking the machine manually (why are you here again?), the culprit is likely a keyboard or mouse. Skip the next section below to find out which devices are "wake armed" and how to disable them from waking the system.

If your output reads Wake History Count - 0, continue below, but bare in mind that this can be a very tricky situation to diagnose. If your last wake source WAS NOT a hardware device, it could be a wake timer.

Determining which (and disabling) devices that are wake armed[/size]

In this section we can use another command to list all devices that are "wake armed". These are devices that have "Allow this device to wake the computer" enabled. If any of these devices are not behaving properly, they could be the culprit for waking your machine by itself.

1. Open an elevated command prompt (run as Administrator).
2. At the command prompt type powercfg -devicequery wake_armed and press ENTER.
3. Your output might be similar to this:

Code:

Realtek PCIe GBE Family Controller
Logitech HID-compliant G500 Gaming Mouse
HID Keyboard Device (011)


As you can see from my output I have three devices that are wake armed - my network interface, my mouse and my keyboard. Fortunately for me, these devices of mine are working as they should and do not wake my system up on their own will, but yours may not be so cooperative. For troubleshooting purposes I would recommend you disable every device in your list - you can do this by following the below:

1. Open an elevated command prompt (run as Administrator).
2. At the command prompt powercfg -devicedisablewake <DEVICE> and press ENTER. Replace <DEVICE> with the name of the device you obtained from the steps above.
3. Repeat Step 2 for each device from the list obtained above.

As a general measure, I like to disable any wake-on-LAN functionality from the BIOS (if such an option is present).

If you have an add-in network interface, you cannot configure this from your system BIOS - instead use the option ROM it presents during boot, or if none, some drivers (Intel Pro comes to mind) provide a Windows property sheet in device manager for the adapter to turn off certain functionality, one of which is generally wake-on-LAN.[/color]

 


Edited by Netghost56, 04 February 2014 - 01:14 PM.


#5 Skydie

Skydie
  • Topic Starter

  • Members
  • 353 posts
  • OFFLINE
  •  
  • Local time:09:09 AM

Posted 04 February 2014 - 07:06 PM

The only wake armed device I have is: HID-compliant mouse (001)

 

At cmd I typed: powercfg -devicedisablewake HID-compliant mouse (001) 

 

But I got an 'invalid parameters' message. 

 

 

EDIT: correct code was 

 

powercfg -devicedisablewake "HID-compliant mouse (001)"

 

used this website for the code http://www.sevenforums.com/tutorials/122027-devices-allow-prevent-wake-up-computer.html

 

Thanks again for the help. I'll see if the Laptop turns off ok now. 

 

EDIT 2: Just shut down to test if it would restart, unfortunately it did restart ;( 

 

EDIT 3: Some pages I've read suggest it's my 'Realtek PCIe GBE Family Controller'. However when I right click this in device manager there is no option to stop it waking my machine (no power management tab). 


Edited by Skydie, 04 February 2014 - 07:35 PM.


#6 Netghost56

Netghost56

  • Members
  • 973 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:09 AM

Posted 04 February 2014 - 07:53 PM

If you have the driver saved in a folder, say, on your desktop, you can try uninstalling it and testing that. If it doesn't work you can reinstall. And maybe check for a driver update online.

#7 Skydie

Skydie
  • Topic Starter

  • Members
  • 353 posts
  • OFFLINE
  •  
  • Local time:09:09 AM

Posted 05 February 2014 - 02:18 PM

If you have the driver saved in a folder, say, on your desktop, you can try uninstalling it and testing that. If it doesn't work you can reinstall. And maybe check for a driver update online.

 

Driver update for the network card? 

 

@Phil Yeh it's the only way for me to turn it off ;( 

 

 

EDIT: In the 'Advanced' tab I disabled 'Shutdown Wake-On-Lan' and Wake on magic packet. I didn't disable Wake on pattern match (no idea what that does). 


Edited by Skydie, 05 February 2014 - 02:30 PM.


#8 Netghost56

Netghost56

  • Members
  • 973 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:09 AM

Posted 05 February 2014 - 03:37 PM

 

"Wake On LAN" makes the system wake on the "magic packet".

The "Wake on pattern match" option instead checks for packets that matches the operating-system-specified patterns; for example, an ARP request for the computer's address, or a TCP connection attempt.

The default patterns on a Windows 7 system are:

  • magic packet
  • NetBIOS name query
  • TCPv4 SYN
  • TCPv6 SYN
  • IPv6 Neighbour Solicitation

 

Try disabling that too.



#9 Skydie

Skydie
  • Topic Starter

  • Members
  • 353 posts
  • OFFLINE
  •  
  • Local time:09:09 AM

Posted 06 February 2014 - 12:32 PM

 

 

"Wake On LAN" makes the system wake on the "magic packet".

The "Wake on pattern match" option instead checks for packets that matches the operating-system-specified patterns; for example, an ARP request for the computer's address, or a TCP connection attempt.

The default patterns on a Windows 7 system are:

  • magic packet
  • NetBIOS name query
  • TCPv4 SYN
  • TCPv6 SYN
  • IPv6 Neighbour Solicitation

 

Try disabling that too.

 

 

Disabled 'Wake on pattern match' and the computer still is restarting. 



#10 Netghost56

Netghost56

  • Members
  • 973 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:09 AM

Posted 06 February 2014 - 12:58 PM

Ok, at this point I would suggest you start a thread in "Am I infected?" Beyond a driver issue (assuming all your drivers are up to date) I would recommend unplugging the USB mouse and any other external device, and disconnecting from the internet and try powering off.



#11 Skydie

Skydie
  • Topic Starter

  • Members
  • 353 posts
  • OFFLINE
  •  
  • Local time:09:09 AM

Posted 06 February 2014 - 03:13 PM

Ok, at this point I would suggest you start a thread in "Am I infected?" Beyond a driver issue (assuming all your drivers are up to date) I would recommend unplugging the USB mouse and any other external device, and disconnecting from the internet and try powering off.

 

 

Have done that :( Thanks for your help Netghost really appreciate it. Catch 22 situation now, either infected and it'll be 'easy' to fix..or it's something else..



#12 AmgedIsmail

AmgedIsmail

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:10:09 AM

Posted 27 August 2014 - 07:29 PM

I have had this annoying problem with my Inspiron 15z 5523 laptop.

I have done normal "Shut down" operatio through Windows 8.1 and laptop sometimes restarts instead of shutting down.

 

And my laptop also hangs after Windows shuts down. (I noticed this happening when Windows shuts down while Display is turned off) See my detailed work...

 

Look at my screenshots below, I will describe in details what I have figured out but I hope what I have done didn't screw up my laptop.

5751.1.jpg

In this screenshot, I have turned off and turned on my laptop 35 times...

You'll notice a correct mark beside the number, that means the laptop shut down successfully.

For example, the first time, laptop shut down, (2) laptop shut down, (3) the third time, laptop shut down, etc... whereas the number marked by "x" that means laptop hanged on shut down...

Notice the title at the top I type on the board when "Screen is off" I mean by screen is off that I let Windows turn off the display after 1 minute,

Now I let Internet Download Manager turns off laptop after it finishes downloading, so it will turn off it while the screen (display) is turned off, so when the display is turned off, the 11th time, laptop hung on shut down, only power button and fan was running.... I have to hold the power button to shut it down..

Now, see when "Screen is not turned off" and when IDM finishes downloading and shuts down laptop, I tested this 22 times as in the picture and laptop shut down successfully.

6116.2.jpg

Now look at picture number 2,

I tested again when the "Display is turned off" and letting Internet download Manager turns off laptop when it finishes.

In the first time, laptop restarted instead of shutting down, the 7th time it restarted instead of shutting down, and in the 14th time laptop hung on shut down..

0028.3.jpg

I read through internet that I can disable "Wake on Magic Packet" in Device Manager > Wireless and Lan...

However, in the 17th time, laptop as well hang on shut down.

6355.4.jpg

Now, I set "Turn off the Display" to "Never" now the screen is not turned off, and when Internet Download Manager turns off the laptop, see, I tested this 30 times, laptop shut down successfully except for this in the 12th time it restarted instead of shutting down.

4666.5.jpg

I turned off laptop and turned it on 50 times this time but this time I didn't use IDM to turn it off nor I turn off the display, it is just normal shut down using the "Shut down" command in Windows 8.1

See in the picture, in the 12th, 32nd and 37th times, laptop restarted instead of shutting down...

Even the normal "Shut down" operation often causes windows to restart instead of shutting down and when Windows shuts down while display is turned off, it often hangs on shut down which can leads my CPU fan to wear out eventually if I am not using the laptop and sleeping that time...

However, I am still unsure if laptop only hangs on shut down when display is off or no as I can't test this anymore because I have turned off laptop and on about 200 times in a day just to test this...

However I am not going to "turn off display" if I am letting IDM to shut down windows when it finishes downloading, however it may restart Windows instead of shutting it down sometimes which is still a problem for me, if I am leaving laptop to download for about 10 hours and went to sleep say for 10 hours, the IDM restarted laptop so it will be 20 hours for laptop being on.... Do you think this is good for a system like mine???

Inspiron 15z 5523 i7-3537U????!!!!

And if you're going to say "DISABLE" "Turn on Fast startup" option.

I have already done that, however laptop still restarts sometimes instead of shutting down and hangs on a black screen sometimes when it shuts down when display is turned off (Not 100% sure, it may even does hang when display is not even turned off).

Look at this video, this is how laptop hangs after Windows Shuts down.

 

https://www.youtube.com/watch?v=hM5nF8jY_3I



#13 Netghost56

Netghost56

  • Members
  • 973 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Texas
  • Local time:03:09 AM

Posted 28 August 2014 - 08:29 AM

Based on your data (Nice logical approach!) I would assume either a Windows service is running and is having trouble disengaging (svchost), or perhaps your memory isn't always clearing for shutdown. Maybe even a spooling issue.



#14 Skydie

Skydie
  • Topic Starter

  • Members
  • 353 posts
  • OFFLINE
  •  
  • Local time:09:09 AM

Posted 28 August 2014 - 06:04 PM

I think my issue (which was eventually resolved - cheers Oh My!) was down to an 'Always on' USB port. Does your laptop have any of them? 



#15 pgardner

pgardner

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:09 AM

Posted 28 May 2015 - 09:15 AM

My laptop was having the same issue. When I went into properties for the realtek family controller and unchecked wake on lan and "only wake with magic packet" It would automatically recheck the magic packet option on its own. After I disabled this driver I have not had an issue with it automatically restarting on shutdown any more.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users