Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

AMD Radeon HD 6570


  • Please log in to reply
4 replies to this topic

#1 blackkcalb

blackkcalb

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA Okla.
  • Local time:02:58 AM

Posted 30 January 2014 - 09:51 AM

I got a new graphics card a monthe ago. It flickers dramatically especially when I am scrolling through Google+. The AMD Radeon HD 6570 has 2gb and runs on a HP Jasmine motherboard, 8g ram, the OS is Win7. I have checked the ground and have it plugged into the same power source and it still flickers. Does anyone have any other solutions?


Edited by hamluis, 30 January 2014 - 12:56 PM.
Moved from Win 7 to Internal Hardware - Hamluis.


BC AdBot (Login to Remove)

 


#2 zingo156

zingo156

  • BC Advisor
  • 3,333 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:58 AM

Posted 30 January 2014 - 02:17 PM

Install the newest driver from amd's website for the video card if you have not done this already: http://support.amd.com/en-us/download fill in the correct information and download/install.

 

(if you tell me your windows version I can get you a more direct link, I will need to know if it is 32 or 64 bit as well).

 

If you have installed the newest driver, make sure that your refresh settings in Hz match what the monitor is recommended to run at. Probably will be somehwere between 60Hz and 120Hz.


Edited by zingo156, 30 January 2014 - 02:18 PM.

If I am helping you with a problem and I have not responded within 48 hours please send me a PM.

#3 blackkcalb

blackkcalb
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA Okla.
  • Local time:02:58 AM

Posted 30 January 2014 - 07:16 PM

Running Win7 Home Premium 64bit. The refresh rate shows only 60Hz for monitor 2, the rest of the Hz are italic. Monitor 2 is VGA, Monitor 1 is HD 1080 which when not duplicated has many more Hz options. I have disabled Desktop Windows Manager Session Manager and AERO it seems to have cured it, however that should not be the way to cure.

I have downloaded the most current drivers I think, I will double check. I have tried adjusting the resolution to see if it would give me more Hz options, it did not.

Thanks I appreciatte your response.



#4 zingo156

zingo156

  • BC Advisor
  • 3,333 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:02:58 AM

Posted 31 January 2014 - 08:52 AM

This is the most current driver package link directly from amd: http://support.amd.com/en-us/download/desktop?os=Windows%207%20-%2064

 

Get the Catalyst Software Suite Download


If I am helping you with a problem and I have not responded within 48 hours please send me a PM.

#5 blackkcalb

blackkcalb
  • Topic Starter

  • Members
  • 26 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA Okla.
  • Local time:02:58 AM

Posted 31 January 2014 - 10:48 AM

I had the correct current driver, however I reinstalled it. The violent flicker is gone. I do appreciate all of you folks help. thanks






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users