Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

DirectX d3dx9_43.dll STILL not found after update


  • Please log in to reply
12 replies to this topic

#1 Pageajj10

Pageajj10

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:20 AM

Posted 30 January 2014 - 12:10 AM

Mod Edit:  Merged topics - Hamluis.

 

Hello all.  I'm on day 5 of my saga trying to get the Game Gray matter to work on one of my available computers.  Now I'm trying in VirtualBox running Windows XP home edition on my MacBook.

 

Everything goes fine with the installation, except when it asks to install DirectX, it fails to do so.  Fine.  I go into the disk, locate DXSETUP.exe, and receive this message:

 

"The procedure entry point DecodePointer could not be located in the dynamic link library KERNEL32.dll"

 

Hmmm...

 

No problem.  I know how to go online and update DirectX.  I head over to the official site, go through the DirectX 9.0 update process.  All goes smoothly!  Hooray, re-start, try to open game:

 

"This application has failed to start because d3dx9_43.dll was not found.  Re-installing the application may fix this problem."

 

I've googled around, and every d3d(variant).dll problem just says to update directx, which I've already done.  I've restarted the computer and reinstalled the game and directx several times to no avail.  There are various directx related files on the Gray Matter disc, INCLUDING d3dx9_43.dll, but my computer knowledge doesn't stretch to what I should actually do with it to make the game work.

 

Please help, internet!  You're my only hope!

 

Ari J.


Edited by hamluis, 30 January 2014 - 04:43 PM.


BC AdBot (Login to Remove)

 


#2 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,230 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:04:20 PM

Posted 30 January 2014 - 12:54 AM

which service pack are you running?



#3 Anshad Edavana

Anshad Edavana

  • BC Advisor
  • 2,805 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:11:50 AM

Posted 30 January 2014 - 01:09 AM

Hi

 

Most probably you should install Direct X Runtime - June 2010 from the below link.

 

http://www.microsoft.com/en-in/download/details.aspx?id=8109

 

The setup will extract to a blank folder first. Open the folder and run DXSETUP to run the update.



#4 Pageajj10

Pageajj10
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:20 AM

Posted 30 January 2014 - 02:10 PM

which service pack are you running?

Aaaaaaaand a whole 'nother problem.  I have no service pack at all, but when I try to download SP1a (so I can then update to SP3), it says "the server did not respond." I've tried to find a standalone version, so far no luck.

 

Hi

 

Most probably you should install Direct X Runtime - June 2010 from the below link.

 

http://www.microsoft.com/en-in/download/details.aspx?id=8109

 

The setup will extract to a blank folder first. Open the folder and run DXSETUP to run the update.

I may not have made myself clear... I've ALREADY done this, still getting the missing d3dx9 message.


Edited by Pageajj10, 30 January 2014 - 02:10 PM.


#5 Pageajj10

Pageajj10
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:20 AM

Posted 30 January 2014 - 02:15 PM

I'm trying to set up windows XP to use on my MacBook, but I'm running into a whole host of problems getting it updated (my windows version is from an old computer, the disc is pre-service packs).

 

Trying to update everything, the windows.com/microsoft websites keep re-routing me to a "time to upgrade your browser" page.  Fine.

 

I click the download button on the page (to get explorer 8), run the .exe, only to have it freeze halfway through the process and give me this message:

 

"The procedure entry point SHRegGetValueW could not be located in the dynamic link library SHLWAPI.dll"

 

Ideas?


Edited by hamluis, 30 January 2014 - 04:43 PM.
Merged topics - Hamluis.


#6 hamluis

hamluis

    Moderator


  • Moderator
  • 55,554 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:01:20 AM

Posted 30 January 2014 - 03:58 PM

I would download/install SP1 first...then download/install SP3.  You don't need Windows Update to do this, just download and install from your desktop.

 

http://www.microsoft.com/en-us/download/details.aspx?id=19751

 

http://www.microsoft.com/en-us/download/details.aspx?id=24

 

After these two are installed...go to Windows Update and install all critical updates available...only critical updates.

 

Louis



#7 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,230 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:04:20 PM

Posted 30 January 2014 - 04:21 PM

download the service packs as an ISO/executable and install. you need SP2 for that driver to work correctly.

 

edit: you could try brute forcing it, and just copy the dll file from the disk to the system32 folder, might work....


Edited by TsVk!, 30 January 2014 - 04:22 PM.


#8 Pageajj10

Pageajj10
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:20 AM

Posted 30 January 2014 - 07:45 PM

Okay, update:

 

I've now managed to update all the way to Service Pack 3 (eventually found a full, standalone version of 1a, and then the update to 3 worked fine).

 

However, my original problem has not been solved.  After updating to SP3 and updating directx, I now get this message when I try to run Gray Matter:

 

"Config.exe - Application Error

 

The application failed to initialize properly (0xc0000135), Click on OK to terminate the application."

 

Is this still a directx problem?  What other steps might help?



#9 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,230 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:04:20 PM

Posted 30 January 2014 - 07:48 PM

you need to install the .NET framework from: http://www.microsoft.com/en-us/download/details.aspx?id=21


Edited by TsVk!, 30 January 2014 - 07:50 PM.


#10 Pageajj10

Pageajj10
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:20 AM

Posted 30 January 2014 - 08:50 PM

Alright, thanks guys!  Definitely getting closer :)

 

Installed .NET 3.5, now the program actually opens to its config screen.  First it gives me this message:

 

When I run the program now, I get this message:

 

"Unhandled exception has occurred in your application.  If you click continue, the application will ignore this error and attempt to continue.  If you click Quit, the application will close immediately.

 

Could not load file or assembly "Microsoft.DirectX.Direct3D, 

Version=1.0.2902.0, Culture=neutral,

PublicKeyToken=31bf3856ad364e35' or one of its dependencies.  The system cannot find the file specified."

 

If I press Continue, config opens (hooray! Farthest I've gotten so far), but all the selection dropdown menus are empty.  Some are simply blank (language and Display), some have options (Effects, Rendering, and Quality).  If I select one of the options (set shadows to "low" for example), I get this message:

 

"Unhandled exception has occurred in your application.  If you click continue, the application will ignore this error and attempt to continue.  If you click Quit, the application will close immediately.

 

InvalidArgument=Value of '0' is not valid for 'SelectedIndex'.

Parameter name: SelectedIndex."

 

Then, if I click 'save' nothing happens; if I click 'save and Run Gray Matter, it returns to the first error message (the one with PublicKeyToken etc.).

 

Making progress!



#11 Anshad Edavana

Anshad Edavana

  • BC Advisor
  • 2,805 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:India
  • Local time:11:50 AM

Posted 31 January 2014 - 06:43 AM

 

 

I may not have made myself clear... I've ALREADY done this, still getting the missing d3dx9 message.

 

If you run the DirectX web update, it is not going to update all DirectX components. Only DirectX setup which updates all DirectX components including 9, 10 and 11 is only the "June 2010" offline installer from my previous post. If you already downloaded and installed the Direct X Runtime - June 2010 offline setup,  please ignore this post.



#12 TsVk!

TsVk!

    penguin farmer


  • Members
  • 6,230 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:The Antipodes
  • Local time:04:20 PM

Posted 31 January 2014 - 06:56 AM

yup, now the directx installer/updater.....



#13 Pageajj10

Pageajj10
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:01:20 AM

Posted 31 January 2014 - 01:38 PM

I don't

 

 

 

 

I may not have made myself clear... I've ALREADY done this, still getting the missing d3dx9 message.

 

If you run the DirectX web update, it is not going to update all DirectX components. Only DirectX setup which updates all DirectX components including 9, 10 and 11 is only the "June 2010" offline installer from my previous post. If you already downloaded and installed the Direct X Runtime - June 2010 offline setup,  please ignore this post.

 

I'm confused... do I need to do something beyond running the DxSETUP.exe?  When I run the one included with the game disc (as opposed to the one I downloaded from microsoft), the config program seems to open normally (all dropdowns are populated), but when I save the configuration and try to run the game, I get a "game.exe has encountered a problem and needs to close" error.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users