Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Gioteck RT-2 Real Triggers


  • Please log in to reply
1 reply to this topic

#1 sn0zb0z

sn0zb0z

  • Members
  • 253 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:UK
  • Local time:08:38 PM

Posted 25 January 2014 - 08:42 AM

Hi.

I have some Gioteck RT-2 Real Triggers but I can't seem to clip them on to my (official) PS3 controller.

The diagram shows the triggers being pushed up and clipping on. The official website says "Simple Installation. Just clip on and go!" The only explanation of how to put them on is just clip them on and I've even watched a video where a guy just clipped it on in a second. No problems.

Mine, however, will not just clip on. I've tried pushing the trigger on at different angles, just pushing it on straight on with angling it like it shows. Tried both triggers on both buttons and neither will go on. I gave it to someone else to look at and they had the same problem.

I have noticed that on the back the triggers have a small plastic bit on them which appears to be stopping the trigger pushing on - is that meant to be there? It is a small plastic triangle which starts at the base and goes up to about half way and it goes all the way to the back of the trigger.

Am I doing something wrong or is it the triggers?

Thanks.



BC AdBot (Login to Remove)

 


#2 sn0zb0z

sn0zb0z
  • Topic Starter

  • Members
  • 253 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:UK
  • Local time:08:38 PM

Posted 25 January 2014 - 08:59 AM

Managed to do it at last but it didn't clip very easily. Certainly nowhere near as easily as suggested or the video I saw. Not sure why...






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users