Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

This is relating to LEMMIWINKS post (renamed processes, services, redirects)


  • This topic is locked This topic is locked
2 replies to this topic

#1 sparaz

sparaz

  • Members
  • 1 posts
  • OFFLINE
  •  

Posted 21 January 2014 - 02:24 PM


This post is for the assistant not for the original poster, I Just need to give you some info.  I run a web server business and I've been a sys admin for over in the past for 50+ workstations so I am qualified to at least inform you.
 
I just dealt with this issue all weekend.  It is the best I've seen.  I haven't finished it yet cause it was a pain...  First off, it's very hard to tell where this demon is hiding.  It infected two systems on my internal network somehow and on the laptop it flashed the BIOS with a modified version based on the Intel customizable boot logo utility.  On that system it installed network drivers, webcam drivers, a vnc service into the firmware of the laptop.  The laptop will now ALWAYS be in standby mode if the power is plugged in. 
 
It has changed BIOS code line execution to "extreme" priority and allowed a VPN bypass port for WOL execution.  They can boot up my laptop with a  VPN pass-through and see the webcam stream using hardware/firmware and a VPN pass through on a router.  On the computer it runs a script on initiation that will create a WMI modification of the ASSOC roles/classes.  It literally removed the "SYSTEM" association and added 7 other types of defaults.  The administrator role in WMIC is not there and the ASSOC changes of every area means that namespace's and roles are worthless without a fix.  Additionally it attached a VNC service, a web server, and a custom SQL interpreter for XML onto my file system (random locations have the actual web server files).
 
in system32 there is a ApplicationPatch directory (or some variation) that runs a script that causes every associated filename on the system to modify behavior and run some form of hidden redirect...  I found out the hard way, that the more you fight it the more it takes control.  It establishes a number of %application%.exe.mui files around your system so that when you load cmd.com, taskmgr.exe, services.exe, etc etc...  it will initiate a console host command and fulfill more code. It installs a COMPLETELY BELIEVABLE fake Norton (in my case), and fake windows upgrade/defender program so that when you run a recovery or anything similar (including windows update) it will tell the user some very sophisticated stuff and it sounds believably like Microsoft but when you run it just downloads more files into your system.
 
It also uses chrome, internet explorer, and the entire NetBIOS and net system to implement a DNS server on your computer which modifies IP Addresses remotely and allows for remote execution of service and authority modifications.  It attaches a remote process call service dependency to almost every single service running.  basically the entire windows system becomes bloated with modified files usually contains only one of two exact same dates, those dates are associated with the XML script that it runs.  It will utilize chrome extension to do even more damage.  If you try to run windows recovery (at least once its deep enough) it WILL delete your partition. 
 
Its either deep in the MBR, or its literally in the BIOS.  It might take a CMOS battery reset to remove it, I haven't tried yet.  But to give you an idea, I tried Norton power eraser, and even when I boot into a CD it manages to replicate itself from the uncounted and driverless hard drive O/S partition and install itself onto the RAMDISK that Norton was using.  Norton's "CD" cmd prompt root kit fixer looked exactly like my windows install in terms of obvious signs of successful replication, and it managed to get itself into the network service of Norton's bootable power eraser and package itself into tcp packets that were sent requesting the updated definition files. 
 
I haven't been able to get rid of it through boot disks, recovery software, or anything else... and I am normally very skilled at executing a clever WMIC -script solution or manual console recovery..
 
Be warned it finally got "mad" and deleted all my files on my boot system.  I recovered them last night onto an external using testdisk and managed to finally find the script file that it looks like it uses initially... I haven't had time to look discretely at it, but it is very very impressive work. 
 
Anyways, if you have an answer for this person, I'd love to hear it too.  Thought you should know all this stuff, his log file looks exactly like my configuration, but it's very clever at hiding from everything... most of nothing can detect it so far. I can't say he will have all the same symptoms, but he will definitely have some.  Mine seems to be something that happened piece by piece. without me knowing.
 
The dhcp, dns, web client, web server, vnc, and wlan, ip helper, and a number of other malicious services installed seems to allow it to very effectively transmit itself through my system and network with completely fabricated and legitimate seeming ports and network addresses.  So who knows how longs it been here.  Which is very scary...
 
There are more things it did to me, but I already wrote a lot.

BC AdBot (Login to Remove)

 


#2 HelpBot

HelpBot

    Bleepin' Binary Bot


  • Bots
  • 12,627 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:44 AM

Posted 26 January 2014 - 02:25 PM

Hello and welcome to Bleeping Computer!

I am HelpBot: an automated program designed to help the Bleeping Computer Staff better assist you! This message contains very important information, so please read through all of it before doing anything.

We apologize for the delay in responding to your request for help. Here at Bleeping Computer we get overwhelmed at times, and we are trying our best to keep up. Please note that your topic was not intentionally overlooked. Our mission is to help everyone in need, but sometimes it takes just a little longer to get to every request for help. No one is ignored here.

To help Bleeping Computer better assist you please perform the following steps:

***************************************************

step1.gif In order to continue receiving help at BleepingComputer.com, YOU MUST tell me if you still need help or if your issue has already been resolved on your own or through another resource! To tell me this, please click on the following link and follow the instructions there.

CLICK THIS LINK >>> http://www.bleepingcomputer.com/logreply/521590 <<< CLICK THIS LINK



If you no longer need help, then all you needed to do was the previous instructions of telling me so. You can skip the rest of this post. If you do need help please continue with Step 2 below.

***************************************************

step2.gifIf you still need help, I would like you to post a Reply to this topic (click the "Add Reply" button in the lower right hand of this page). In that reply, please include the following information:

  • If you have not done so already, include a clear description of the problems you're having, along with any steps you may have performed so far.
  • A new DDS log. For your convenience, you will find the instructions for generating these logs repeated at the bottom of this post.
    • Please do this even if you have previously posted logs for us.
    • If you were unable to produce the logs originally please try once more.
    • If you are unable to create a log please provide detailed information about your installed Windows Operating System including the Version, Edition and if it is a 32bit or a 64bit system.
    • If you are unsure about any of these characteristics just post what you can and we will guide you.
  • Please tell us if you have your original Windows CD/DVD available.
  • Upon completing the above steps and posting a reply, another staff member will review your topic and do their best to resolve your issues.

Thank you for your patience, and again sorry for the delay.

***************************************************

We need to see some information about what is happening in your machine. Please perform the following scan again:

  • Download DDS by sUBs from the following link if you no longer have it available and save it to your destop.

    DDS.com Download Link
  • Double click on the DDS icon, allow it to run.
  • A small box will open, with an explanation about the tool. No input is needed, the scan is running.
  • Notepad will open with the results.
  • Follow the instructions that pop up for posting the results.
  • Close the program window, and delete the program from your desktop.
Please note: You may have to disable any script protection running if the scan fails to run. After downloading the tool, disconnect from the internet and disable all antivirus protection. Run the scan, enable your A/V and reconnect to the internet.

Information on A/V control can be found HERE.

As I am just a silly little program running on the BleepingComputer.com servers, please do not send me private messages as I do not know how to read and reply to them! Thanks!

#3 HelpBot

HelpBot

    Bleepin' Binary Bot


  • Bots
  • 12,627 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:05:44 AM

Posted 31 January 2014 - 02:30 PM

Hello again!

I haven't heard from you in 5 days. Therefore, I am going to assume that you no longer need our help, and close this topic.

If you do still need help, please send a Private Message to any Moderator within the next five days. Be sure to include a link to your topic in your Private Message.

Thank you for using Bleeping Computer, and have a great day!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users